Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register

USB flash drive issues

dark cloud

Active Member
Apr 14, 2018
2,021
2,273
BC
Okay, who is really good with this stuff? My music files on my 64 GB Lexar was working fine up until last month. Not sure if it was the latest update or my connection to the dash cam I installed that caused it to not work as well as it did, but more and more it won't show as USB on the touchscreen, and it just flashes quickly. I remove it and reinstall it and it shows loading up to 6%, and then nothing. Sometimes it loads fine, I play a song and then it shuts off and the USB cannot be found. I thought maybe I would reformat it again, would that help? here are the instructions I got from Teslatap:


Formatting with OS X

Open Finder, search for Disk Utility and select. On the left pane, select your flash drive. Be absolutely sure you’ve selected your flash drive and not the hard disk! Click Partition to identify the current format. If not “MS-DOS (FAT)”, click Erase. Select MS-DOS (FAT) as the format. Note that Apple makes it a bit confusing as “MS-DOS (FAT)” is really Windows FAT32. Click on the lower “Erase…” button, and a confirmation dialog appears. Click the Erase button and the format should begin.


The Teslatap instructions I followed above claims that the partition map should say MS-DOS-(fat) shown below, but I could not erase the flash drive Lexar, I could only erase the file Tesla tunes contained on the flash drive. Below it says MBR??

Here is what my MacBook says about it: does this look okay? Anyone else having issues lately?

Screen Shot 2019-01-27 at 4.56.32 PM.png
 

Krash

Data Technician
Apr 18, 2017
1,908
2,090
Intermountain US
My USB stopped being recognized around the same timeframe on MCU1 and an unactivated EAP 2.0. So in my case, unrelated to dashcam features. Hoping the fix is something easy.

UPDATE-my issue is unrelated, sorry for any confusion
 
Last edited by a moderator:

dark cloud

Active Member
Apr 14, 2018
2,021
2,273
BC
So I tried a different USB stick; a generic (no-name) 8 GB flash drive and today it worked flawlessly. So maybe my brand name flash drive (Lexar) is having issues and it is not the car.
 

migselv

Member
Jan 23, 2017
64
79
Denmark
I got a strange experience with my 64 GB Sandisk flash drive a few months back. Suddenly the drive would take much longer to be initialized by the car. At this point the drive would no longer be recognized by any Windows 7 or 10 PC I tried.
A few weeks later actual playback issues occured. Music would stop playing in the middle of a few songs, always at the exact same spot. Once this happened the drive became completely unplayable until it was ejected and reinserted. If you skipped the problematic song you would be fine.

I was ready to ditch the drive since it would no longer seem to work properly or could be repaired.
That is until I plugged it in on a Linux PC where it was recognized perfectly fine.
I chose to format the drive but using the ext4 file system.
The MCU runs Linux, so why wouldn’t it recognize a Linux fs?
And sure enough, the MCU reads the frash drive perfectly fine. After copying all song over again it has been performing flawlessly for a couple of months now.
 
  • Informative
Reactions: BridgeMojo

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top