Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.

"USB" voice command "can't open that service"

The "USB" voice command used to cause the USB player to play starting where it was when the car was last turned off.

However, now it just says "I can't open that service". Going to the USB screen and pressing one of the listed tracks starts playing it, so it is not like the actual USB stick is inaccessible. The USB stick with the audio tracks is plugged into a hub in the glovebox that the dashcam USB stick is also plugged into.

There was no software update in between when it was working and now. Software version is 2022.12.3.2.

What can fix this problem?
OK, so I got the feedback and repair instructions below from Tesla tech here in the UK. Haven't tried it yet, so usual at your own risk warnings if you have a go - I'll do it when I get home later.

Hi Paul, my name is xxxx and I am the remote diagnostic technician looking into your USB concern. I believe the Dashcam USB is corrupted and needs reformatting. I will send instructions to do this in another message. Could you please remove the USB device from the vehicle and carry out a scroll wheel reset. Once the vehicle has woken, please carry out the USB voice command and let me know if this works. Please do this with the Dashcam USB disconnected. Please also try other voice commands like "Play Radio...", "Navigate to...." etc and let me know if these work. Lastly, if you find that after formatting the device still shows as having no Dashcam, there is a firmware bug that is present that may be causing this issue too and will be resolved in an upcoming firmware package. Let me know how you get on, Regards, xxxx


FORMATTING USB - 1. Remove the USB from the vehicle. 2. Insert into a Laptop/PC 3. Format to FAT32 4. Create a file called 'TeslaCam' 5. Carry out a soft reset in the car 6. Insert USB in the glovebox USB port and test the system again but do NOT download any onboard Sentry footage incase it's corrupt.
OK, this instruction fixed the problem I was having with the dashcam. But the "USB" command still doesn't work. Tesla suggested this instead

"Change audio source to USB"

That works for me exactly the same as the "USB" command previously did.

Voice commands aren't interpreted by the car, they're transmitted to Tesla, interpreted and a command is returned from servers on Tesla's network to the car...so, somehow, the response to the "USB" command has changed and it's now not something the car understands.

So, how long till they change the response to this new voice command....
Tesla suggested this instead

"Change audio source to USB"

That works for me exactly the same as the "USB" command previously did.
Interesting... "change audio source to USB" now works. But it takes longer to say than "USB".

Of course, it would be better if the default when turning the car off and back on again is to keep the same audio source that was playing when the car was turned off.
Thank you Horatio Alger and Transformer for the info. Both of those commands still work on my Model X as of this morning (June 3 2022). In summery:

Voice "Switch to USB"
Voice "Change audio source to USB"

Voice "USB"

If course Tesla might be revamping the whole media center in patch 2022.16. But until they break something again ;) we, who live by USB unabridged audio books on long trips, are once again saved !!
Last edited:

Products we're discussing on TMC...

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.