Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register

v9 browser not working?

fsch

Member
Sep 21, 2015
151
177
Montreal, QC
Had the same problem since V9 update (browser not working at all) but last night I got the new update (42.2) and it now works, including with TeslaWaze. Strangely, this new version allows to display the radio/multimedia and a second app at the same time (rearview camera, phone, calendar) except the browser!
 

SpudLime

Active Member
Jun 10, 2018
1,424
2,454
Leesburg, Va
42.2 and I have to reboot for the browser to work. After I get out of the car and then get back in later, browser won’t work until I reboot again. I have submitted many bug reports.
 

viper2ko

Active Member
Aug 30, 2017
1,441
1,388
USA
42.2 and I have to reboot for the browser to work. After I get out of the car and then get back in later, browser won’t work until I reboot again. I have submitted many bug reports.

MCU2 or MCU1? Also this seems like it's isolated to S and X. Model 3 browser works flawless from what i've seen
 

David29

Supporting Member
Supporting Member
Aug 1, 2015
2,257
1,909
DEDHAM, MA
I so wanted to start a new thread entitled, "Holy Cow! My Browser Worked!"
But then I saw this thread and decided it was more appropriate to add a comment here.
Anyway, yesterday afternoon I was waiting in the cellphone lot at Boston's Logan Airport to hear from my spouse that she had landed. The plane was late so I wanted to check whether or not it had arrived while I was on my way to the airport. I pulled out my TMobile phone and looked for the JetBlue flight status page. I had 2 or 3 bars on my phone, but it seemed to be taking forever for the page to load.
Out of frustration, since I was just sitting there anyway, I started the car's browser and typed in the same search term. Before too long, the JetBlue page appeared! It was a bit difficult to tell if the flight search number panel was active or not, and I had to poke around a bit, but I put in the flight number, and in a few seconds got the flight status. The cellphone had still not responded (but did eventually respond, a minute or two later.)
I think that is one of the few times the car's browser has ever provided any useful results in the 3 years I have had the car, and certainly the first time it has even worked since I got v9.
In all honesty, I would probably not have been as impressed if the cellphone had performed normally. My guess is the TMobile network was just too busy, or that particular page was busy, since i was at an airport in bad weather with hundreds or thousands of people in the same vicinity probably all trying to do the same search.
But I was pleased to know the browser could actually deliver a result.
The screen clarity -- well, that is a different story. Not sure how much of that was the browser versus the JetBlue screen design.
My car is on 2018.39.6.
 
  • Like
Reactions: Sabre Man

whitex

Well-Known Member
Sep 30, 2015
6,703
8,041
Seattle area, WA
My MCU1 browser hasn't worked since v9, except for maybe 2 or 3 occasions. Any other time it just sits there with a blank screen. Has anyone reached out to service about this, rather than the usual hope and prayer strategy? My car is going to go out of warranty in few months, and since the browser is an official car feature I feel like they should fix it under warranty. If their software requires MCU2, fine, swap mine with MCU2, not my problem they chose to abandon MCU1 support and update my car with it. At the very least maybe log that the MCU is going bad, so if it was to fail completely after the warranty ends, I should get a free replacement since it was already bad under warranty.
 

whitex

Well-Known Member
Sep 30, 2015
6,703
8,041
Seattle area, WA
An update: somehow, after weeks of not working, the browser sprung to life today. Not sure how long it will last, but now no repro. It's frustrating. Maybe Tesla should rename themselves to Betabet. ;)
 

Paritosh Patel

New Member
Oct 12, 2018
3
0
Parkland, FL
For me, (MCU 2) not only does the browser rarely work, but the audio stops working at least once a week. Twice, so far, all sound did not work (including the noise of the directional signals)... creepy feeling

Once, I hard rebooted at a red light because it was too quiet :)
 

whitex

Well-Known Member
Sep 30, 2015
6,703
8,041
Seattle area, WA
For me, (MCU 2) not only does the browser rarely work, but the audio stops working at least once a week. Twice, so far, all sound did not work (including the noise of the directional signals)... creepy feeling

Once, I hard rebooted at a red light because it was too quiet :)
Yea, my wife tells me her MCU2 screeches at her sometimes instead of making blinker noises. Tesla should change their name to "BetaBet".
 

cfwiggum

Member
Oct 25, 2018
12
5
SF Bay Area
When my MCU1 browser gets "stuck" I can usually bring it back to life by loading a favorite. Even then, it seems to only be able to load an initial url. Any further navigation within the page fails way more often than not. This gets worse when there is no visual feedback that it actually registered the link you tapped. Sometimes I think it's hung when it actually just wants MINUTES to load a lightweight page.

I think there are multiple things at play for why the browser is so terrible.

Oh, one thing I've grown to hate is when trying to swipe it to full screen, I almost always end up hitting the url bar itself which brings up the keyboard. Am I the only one?
 

controller

Model S 90D 2016 facelift AP1
Jun 4, 2017
15
18
Helsinki, Finland
European MS 2016 AP1 facelift here. After v9 was installed couple of weeks ago, the browser and Spotify went on strike. Both things don't work.

The TuneIn works with some glitches - sometimes not working for few hours and then come back online.

Tesla tried to diagnose the bug remotely and even pushed 42.3 to my car but it didn't help. And it looks like they just stopped trying to fix it...
 

Gentilly7

Member
Feb 16, 2014
188
58
US
Same problem here. I have MCU 1and browser works sporadically. I talked to Tesla about it and they said to delete map history locations one by one to free up memory. I have yet to try.
 
  • Informative
Reactions: Fiddler

Products we're discussing on TMC...

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top