Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register

[V9] How to Format USB into 2 Partitions for DashCam and Music [Windows]

Mishakim

Member
Apr 4, 2016
146
122
Boston, MA
Yes, you can do that. There are several small 2-port USB hubs on the market that will let you use 2 flash drives at the same time. I just wanted a cleaner solution.
To be clear, there are products actually called "USB splitter," and they will probably not work. You need a hub to get data from both drives. The things called splitters are passive devices that pass the data on one female socket, and only pass power on the other, so you can charge a phone, but you can't use both ports for data.
 

GPinzone

Member
Sep 3, 2018
319
170
Ronkonkoma, NY
To people still on Windows 7: Install the set of altenative drivers that will allow you to see both partition or try the Lexar tool that MIGHT convert your flash drive from removable to non-removable.
 

cbutters

Member
Jan 25, 2017
334
466
Utah
Since following this guide with GPT, I have never gotten the X on the dashcam; however I randomly will sometimes not get the dashcam icon AT ALL and my music USB won't show up. It happens about every 3rd time I drive the car. not sure why this could be. I might try a different drive. (using PNY 128GB currently)
 

xwang

Member
Jan 26, 2018
8
9
California
I have the 32G flash drive. I tried to follow the instructions on Windows 7, but it will not allow me to create the second partition. I researched it and it seems that windows 7 thinking USB drive is removable, not allow creating another partition on it. There is work around to change the driver, and I guess Windows 10 and later it is not a problem anymore.

I found out it is much easier to do it from command line on Apple Mac, using "diskutil"

Xins-MacBook-Pro:Downloads xwang$ diskutil list

/dev/disk0 (internal, physical):
....
/dev/disk1 (internal, virtual):
....
/dev/disk2 (external, physical):
#: TYPE NAME SIZE IDENTIFIER
0: GUID_partition_scheme *31.4 GB disk2
1: Microsoft Basic Data TESLA 31.4 GB disk2s1

Xins-MacBook-Pro:Downloads xwang$ sudo diskutil partitionDisk disk2 2 MBR MS-DOS TESLACAM 16G MS-DOS MUSIC R
Password:
Started partitioning on disk2
Unmounting disk
Creating the partition map
Waiting for partitions to activate
Formatting disk2s1 as MS-DOS (FAT) with name TESLACAM
512 bytes per physical sector
/dev/rdisk2s1: 31219472 sectors in 1951217 FAT32 clusters (8192 bytes/cluster)
bps=512 spc=16 res=32 nft=2 mid=0xf8 spt=32 hds=255 hid=2 drv=0x80 bsec=31250000 bspf=15244 rdcl=2 infs=1 bkbs=6
Mounting disk
Formatting disk2s2 as MS-DOS (FAT) with name MUSIC
512 bytes per physical sector
/dev/rdisk2s2: 30062288 sectors in 1878893 FAT32 clusters (8192 bytes/cluster)
bps=512 spc=16 res=32 nft=2 mid=0xf8 spt=32 hds=255 hid=31250003 drv=0x80 bsec=30091693 bspf=14679 rdcl=2 infs=1 bkbs=6
Mounting disk
Finished partitioning on disk2
/dev/disk2 (external, physical):
#: TYPE NAME SIZE IDENTIFIER
0: FDisk_partition_scheme *31.4 GB disk2
1: DOS_FAT_32 TESLACAM 16.0 GB disk2s1
2: DOS_FAT_32 MUSIC 15.4 GB disk2s2


This will wipe out everything from the drive and you need to start over by create "TeslaCam" directory on first partition, and copy music files to the second partition.
 

krazykanuck30

Member
Jun 28, 2018
44
40
Alberta, Canada
Followed the instructions. Created 8Gb cam partition. Lasted 2 days ( longer than before). Today I had to lock and unlock the car multiple times and the dashcam broke with the X.

Oh well, hopefully they did it next update.
 

animorph

Active Member
Apr 1, 2016
2,132
1,527
Scottsdale, AZ
I followed the instructions with a 128GB SanDisk Ultra Fit USB 3.1, creating a 32GB dashcam partition and an 80GB+ music partition. It worked for one drive before the grey X showed up. No magic bullet there.
 

h3ax2

New Member
Oct 5, 2018
1
7
Michigan
I realize the original post author intended this to be a general solution for Windows 7 thru 10, but please note:

As of Windows 10 "Creators Update" (version 1703, released in April 2017), Windows now has built-in support for multiple partitions on USB flash drives, and you no longer need to use a 3rd-party tool like fat32format.

Here are a couple links with examples:
Windows 10 Version 1703: USB Stick multi partition support | Born's Tech and Windows World
Windows 10 Creators Update allows multiple partitions on a USB drive
 

laudbrian

Member
Sep 5, 2018
74
64
Alameda, Ca
Sadly, this solution also only lasted a few days for me before I got the dreaded X earlier and I had to pull our the drive to repair it via Windows. I was urging other people having usb dashcam issues to use this write up in the groups I'm a part o,f which I don't regret because it's still the best one that has lasted longer than my other attempts with different drives, tools, etc.

Now that my Raspberry Pi Zero W has arrived I am going to attempt to build a Smart USB drive from a rPI.
One of my buddies just confirmed he has been using this solution for one WEEK now with no X issues with his smart usb drive. :D
The only con I see so far is that he has to leave climate control on for 15-20 minutes to allow time for the wireless upload of his Dashcam recordings.

The write up is in this GitHub which originated from this Reddit post.
From the Prerequisites before you consider it:

Assumptions
  • You park in range of your wireless network.
  • Your wireless network is configured with WPA2 PSK access.
  • You'll be archiving your dashcam clips to a Windows machine, and the Windows machine has a stable IP address on your home network.
  • You'll be setting up the Raspberry Pi using a Windows machine.
 
  • Like
Reactions: bhzmark

outie

Active Member
May 22, 2016
2,732
2,340
SoCal
FWIW I haven't had any issues with the dreaded X, but it might be because I'm using a 120GB M.2 2242 SSD with a USB3.0 to M.2 enclosure/case.
Seems like eventually one will get it sooner or later. I thought I was fine for whole week until today, my 3 got the X. I never unplugged it. My Model X got the X literally on the actual drive after putting in the USB minutes later. I am giving up and will just wait for Tesla to fix it up. I have a blackvue anyways on both cars.
 

brianman

Burrito Founder
Nov 10, 2011
17,518
2,980
I wanted to make sure that the default method of formatting was used, just in case DISKPART does something different. It probably doesn't, but I don't know that for sure.
I guess we use the word "default" differently. DISKPART is older.
 

Haggy

Member
Jun 19, 2014
188
31
Fremont
Windows 7 doesn’t recognize 2 drive letters for multi-partitioned usb drives. I think that didn’t become available until windows 10. I tried doing this on a windows 7 computer and it errors trying to create a second primary partition. I even tried using a third party app. It’s a no go unless you’re on windows 10 (no go for me anyway)

That's correct, Windows 7 won't let you give both partitions letters at the same time. You can do it under Windows 7. It's a bit of a pain, less so if you don't change your audio files very often and can live without seeing them every time.

I don't have a Window 7 machine with me now but I did it on Windows 7. I used EaseUS partition master for part of it and had to go back and forth from one partition to another before I had labels on both volumes, but by the time I was done, it worked fine. I left it with a drive letter for only the Teslacam partition, and when I looked at it later with a Mac, both partitions were visible.

If I need to look at it with Windows 7 and need to see the audio files, I should be able to use Windows to remove the drive letter and then put one on the other partition.
 

omgwtfbyobbq

Active Member
Aug 24, 2013
1,450
1,612
Southern California
That is an interesting setup. How long have you been using this and do you unplug often?
I've been using it about a week and I've only unplugged a few times.

Seems like eventually one will get it sooner or later. I thought I was fine for whole week until today, my 3 got the X. I never unplugged it. My Model X got the X literally on the actual drive after putting in the USB minutes later. I am giving up and will just wait for Tesla to fix it up. I have a blackvue anyways on both cars.
Now that I'm thinking about it, I might have gotten the X before, but I just rebooted the car and it went away. There might be something about unplugging the drive when the X is present that's causing drive corruption.

Edit - This is the drive I'm using.

ADATA 120GB m.2 2242 SSD (SATA)
 
Last edited:
  • Helpful
Reactions: laudbrian

EVnut

DARΞLL
Mar 24, 2009
1,587
1,217
Davis, CA
Just for a data point.... I was getting the X after about 30 minutes for the first few days of trying. My solution was to take the drive out and reformat it. It would then work again for another ~ 30 files. The last time it happened, I merely deleted all files. I did not format. I *also* plugged it into a USB 3.0 hub along with my music drive. And for four days (record!) it has worked every time. I haven't been brave enough to take it out and look at it. But I have many, many hours of driving on it now. So it should have a whole bunch of files. Does anybody yet know just how it overwrites the files eventually? We keep hearing about this "hour" but with 1-minute files, I can't believe that it clobbers 60 of them at a time. It'll be about 70 hours before mine is full (128 Gig)
 

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top