Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register

Vision Only Autopilot Not Calibrating

LoganNolag

Member
Mar 3, 2021
104
96
USA
I've driven my vision only Model Y for about 150 miles so far over the last week and it hasn't finished calibrating yet. The blue ring made it almost all the way around after about 20 miles but it got stuck at probably 95% - 98% and stayed there for the next 100.

I have an appointment to install the garage door opener on the 17th so when I contacted Tesla they said it wasn't normal and they said they would check it out then.

After reading some other threads I figured I would try and solve it myself so I soft reset the car and restarted the calibration now after about 30 miles it is back to about 95% - 98% and seems to be stuck again.

I have yet to take it on the highway could that be the cause of the issue? Although I have driven it on many large multilane roads. Does anyone have any suggestions?
 

TresLA

Member
Jul 15, 2018
146
171
L.A.
Do you have a longer trip to drive coming up soon? Maybe try hard rebooting (the one where you park for a couple hours at least and make sure sentry mode is off and no 3rd party apps waking up the car), then restarting calibration and going on a longer drive?
 

LoganNolag

Member
Mar 3, 2021
104
96
USA
Do you have a longer trip to drive coming up soon? Maybe try hard rebooting (the one where you park for a couple hours at least and make sure sentry mode is off and no 3rd party apps waking up the car), then restarting calibration and going on a longer drive?

No plans for a long drive anytime soon.
 

buyleonard

Member
Jan 4, 2020
68
85
Oregon
It will only calibrate with well defined lane lines on both sides of the car. Driving home from picking my car up, it calibrated to about 95%, and then stopped because the road at that point was 4 lane divided road, which meant neither lane on my side had lines on both sides of the lane. I had to go find a road with good lane markers on both sides before it would finish.
 

LoganNolag

Member
Mar 3, 2021
104
96
USA
It will only calibrate with well defined lane lines on both sides of the car. Driving home from picking my car up, it calibrated to about 95%, and then stopped because the road at that point was 4 lane divided road, which meant neither lane on my side had lines on both sides of the lane. I had to go find a road with good lane markers on both sides before it would finish.

Yeah that's what I heard. I drove for about 15 miles on a 6 lane divided road with ok lines but I guess it could be that that isn't good enough. I think I might have to take it on the highway but I've heard from some people that side roads are actually better.
 

buyleonard

Member
Jan 4, 2020
68
85
Oregon
I actually finished the calibration on the freeway. Drove south a few miles, took the exit, and the got back on going north. About 5 miles each way, then it finished.
 

danimal99

New Member
Apr 21, 2021
3
0
Austin
I had the same issue with mine last week. It ended up taking 234 miles, but I reset calibration at 150 with it being stuck around 98%. So after reset it was 84 miles.

I don’t think I needed to do the reset at all however. I had mainly been driving in suburbs and short stretches on a few bigger roadways. But after one night reading on the forums that you need to drive on a long, well-marked, straight road like a major highway or interstate I got up the next morning to do just that. I planned to drive to a different city and supercharge there, but I was barely out of my city on the interstate when AutoPilot started working.
 

LoganNolag

Member
Mar 3, 2021
104
96
USA
Took it on the highway this morning and it finished right away after maybe 5 miles. Looks like the vision only system really needs some highway driving to finish. Seems to work really well although I did get a side pillar camera obscured notice a couple of times on my drive back. I wonder if maybe there is something wrong with the camera and that is what was causing the delay.
 

ahoen117

Member
Jun 9, 2021
80
156
Western NC
Took it on the highway this morning and it finished right away after maybe 5 miles. Looks like the vision only system really needs some highway driving to finish. Seems to work really well although I did get a side pillar camera obscured notice a couple of times on my drive back. I wonder if maybe there is something wrong with the camera and that is what was causing the delay.
So, when I first picked up my car I had similar obstructed popups for my passenger side B pillar camera, mainly in low light, rain, or fog. As turned out they left the protective plastic on that pillar when I took delivery. It sounds silly, but may be worth checking.
 

LoganNolag

Member
Mar 3, 2021
104
96
USA
So, when I first picked up my car I had similar obstructed popups for my passenger side B pillar camera, mainly in low light, rain, or fog. As turned out they left the protective plastic on that pillar when I took delivery. It sounds silly, but may be worth checking.

I'll check it out tomorrow but I don't remember seeing anything. Regardless I haven't seen any other popups since the few just after it finished calibrating.
 

Products we're discussing on TMC...

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top