Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register

'Voice Commands' in latest 2020.4.1

My 2 cents: late 2014 model S (early auto-pilot capable). I've always used press & hold, speak, release.

After the update, "Navigate ..." (the only voice command I ever used) stopped working entirely - phrases usually not echoed on console, occasionally echoed parts, often incorrectly. Shouting seemed to help get phrases through, sometimes correctly. Did several resets, no change.

Found that pressing the Navigate button and then the microphone icon (on keyboard) worked to get phrases recognized without shouting. "Navigate home" and "Go home" still failed - phrases were correctly echoed, but I was offered a bunch of destination options that included 'Home' in the names. Only pressing the Home button worked properly.

Gave up, came inside, read a few more posts here and decided to try again. Using press & release then speak worked fine without needing to shout. "Navigate Home" echoed properly, but still failed as before. Tried a bunch of the new commands: seat heaters on & off, doors lock and unlock, inside lighting on and off all worked. Tried "Navigate home" and to my surprise, it worked correctly! There were no resets between when it was failing and when it started to work. Repeated "Navigate Home" and "Go Home" several times, all successful. (Somewhere in there, not sure where, I filled in the Work destination option, previously empty. Seems unlikely that had anything to do with the change.)

Oh, and press & hold works fine now.

So, did it re-learn my voice? Ghost in the machine?

"Any sufficiently advanced technology is indistinguishable from magic." - Arthur C. Clarke
 
  • Informative
Reactions: TexasDuke
I finally came back, I have the 2013 Model S. The momentary touch of the button, just long enough to make it go beep, and release works great. So now I drive down the highway telling the car 'temperature 67 degrees' and it does it. Told it something like 'turn air conditioner off' and it did. Then I told it to 'navigate home' which it did at which point I started to just give it nonsense commands.

So I'm happy. It wouldn't do a text but I rarely text anyway so that's nothing. It complained my phones OS was too old or something like that.
 
  • Like
Reactions: markn455

beatle

Active Member
Aug 31, 2019
1,277
757
Springfield, VA
I don't normally use them, but I wanted to experiment on the ride home and tried to see if I could turn on the heated steering wheel. I like the feature, but hate how it is buried in the HVAC menu and not available via the wheel itself or the controls at the bottom.

"Turn on heated steering wheel" yielded a "failure" but then I noticed the wheel was warming up. I tried "turn off heated steering wheel" and again it failed, but the wheel started cooling off. Strange.

FWIW, I have not had too many problems with voice commands like navigation or asking it to play songs. A reboot usually fixes things though.
 
  • Informative
Reactions: TexasDuke
My voice command is not working either.
From Tesla SC:
Hi Antwan! This is Tesla Virtual Service, this issue is currently under investigation and is expected to be fixed in Firmware 2020.8 . Currently we do not have an eta for that release yet. At this time I would like to go ahead and cancel the appointment. Thanks
Yep, I had the same response from Tesla service here in Brisbane Australia. By 2015 AP1 P90 D has had reasonable functionality of voice commands but after the latest update - nothing! After several reboots et cetera I rang the service centre and they said it was an issue with the voice command software turning off the microphone. Not sure if that's true, but I was told a software patch is being worked on to rectify the situation.

Very annoying to have good functionality, get a software update and its worse. Fingers crossed men, it won't be long to get an update.
 
Agree with the others. Worked well before the update. Useless now. I hope
Tesla pushes out another firmware update soon.
Don't think we need a firmware upgrade. At least in my case, what we have here is failure to communicate.

Previously: Press and hold voice-command button; issue command.
Now: Press and do not hold voice-command button; issue command.

Tesla just didn't tell us.

This really bugged me for a while -- thought my GPS gal didn't know my voice any longer.
 
  • Informative
Reactions: RDuke

David29

Active Member
Supporting Member
Aug 1, 2015
2,325
2,000
DEDHAM, MA
Right. I have had the new update for 2+ days and have tried several voice commands. the "Natural language" trick seems not to work, and the whole voice command system seems to shut down after using it a few times. Interpretation of what i have said seems worse than ever. I have tried about 10 times to do "bug reports," and it might have gotten all the way through with correct interpretation once.
Having said that, I have been using the old method of holding the button down. If indeed we are no longer supposed to (not mentioned in release notes), then all my comments may be because i was doing it wrong. i will test some more tomorrow....

Since I posted that, I have been able to initiate some voice commands, and I have been able to respond to text messages. I just click the Voice Command button and do not hold it down. So, that is a change. Voice interpretation is still imperfect, but to my pleasant surprise i was able to tell it to shut off a seat heater, and it worked!
 

Galinette

Member
Jan 2, 2018
257
240
Nantes
The speech to text part of the job is offloaded to a Tesla server and is not done by the MCU. So it’s totally plausible that it suddenly starts to work without rebooting or upgrading. It seems that the server is not scaled properly for the increase of vocal commands in 2020.4, so it became very unreliable. Your 3G/LTE connection may also have an impact. And yes, the navigate to command was totally messed up at last update.
 
  • Informative
Reactions: David29

AustinP

Active Member
Apr 6, 2015
1,402
1,132
Belgium
I came this week-end to believe it is MCU1 related. Most complains (ie useless - mine too) are from MCU1 owners, while MCU2 mostly are happy with it.
Guess we need to wait on next update :rolleyes:
A recent evaluation of this post of mine from last month led me to read it again.
There is a time to complain, what I obviously did and will do again, and a time to be thankful.
This time is the later one: commands working have grown over the weeks amazingly well.
For me, all voice capabilities from before the update work again but even better, as variants more natural are working too.
And the new commands work too, though not as well in French as in English yet.
This happened without any sw update.
So it looks like it’s all improving on the Tesla servers and they are indeed being worked on. Excellent !
 
  • Informative
Reactions: Gt1948

Products we're discussing on TMC...

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top