TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker and becoming a Supporting Member. For more info: Support TMC

Voice commands suddenly not working

Discussion in 'Model S' started by cab, May 22, 2018.

  1. cab

    cab Member

    Joined:
    Sep 5, 2013
    Messages:
    827
    Location:
    Grapevine, TX
    So a couple of weeks ago I had my car in the shop (drive unit) and in that time it got a couple of software updates. I am currently on 2018.16. Since I got it back I notice the voice commands almost never work "first try" and sometimes even beyond that. I might say "play xx" or "call yyy" and it just sits there as if it never hears the command (essentially like it is not uploading to the cloud for interpretation). It displays the message to "say commands like play x", etc. (or whatever that verbiage is).

    Anyway, has anyone experienced anything similar? I'm not sure if it is tied to the update or what.

    Thanks!
     
  2. TLej

    TLej Little-Known Member

    Joined:
    Dec 29, 2015
    Messages:
    356
    Location:
    Edmonton, Alberta, Canada
    Yes, it has happened to me. Today, in fact. The voice command button triggered the beep and the “listening” circle, but the car did not hear/recognize my instructions to phone a co-worker and I could not get it to stop listening with the voice command button. Eventually it got bored and timed out. First button press activated, second was unrecognized. I figured I must have had crummy cell reception, off in the boonies as I was. Tried it a couple of times and then just gave up and dialed from my contact list all old-school.
     
  3. David.85D

    David.85D Member

    Joined:
    Oct 29, 2016
    Messages:
    701
    Location:
    Maryland
    Me too. Seems to miss the button press to go to listening mode. Takes 2-3 tries now. Sigh
     
  4. Seattle Tom

    Seattle Tom Member

    Joined:
    Mar 31, 2016
    Messages:
    386
    Location:
    Seattle, WA
    Me three. We took a road trip last week so the car was getting lots of use with many voice commands for navigation. Easily 90%of the time, the voice command didn’t recognize on the first try...it took a few efforts. And during that time I had the same experience with the “listening circle” lighting up and then displaying a list of commands as suggestions, like it couldn’t hear me.

    I figured it was poor cell reception or perhaps a bug in the latest update that would self correct.

    EDIT: Didn’t notice this was the S forum before posting, but I figure this is not a seprate issue and could likely affect all models.
     
  5. pelargir

    pelargir Member

    Joined:
    Nov 2, 2017
    Messages:
    67
    Location:
    North Carolina
    Having the same problem here on a late 2017 MS running 2018.16 firmware.
     
  6. minderbinder

    minderbinder Member

    Joined:
    Oct 19, 2015
    Messages:
    101
    Location:
    Concord, MA
    Yep, add me to the list. I’m seeing the same behavior. I was also chalking it up to bad cell reception, but the thing is the audio streaming was working fine.

    And why doesn’t the second press cancel it? That’s clearly a bug.
     
  7. MorrisonHiker

    MorrisonHiker S 100D 2019.16.2

    Joined:
    Mar 8, 2015
    Messages:
    6,289
    Location:
    Colorado
    I'm having this same issue on 2018.14.2.
     
  8. brkaus

    brkaus Well-Known Member

    Joined:
    Jul 8, 2014
    Messages:
    5,156
    Location:
    Austin, TX
    I’m having the same on 2018.18.2.

    I *think* I figured out that if I talk louder it works. No scientific proof yet.
     
  9. Maxv

    Maxv Member

    Joined:
    Jun 4, 2017
    Messages:
    52
    Location:
    Boston
    I had the problem over the past few days but an MCU reboot (press both scroll buttons for 10s) resolved it completely.
     
  10. Reefdiver

    Reefdiver Member

    Joined:
    Aug 12, 2017
    Messages:
    30
    Location:
    West Palm Beach
    Same exact problem, was going to ask myself. Definitely began exactly after last software update 2018.18
     
  11. Scott_K

    Scott_K Member

    Joined:
    Jan 1, 2018
    Messages:
    89
    Location:
    Ottawa, Ontario
    I’ve also been seeing the problem only since 2018.18.

    MCU reboot unfortunately didn’t work for me :(
     
  12. P-town_P85

    P-town_P85 Member

    Joined:
    Aug 26, 2017
    Messages:
    62
    Location:
    Pleasanton, CA
    Do you have apple watches? I’ve started putting the watch in airplane mode and voice command works better and call quality (transmit) is improved.
     
  13. David_Cary

    David_Cary Member

    Joined:
    Dec 17, 2012
    Messages:
    773
    Location:
    Cary, NC
    Terrible since latest software updates. No apple products here.
     
  14. TSLA Pilot

    TSLA Pilot Member

    Joined:
    Mar 12, 2013
    Messages:
    717
    Location:
    United States
    Yes--same problem. Voice commands effectively inop now.

    Frustrating as it used to work quite well.
     
  15. minderbinder

    minderbinder Member

    Joined:
    Oct 19, 2015
    Messages:
    101
    Location:
    Concord, MA
    Did a reboot - now seems to be working. I wonder if it gets into a funny state at some point and then can’t get out of it.
     
  16. TSLA Pilot

    TSLA Pilot Member

    Joined:
    Mar 12, 2013
    Messages:
    717
    Location:
    United States
    Yeah, tried that; no impact. Will try again as it can't hurt.
     
  17. David29

    David29 Supporting Member

    Joined:
    Aug 1, 2015
    Messages:
    1,610
    Location:
    DEDHAM, MA
    I have been having a bit of similar trouble off and on, and had not connected it to my latest software update. But now that you (all) mention it, I think it has been more troublesome since the last update(s).
    I will try a reboot.
     
  18. David.85D

    David.85D Member

    Joined:
    Oct 29, 2016
    Messages:
    701
    Location:
    Maryland
    My Tesla is getting old and deaf? I thought I had to worry about battery degradation over time, not hearing loss!!
     
  19. Duffer

    Duffer TSLA Long

    Joined:
    Oct 19, 2017
    Messages:
    263
    Location:
    NorCal
    Your car isn't going deaf. It's lack of response is just part of the neural net/A.I. learning process. Your significant other doesn't listen to you why should your car? ;)
     
    • Funny x 1
  20. David.85D

    David.85D Member

    Joined:
    Oct 29, 2016
    Messages:
    701
    Location:
    Maryland
    I yelled at it today like it was my retired Marine neighbor. Seemed to understand me, except when I called it “gunny” :p
     

Share This Page

  • About Us

    Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.
  • Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


    SUPPORT TMC