Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register
  • We just completed a significant update, but we still have some fixes and adjustments to make. Please see this thread for more details and to find out how to revert to the old design. Cheers!

Walk up unlocking/phone start - all gone since app update

ticktock111

New Member
Sep 10, 2021
1
0
UK
Hi all,

I've tried searching for solutions to this or if anyone has had this happen, but I can't see many/any which has!

Since my app auto-update a week or so ago, my phone no longer unlocks the car as a walk up to/away from it.

Auto-start via phone Bluetooth also doesn't work.

Have tried disconnecting/reconnecting Bluetooth with no luck.

I now have to go into the app to manually unlock and start the car, often forgetting when I leave the car that it hasn't locked behind me.

Anyone else have/resolved this issue?

Iphone iOS 14.7.1
Tesla app 4.0.1 build 646
 
Upvote 0

phil4

Member
Sep 8, 2020
355
203
UK
I've had my car a year now.... when I first got it, it seemed whenever I had my phone on me, walking up/away worked and unlocked.

Then an update came along, and I suddenly needed to have the tesla app running... which then worked nicely. Indeed if you close the tesla app in the car it tells you that walk away lock is disabled. Sort of suggesting you need the tesla app open.

But then more recently... it's back to not needing it open, and just having the phone on me unlocks and locks just fine. There are a few moments when I go up to the car and it doesn't unlock, but give it a few seconds and it does.

So I've had it behave both ways, and never worked out what if anything changed. Good luck.
 

NewbieT

Active Member
Aug 16, 2019
1,258
879
North West
What car / firmware?

Tesla App is now 4.0.2 perhaps update manually in App Store. iPhone 14.8 is a highly recommended update due to zero day vulnerability.

Make sure the Tesla App still has permission to run in the background too.

Edit: also try deleting and re-adding the phone key in the car.
 
Last edited:

Alistairuk

Member
Jun 25, 2020
570
383
Scotland
I had the same happen 1 week ago after an app update on iPhone (first time it’s done it in a year of owning the car - I assume they’ve messed around with something in latest update of the app).

I just deleted the car key from the app, deleted the phone key from the car and re-paired it all from scratch and it’s worked since.
 

Products we're discussing on TMC...

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top