Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register
  • Want to remove ads? Register an account and login to see fewer ads, and become a Supporting Member to remove almost all ads.
  • The final cut of TMC Podcast #27 is available now with topics time-stamped. We discussed: Consolidation in LiDAR manufacturers; Volvo EX90 shipping with LiDAR; FSD Beta Full Release in N.A.; FSD detecting autopilot cheats, Gwen Shotwell directly overseeing SpaceX Starship; and more. You can watch it now on YouTube. We should have it published to podcast networks shortly.

Wall Charger drops from 40A to 20A

Orest

Member
Aug 13, 2022
8
12
MN
I got my MYP a couple weeks ago and noticed the last few times I charged it would start charging at 40/40A initially, but about 10-15 seconds after it reaches 40, it beeps and drops to 20/20A. No error message. The top light on the charger turns red when it drops to 20A, the bottom 4 are green. I've tried resetting the breaker (50A), still get the same issue. I had an electrician install the charger, it is the Tesla version 3 charger (I think? I got it in April, 2022.)

I tried searching, found a couple threads about the mobile charger having this issue but not the wall charger, so I figured I'd start a new one.

Let me know if you think this is a problem with the car, charger, or an electrical/wiring issue. It's a pretty simple install, my breaker box is in the garage so the electrician ran a wire (in conduit) up to the ceiling and across garage. I can ask him to come back to check it out, figured I'd ask the question here first.
 

Sophias_dad

Active Member
Supporting Member
Jul 29, 2018
2,446
2,863
Massachusetts
Sounds like a problem in the wall connector itself, or perhaps its connection to the input power lines.

What does the car report about the voltage initially, and as the current ramps up, and when it is cut to 20A.

What is the model number of the wall connector? If it ends with an -F, its likely bad, or bad enough you want it replaced anyway. They are under warranty for four years(!)
 
Could be the car, could be the wall connector. Could be the house wiring. And there's a setting in the charging screen that lets one set the charge rate based upon location.

First things first: You do have an error: That red light on the wall connector. That's a Gen 3 wall connector. I have a Gen 2, so can't answer or pose questions well, but my understanding is that the Gen 3 has a Web UI that one can get to from a PC's web browser. Get the error, fire up the web browser, and go looking for errors in there.

Just looked for Tesla Gen 3 Wall Connector Manual on Duck-duck go and got the link, direct from Tesla. Let's see, top LED is red. Looked in the troubleshooting session and we got three things:
1662946559157.png

The above looks like a fault in the Wall Connector. Number 2:
1662946611700.png

That sounds about right for what you've got going. And then, we got this:
1662946697022.png


All of which sounds very reasonable. Sounds like it's time to get the Commissioning Screen up, get a fault, and then go spelunking.

Next: It's possible that it's the car. The usual trick when something like this happens is to get the car to a Wall Connector somewhere else and try it. There'll be one to several at any Tesla Service Center; you can plug the car in there and verify that it works correctly.

But try the commissioning screen first. A red LED is a sure sign of something.
 
  • Helpful
Reactions: Rocky_H
I would check a few things.

1) Make sure that the breaker is not GFCI
2) For full power, the breaker should be 60 amp and not 50 amp. Not sure if the charger or car would know that it is undersized, but why not maximize the wall charger's capability?
3) Connect to the wall connector via wifi and check that the settings are correct.

You might want to connect your car to somebody else's wall connector. If it charges at full power on it then at least you can eliminate the car as the issue and focus your troubleshooting on the connector.
 

Orest

Member
Aug 13, 2022
8
12
MN
Thanks for the quick replies. So a little more info, what I described above happens over and over if I unplug and plug right back in after having not used the charger for a day or more. But after charging it for about an hour at 20A, when I unplug and plug in it stays at 40A. This is telling me it's likely not the car, but either the charger or wiring.

I watched the voltage, it's always around 240-246V, whether it stays at 40A or drops to 20A.

I will have to try commisioning screen it in a day or so as I can't replicate the error now while it's charging fine. It doesn't appear there is a log of past events/errors, the browser page is really quite simple.

I'll get back with what I find, thanks again for the replies. I'll also try swinging by a Tesla service center, I don't live too far from one before I call the electrician back.
 

Orest

Member
Aug 13, 2022
8
12
MN
Thanks Torch, it is not GFCI, and he did put in a 50 amp breaker. I didn't think to ask him when he was installing so while I would've preferred 60, it's not a big difference for me as I charge overnight. Everything appears set correctly in the commisioning procedure.
 

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top