TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker and becoming a Supporting Member. For more info: Support TMC
Start a Discussionhttps://teslamotorsclub.com/tmc/tags/

When do autopilot features begin to work on a new Tesla?

Discussion in 'Model S' started by Adam0617, Feb 17, 2017.

  1. Adam0617

    Adam0617 Member

    Joined:
    Dec 12, 2016
    Messages:
    11
    Location:
    Dallas, TX
    Picked up my MS 90d yesterday. HW2 running version 17.4.75. Have 104 miles driven so far. No autopilot features activated yet. What should I expect? Sorry if this is explained elsewhere. Thanks!
     
  2. croman

    croman Active Member

    Joined:
    Nov 21, 2016
    Messages:
    1,531
    Location:
    Chicago, IL
    17.4.75 is not reported in any firmware database. Could you perhaps post your firmware release notes?

    As far as availability of autopilot, presuming your build had it, your cameras need about 150 miles and one day to calibrate. It might take more maybe less depending on conditions of driving.
     
  3. bakchod87

    bakchod87 Member

    Joined:
    Sep 25, 2016
    Messages:
    73
    Location:
    Chicago
    I took delivery today of 90D with enhanced autopilot capability. I don't see autopilot like you do but it should be enabled soon. However, any idea about summon feature? Neither do I see it in the app nor does it get activated via the key fob ...
     
  4. oktane

    oktane Active Member

    Joined:
    Oct 25, 2016
    Messages:
    1,427
    Location:
    USA
    No intelligent features are activated yet other than adaptive cruise control up to 80MPH and autosteer up to 50MPH on major highways only. I think auto headlights might work but not auto wipers. I believe there is a side collision warning but it doesn't do much in my car. No forward collision prevention yet. There are many other threads on this. Good luck.
     
  5. tizio

    tizio Member

    Joined:
    Mar 26, 2017
    Messages:
    35
    Location:
    The Emerald City
    I just got my ap2 X yesterday. It is also running 17.4.75 and has no positive control features I've found.

    It said there was an update, but the message went away after it failed to complete last night.
     
  6. bob_p

    bob_p Active Member

    Joined:
    Apr 5, 2012
    Messages:
    1,649
    Our S 100D completed production in mid-February (with the 17.7.2 release installed) and spent a month in transport and waiting for the EPA hold before delivery. During that time, the 17.9.3 release was distributed, but was not installed in the car while Tesla had it at the Service Center.

    After delivery, I took the car back to the Service Center and after several hours, they were unable to get 17.9.3 to install and ordered a new processor module. When I got home, I did a "Power Off" and rebooted both the dashboard and console processors - and within an hour, my smartphone showed our S 100D had a new update available - and 17.9.3 installed successfully on the first try at home.

    It's not clear why 17.9.3 installed in our garage after Tesla was unable to get it to install at the Service Center. Getting it to install may have been due to the Power Off/reboot sequence I did at home or might have needed something Tesla did at the Service Center while trying to get it to install there.

    Yesterday afternoon, after returning home, I received a "software update available" message on my smartphone - and was able to install the 8.1 release on the first try. So whatever was preventing 17.9.3 from being installed appears to be cleared up now.

    If you have a new S/X and still running 17.7.2 or 17.9.3 and don't receive 8.1 in the next few days, I recommend trying the Power off/reboot sequence and if that doesn't work overnight, then contact Tesla's phone support for assistance.
     
  7. ncent

    ncent Member

    Joined:
    Nov 22, 2015
    Messages:
    57
    Location:
    Goldsboro, NC
    Probably a silly question, but have you activated it yet? I picked up my 100D and was wondering why my Autopilot was not working, but I had to turn it on! Felt sort of dumb. It is not on by default.
     
  8. tizio

    tizio Member

    Joined:
    Mar 26, 2017
    Messages:
    35
    Location:
    The Emerald City
    I took my X back to the service center for the wifi trick today and it worked! I asked one of the reps and she confirmed that my previous upgrade had failed and that my ride was currently downloading another update. I couldn't wait around all afternoon for the software to arrive, so I headed out and hoped for the best.

    When I got in that evening, it automatically installed a maps update without prompting. When I got home and connected to Wifi, it prompted me to install a bizarre system update that didn't change the version number or any features I could find. About 15 minutes later, it got another update which ended up being 8.1. I opted in to all the beta features and will take it for a spin in the morning!
     

Share This Page