Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register

White Washed Instrument Cluster (CID) - Failing?

Exiom

Member
Nov 29, 2017
206
105
Hong Kong
Hi,

So lately as I get into my car the CID is just black and the car unable to start while the MCU is fine.

It would come on after a minute or maybe more, or after some mashing of the 2 top buttons on the steering wheel in an attempt to restart it.

Once it comes on, the screen it completely white and then very very slowly, the screen returns to normal (30mins or so)

Is this normal? Prior to this, I have only ever had this happen once before after a long day in the sun, and now it seems to be happening almost daily.

Has this happened to anyone else? What causes it?

I am currently under warranty but just concerned that when I take it to Tesla, they will say it's not broken as it returns to normal after a while... but while it is black the car wont start which is also very concerning because I fear that complete failure seems inevitable and I'd be stuck needing a tow.

So I just want more understanding and be able to arm myself against whatever Tesla Service Center will say to brush me off...

I have attached some photos... it happens whether it is day or night...
 

Attachments

  • IMG_1935.jpg
    IMG_1935.jpg
    417.1 KB · Views: 27
  • IMG_6216.jpg
    IMG_6216.jpg
    398.7 KB · Views: 28
  • IMG_2432.jpg
    IMG_2432.jpg
    141.9 KB · Views: 27

random155

Member
Mar 18, 2019
876
451
NJ
I've never seen or heard of this happening before. I would think its a problem that should be replaced by Tesla if you still have a warranty.
 

Chaserr

Hyperactive Hyperdrive
Sep 5, 2017
2,664
5,591
Logan
I am currently under warranty but just concerned that when I take it to Tesla, they will say it's not broken as it returns to normal after a while... but while it is black the car wont start which is also very concerning because I fear that complete failure seems inevitable and I'd be stuck needing a tow.
They say that about everything now, but this looks like it's a warranty replacement thing. Replace it soon so you don't have to worry about getting towed.

When it happens, voice command "bookmark screen was off" or "bug report it wasn't working" - these will add markers in your car's logs for them to find the errors.
 

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top