TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker and becoming a Supporting Member. For more info: Support TMC

Windshield washer not working?

Discussion in 'Hong Kong' started by Titus, Oct 18, 2015.

  1. Titus

    Titus Member

    Joined:
    Sep 22, 2015
    Messages:
    213
    Location:
    Hong Kong SAR
    Anyone else had issues with their windshield washer? Just picked up my Model S last Friday (fantastic drive so far), one major thing is my windshield washer wasn't working.... I'd have thought they'd check this in the PDI. At first I whatsapped the sales/delivery team reps just FYIing them their team didn't add washer fluid to my car during delivery. Then when I tried to fill it up myself it was already full. So I Googled and there were posts about the washer taking a long time to load but I pressed the washer button (hard to the farthest) and I hear the washer motor whirring (maybe a bit of grinding??) for 1minute stop and repeat three times but still no washer fluid came out. Yet to hear back since it's Sunday but just wondering if anyone else had an issue and it's just me being stupid; would like to avoid driving back to service center and wait just for a windshield washer issue.... Especially on a brand new car it seems odd that this would be a "weakness" in the Model S....
     
  2. 3fiftynine

    3fiftynine Member

    Joined:
    Oct 19, 2014
    Messages:
    256
    Location:
    Hong Kong
    Have you tried pressing the button harder at the end of the stalk? I heard report saying it wasn't working but that guy didn't realize that button is of 2 steps, first for one stroke wiper second (harder) to activate water spray.
     
  3. Titus

    Titus Member

    Joined:
    Sep 22, 2015
    Messages:
    213
    Location:
    Hong Kong SAR
    Yes I have, yea I read about that on the forums some people don't press it hard enough. But I've pressed it all the way in and hear the pump going (maybe even a bit of grinding sounds???) but no water.

    Called tech support twice yesterday, still waiting call back from service dept; they don't advise me doing a drop-in....
     
  4. Titus

    Titus Member

    Joined:
    Sep 22, 2015
    Messages:
    213
    Location:
    Hong Kong SAR
    Update; morning of day 4 (day 3 if you don't could the public holiday yesterday). Still no calls from the Service Dept for appointment booking... will call Tech support again tomorrow. But my slack cutting quota for Tesla is slowly used up... I mean they should've noticed windshield washer not working during pre-delivery inspection... and something as simple as a windshield washer being broken from the start....
     
  5. Titus

    Titus Member

    Joined:
    Sep 22, 2015
    Messages:
    213
    Location:
    Hong Kong SAR
    Update: Gave them a call in the afternoon yesterday, told tech support no one called me back and this time they put me through directly to service dept. Quickest appointment.... 19 Nov... oh well I hope it's only that long because it's not a critical failure. Tried fidgeting with the washer hose but decided to just leave it and not make matters worse
     
  6. NerdDoc

    NerdDoc Member

    Joined:
    Aug 18, 2015
    Messages:
    60
    Location:
    New Jersey
    @Titus any update on the washer fluid? Sorry to resurrect this thread but just took delivery of my Model X and same thing, no washer fluid.
     
  7. Titus

    Titus Member

    Joined:
    Sep 22, 2015
    Messages:
    213
    Location:
    Hong Kong SAR
    @NerDoc actually thanks for bringing this up would be good to archive for new owners. The problem was there's a clip they install at the factory that pinches close all fluid hoses during transport. PDI was supposed to remove this clip but they forgot at the Hong Kong service center when they prepped my car for delivery. Took the service tech 3 mins to remove the wheel well fender and remove the clip; voila windshield washer spray works. I suggest letting your service center do it.

    Congrats on your new Model X and happy new year!
     
  8. NerdDoc

    NerdDoc Member

    Joined:
    Aug 18, 2015
    Messages:
    60
    Location:
    New Jersey
    Thanks for the info! Got mine fixed as well. They said a kink in the hose. 10 min fix.
     

Share This Page