TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker or making a Paypal contribution here: paypal.me/SupportTMC

Wiper blade motor

Discussion in 'Model S: Interior & Exterior' started by HawaiiBee, Dec 13, 2014.

  1. HawaiiBee

    HawaiiBee Member

    Joined:
    Nov 8, 2014
    Messages:
    20
    Location:
    Hawaii
    Anyone notice that the wiper blade motor makes a lot of noise ? Almost sounds like its a loose mounting... or the blade is too tight against the glass.

    Service center changed the arm and it helped a little, but there is still noise there.

    Wish the wipers could go faster, during the summer, those heavy rains were difficult to drive in.
     
  2. Mnlevin

    Mnlevin Member

    Joined:
    Feb 4, 2013
    Messages:
    417
    Location:
    South Florida
    the just replaced mine last week. My first car the 60 has had no problems, but the P85 had a very loud noise from the motor. Seems fine now
     
  3. TES-E

    TES-E Member

    Joined:
    Jun 23, 2014
    Messages:
    373
    Location:
    Casa Grande, AZ
    Used my wipers this morning for the first time (doesn't rain much here). I didn't notice any unusual sound. I did see the streaking problem, but it was minor.
     
  4. Akikiki

    Akikiki A'-Lo-HA ! y'all

    Joined:
    Nov 26, 2012
    Messages:
    1,607
    Location:
    Kaneohe
    Nope, not mine.
     

Share This Page