TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker and becoming a Supporting Member. For more info: Support TMC

Wiper fluid spray stopped working

Discussion in 'Model S: Interior & Exterior' started by tnt1971, Dec 19, 2016.

  1. tnt1971

    tnt1971 Member

    Joined:
    Feb 5, 2016
    Messages:
    204
    Location:
    United States
    I have an 85D I took delivery of in March of 2016. Yesterday when I hit the button to clean the windshield no fluid came out. I had some wiper fluid in my garage and I tried to add some. I did not get more than a cup in there and it was right up to the neck. Tried again to no avail.

    We had a few 20 degree days here but it was near 60 yesterday. The car is also garaged overnight, so I don't think it is a freezing problem. I have never added wiper fluid on my own until yesterday to try and fix the problem. What was in there was Tesla stock.

    Anyone else have this issue? I called the customer service number and they said service was going to call me to make an appointment.
     
  2. anthony

    anthony Member

    Joined:
    May 3, 2013
    Messages:
    183
    Location:
    New Hampshire
    My pump just went and had to be replaced.
    If its not making any noise when you push the button in all the way (there are two steps, first just wipes second sprays) you might check the fuse if you can figure out which one it is by searching this forum.
     

Share This Page

  • About Us

    Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.
  • Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


    SUPPORT TMC