Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register

Yellow Band on Screen UV fix - photos

Asterix187

Member
Oct 7, 2017
733
682
England
I have just got my Aug 17 Model S back from the Service Centre where i was having the CCS adaptor hardware installed and it turns out whilst it was there they performed the fabled UV fix on my screen so I thought I would post photos for anyone that was interested.

Sorry about the before photo, i wasn't expecting to get it fixed so didn't take a proper before.

screen-y1.jpg


after

screen-y2.jpg


Still a very slight yellow band but you don't notice it if your not looking for it.
 

Asterix187

Member
Oct 7, 2017
733
682
England
I had logged it over a year ago and happened to mention it as my 50k miles is up a few hundred and asked if would still be done when there is a fix even if I go over 50k. They said ‘oh it’s already booked I’m for that to be done’ and that was that.

I am happy with the results.
 

Joelgjr

Member
Mar 24, 2018
429
563
Westlake Village, CA
I had mobile service out to fix a washer nozzle issue. He told me the UV fix was in at San Diego and to make an appointment.

I had showed up a few weeks earlier and was told “we don’t have it yet but please make an appointment in a few weeks and we'll take care of it”
 

BPeter

Member
Feb 2, 2019
751
1,186
Minnesota
Looks pretty good! I'm taking mine in at the end of the month to get my winter wheels and tires along with a rattle I want them to attempt to fix for the fourth time. Will get the UV treatment then, too. Hope it fixes it nice!
 
  • Like
Reactions: Asterix187

phildas1

Member
Jun 27, 2018
51
63
Long Beach, CA
I have just got my Aug 17 Model S back from the Service Centre where i was having the CCS adaptor hardware installed and it turns out whilst it was there they performed the fabled UV fix on my screen so I thought I would post photos for anyone that was interested.

Sorry about the before photo, i wasn't expecting to get it fixed so didn't take a proper before.

View attachment 462256

after

View attachment 462257

Still a very slight yellow band but you don't notice it if your not looking for it.

Have had the yellow border on my MX (6/18 build) for several months now. Hasn’t really bothered me much till yesterday when I tried using the entertainment feature from version 10. Netflix , You Tube, and Hulu all work well except when I tried to exit the screen. Unfortunately the “X” to turn off the app is in the upper right corner of the screen where the yellow band is and it doesn’t work. Even after multiple attempts to exit. Had to reboot the system to get rid of the screen. Din’t know if the UV fix will fix this problem. Anyone else experienced this?
Going to have to make an appointment with SC
 

Asterix187

Member
Oct 7, 2017
733
682
England
Have had the yellow border on my MX (6/18 build) for several months now. Hasn’t really bothered me much till yesterday when I tried using the entertainment feature from version 10. Netflix , You Tube, and Hulu all work well except when I tried to exit the screen. Unfortunately the “X” to turn off the app is in the upper right corner of the screen where the yellow band is and it doesn’t work. Even after multiple attempts to exit. Had to reboot the system to get rid of the screen. Din’t know if the UV fix will fix this problem. Anyone else experienced this?
Going to have to make an appointment with SC
Sorry, I have never had a functional issue, only visual.
 

croman

Active Member
Nov 21, 2016
4,962
7,585
Chicago, IL
My service center keeps telling me engineering has a new screen they are testing that solves this issue and they will not do UV because it's not permanent and I have an active warranty claim, UV will only be goodwill repair for non warranty. So many confusing statements.
 

MarcusMaximus

Active Member
Jan 2, 2017
3,789
16,747
Los Gatos
My service center keeps telling me engineering has a new screen they are testing that solves this issue and they will not do UV because it's not permanent and I have an active warranty claim, UV will only be goodwill repair for non warranty. So many confusing statements.

Well, at least they seem to be just as confused as we are!
 

jedinite88

New Member
Sep 24, 2019
4
0
Los Angeles
I'm on my 3rd screen and today I just noticed that the yellow band around the perimeter is coming back. I still have 9k on my original warranty so I think I might hold off until early next year to see what happens. I would hate to replace it now only to have a current screen replace it that will have the issue again in a year. So far I've had a screen replacement every year in Oct. 2017 MS. I get a MS loaner and they get it fixed without much hassle except for a spending sometime at the SC. So really nothing to complain about here.
 

Altes

Member
Sep 30, 2016
645
554
SF Bay area
I had mobile service out to fix a washer nozzle issue. He told me the UV fix was in at San Diego and to make an appointment.

I had showed up a few weeks earlier and was told “we don’t have it yet but please make an appointment in a few weeks and we'll take care of it”
The CA bay area "service" centers are saying " make an appt for this and this only so tesla can record fixes:" cant fix anything else with this service call so far they have kept my car for a MINIMUM of three days for every service regardless of complexity. Theynsaidnthey fixed the 50MPH to 80 MPH ROAR by replacing the motor and axles...now i have a decel whine from 25 to 0 (decel only) with the new motor and axles which they refuse to acknowledge quoting no proof
 

Keith909man

Member
Apr 25, 2017
443
859
Tacoma wa
I have just got my Aug 17 Model S back from the Service Centre where i was having the CCS adaptor hardware installed and it turns out whilst it was there they performed the fabled UV fix on my screen so I thought I would post photos for anyone that was interested.

Sorry about the before photo, i wasn't expecting to get it fixed so didn't take a proper before.

View attachment 462256

after

View attachment 462257

Still a very slight yellow band but you don't notice it if your not looking for it.
Hey, you have a software update available! DOWNLOAD NOW!
 

GoTLSAGo

Member
Aug 7, 2019
79
32
London, UK
I have just got my Aug 17 Model S back from the Service Centre where i was having the CCS adaptor hardware installed and it turns out whilst it was there they performed the fabled UV fix on my screen so I thought I would post photos for anyone that was interested.

Sorry about the before photo, i wasn't expecting to get it fixed so didn't take a proper before.

View attachment 462256

after

View attachment 462257

Still a very slight yellow band but you don't notice it if your not looking for it.

Looks like you are based on England and around London. I have the same issue and live in London. I am on 'the waiting list' for a fix so wondering which service centre you went to? I always use the Brooklands SC and the staff there are great! Going there soon to get my referral reward Arachnid wheels fitted so am definitely going to ask about this fix...and hopefully i can quote your story here to help!
 

smtgrg

Member
Sep 19, 2019
10
2
San Jose
The CA bay area "service" centers are saying " make an appt for this and this only so tesla can record fixes:" cant fix anything else with this service call so far they have kept my car for a MINIMUM of three days for every service regardless of complexity. Theynsaidnthey fixed the 50MPH to 80 MPH ROAR by replacing the motor and axles...now i have a decel whine from 25 to 0 (decel only) with the new motor and axles which they refuse to acknowledge quoting no proof

Made a Service Center Appointment. Here is the Service estimate they sent before the appointment.
Not sure what it means "Diverted - Customer Education"?

upload_2019-10-8_8-0-47.png
 

Asterix187

Member
Oct 7, 2017
733
682
England
Looks like you are based on England and around London. I have the same issue and live in London. I am on 'the waiting list' for a fix so wondering which service centre you went to? I always use the Brooklands SC and the staff there are great! Going there soon to get my referral reward Arachnid wheels fitted so am definitely going to ask about this fix...and hopefully i can quote your story here to help!
Actually I am near Warwick so i went to the Digbeth SC.

note1.jpg
 

kkillebrew

Banned
Jun 23, 2019
401
239
austin, tx
I just got this regarding the yellowing in my LESS THAN 3 MONTH OLD CAR:

Says they reviewed the damage. They did not look at the car or ask for any photos. The worry some thing here is that they consider fixing this a "Goodwill Gesture". Nothing about this bothers me a lot except the "Goodwill" part. Am I being overly picky here? I just purchased an extended warranty too. No response on my reply or after I sent the pictures they requested.

Please let me know what you think...? I am REALLY hacked off about the goodwill gesture attitude. My attitude is small claims court and to cancel the extended warranty if this is how Tesla reacts to legitimate concerns.
1.jpeg
teslatext.png
3.jpeg
 
  • Like
Reactions: Jan Fiala

Products we're discussing on TMC...

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top