TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker and becoming a Supporting Member. For more info: Support TMC

Slow to finish loading pages

Discussion in 'Site Feedback' started by ggr, Jul 17, 2018.

  1. ggr

    ggr Roadster R80 537, SigS P85 29, M3P 80k

    Joined:
    Mar 24, 2011
    Messages:
    4,655
    Location:
    San Diego, CA
    This morning I've been observing a strange behavior, which makes browsing painful. When I load a thread, it looks like the content has finished loading, but it doesn't scroll to the most recent unread post straight away. Also (Chrome on a Mac) the little TMC icon on the tab shows up as a blank page for a while. At first I couldn't understand why the forum pages loaded quickly but the threads wouldn't, but that was a red herring; the forum pages don't finish loading for a while either. The difference is that with the forum pages, nothing happens visually when the page finishes loading, while for individual threads, the scrolling to the first unread post doesn't happen until the end.

    A bit more research shows that some chunk of javascript somewhere is trying to establish a secure connection to somewhere else, and it takes ~13 seconds to either succeed or fail and timeout, not sure which. Unfortunately I can't tell which. I also can't find a way to figure out what . I think it's in javascript because the Chrome "I'm still loading" spinner has gone away for all of that 13 seconds.

    Actually, learning a bit more about modern browser stuff (I still use vi to edit html, myself...) I tracked it to:
    importScripts('https://cdn.onesignal.com/sdks/OneSignalSDK.js');
    @doug @danny
     
  2. MorrisonHiker

    MorrisonHiker S 90D 2018.42.2

    Joined:
    Mar 8, 2015
    Messages:
    4,956
    Location:
    Colorado
    I've noticed this lately as well. On my home PC, pages used to load instantly but now some are really dragging.
     
  3. boaterva

    boaterva Supporting Member

    Joined:
    Apr 2, 2016
    Messages:
    5,360
    Location:
    Northern Virginia, USA
    I was noticing that all the plugins seem to slow it down (twitter, facebook, etc.) depending on random times of the week. It's definitely educational to watch the bottom of your browser (at least Firefox) to see what it's loading (or trying to) as it processes a page. :D
     
  4. anticitizen13.7

    anticitizen13.7 Not posting at TMC after 9/17/2018

    Joined:
    Dec 22, 2012
    Messages:
    3,654
    Location:
    United States
    Same issue here.
     
  5. ggr

    ggr Roadster R80 537, SigS P85 29, M3P 80k

    Joined:
    Mar 24, 2011
    Messages:
    4,655
    Location:
    San Diego, CA
    Interesting... I stopped seeing it around 14:00, but you're still seeing it? I assumed they fixed it.
     
  6. anticitizen13.7

    anticitizen13.7 Not posting at TMC after 9/17/2018

    Joined:
    Dec 22, 2012
    Messages:
    3,654
    Location:
    United States
    It’s ok on my browser now.
     

Share This Page

  • About Us

    Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.
  • Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


    SUPPORT TMC