TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker and becoming a Supporting Member. For more info: Support TMC

Sluggish Loading

Discussion in 'Site Feedback' started by Pluto, Jul 19, 2016.

  1. Pluto

    Pluto Member

    Joined:
    Nov 17, 2015
    Messages:
    121
    Location:
    Stockton, California
    Has anyone noticed the site being sluggish today? Multiple tabs I opened took 10+ seconds to finish loading, whereas performing a search on another tab (outside of TMC) loaded pretty much instantly. It seems to have been random occurrences today (I noticed it two different times so far) when TMC takes forever to load pages.

    Cheers
     
  2. GoTslaGo

    GoTslaGo Learning Member

    Joined:
    Dec 25, 2015
    Messages:
    3,070
    Location:
    NV
    Well, I assume you are frequenting TMC from Pluto... What do you expect? ;):D
     
    • Funny x 1
  3. BertL

    BertL Active Member

    Joined:
    Aug 19, 2015
    Messages:
    1,951
    Location:
    Carlsbad, CA
    OP, I have the same problem, but it occurs multiple times every day, at different times, using Safari on my iPad (WiFi) or OSX Safari (hardwired using AT&T Uverse). The problems began when the new TMC was introduced a few months ago. I had zero issues with TMC before the redesign (and hosting changes?):
    • Other sites do not have the same problem at the same time I encounter issues with TMC -- other open browser tabs continue to operate or I can access other sites while waiting for TMC to complete
    • The effect is generally a TMC page stalling somewhere on its load for some number of seconds to get the complete display. It can happen on the Home forum selection screen, a specific forum, scrolling pages within a thread, and IMHO just about anywhere within TMC
    • At times the page does not complete loading, e.g. if there are multiple pictures, sometimes all the post text will appear and some photos will display, while other times only the top part of one photo will display leaving a blank space where the rest of the photo should be, yet another photo(s) up or down-thread is completely there. It's like the hosting service is getting lost sending all the data...
    • Refreshing the page within the browser almost never changes or improves anything, and just displays the "processing" icon until the data eventually comes back or I become frustrated and shut TMCndown and start again
    • Sometimes if I just wait long enough, the page will eventually complete, but not always (see photo example above)
    • What will resolve the problem more than half of the time (but not all) is closing the tab for TMC and re-entering TMC; same thing of course if I shutdown the browser and renter TMC
    • I have tried this for several days with ad blockers in place, and TMC excluded (as I keep it, even though I'm also a donator). I've also tried uninstalling all blockers and all other add-ones so I have a native Safari experience for a few hours with the same TMC-only issues
    • Grasping at straws, I also have tried changing my primary DNS Servers from AT&T to Google to OpenDNS, but have not seen any real difference. I'm running with Google first and AT&T second in my list right now.
     
    • Informative x 1
  4. BertL

    BertL Active Member

    Joined:
    Aug 19, 2015
    Messages:
    1,951
    Location:
    Carlsbad, CA
    FWIW A real-time example of the stalled partial image issue I describe in the previous post. This remained on my iPad for 90 secs (I timed it), before I took action. The screen was fully accessible, and when scrolled, had text and the new post box below it. I refreshed the page, the entire image displayed, and I entered this new post.
    image.jpeg
     
    • Informative x 1
  5. Pluto

    Pluto Member

    Joined:
    Nov 17, 2015
    Messages:
    121
    Location:
    Stockton, California
    For me it also happens multiple times a day, but all pages on TMC stop loading for about 30 seconds (Firefox latest on Windows 10).

    Eventually the pages stop loading and show a blank page. It's then that I can reload the pages and things have returned to normal.
     
    • Informative x 1

Share This Page

  • About Us

    Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.
  • Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


    SUPPORT TMC