Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register

Do I have a unique AP2 issue?

Remuz

Member
Mar 25, 2018
6
5
Stockholm
January 2017 I picked up an AP1 MX60D which was great, but since I started using my car about 2.5x more I wanted a 90D with all options. I found a demo MX90D AP2 with all options including FSD which was delivered in June 2017. My MX60D had some door issues which was fixed soon and that was it. My MX90D however had door issues, several other issues and AP2 only worked on a good day.

The car has been to SC (Stockholm, Sweden) once a month since delivery. Doors have been fixed after two tries, seats have been fixed (one left though), but AP2 is not yet fixed. SC have changed cameras, recalibrated radar, changed ICU, changed MCU etc. The issue persists.

AP2 only works randomly so a guess that cameras have issues is a good one, but that is not the case. Because when I lose AP2 and cruise control I also lose speed limit indication in the screen behind the steering wheel and with the exterior lights set to AUTO ut switches on low beam light instead of daytime running lights. My guess is that the car doesn't know where it is located, therefor it puts the light on (I might be in a country that requires it) and deactivate AP2 (I might be in a country that doesn't allow it). I have presented this theory for SC but no luck there. On google maps and navigon the car knows exactly where it is.

Some software versions ago (I think it was prior 2017.50.3) it didn't even warn when AP2 was deactivated, it just shut down. Now I at least get a warning.

Today, 10month later I have escalated the issue using the feature in myTesla. I am asking for compensation for missing features (plus the feature fixed) or a new car with similar spec and milage.
 
  • Helpful
Reactions: hiroshiy and Texas

daktari

Member
Jan 21, 2017
909
1,030
Norway
My tip is a sensor failure. Was it 17.42 or later that activated the repeater cameras? Then all my driver assistant features and auto headlights and auto wipers got disabled. One side repeater cam had a bad contact. Replaced and worked fine since. Also, the wiring harness can have corrosion in the contact. Maybe the wiring also has had a pinch somewhere and is kind of unstable.

Have you tried calling Tesla roadside assistance for a diagnosis at the moment the system fails? And yes, I support your escalation!
 

hiroshiy

Supporting Member
Supporting Member
Apr 6, 2013
2,407
2,004
Tokyo, Japan
It seems your service center changed cameras and it didn't fix the problem. From your description of AP2 issues it sounds like to me that AP2 computer is malfunctioning for some unknown reason. You described that the SC changed ICU and MCU but not the AP2 computer?
 

Remuz

Member
Mar 25, 2018
6
5
Stockholm
I did not know there is a special Ap2-computer so I do not know If it is replaced.

This night they responded:

I have received feedback from the servicemanager in Stockholm that they have been in contact with you in order to find a path of resolution in this matter. I will close this escalation now, knowing you are in good hands with the Stockholm service team and they have a full picture of the problem.


But no, SC havent been in contact with me for Some time now.
 

hiroshiy

Supporting Member
Supporting Member
Apr 6, 2013
2,407
2,004
Tokyo, Japan
Hope your SC guys can nail the source of the problem. Or they change your car.

Maybe you can ask them to change AP2 computer and see that fixes the problem.

Is there a lemon law in Sweden?
 

Products we're discussing on TMC...

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top