TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker or making a Paypal contribution here: paypal.me/SupportTMC

I Need A New Charging Cable

Discussion in 'Roadster' started by Pantera Dude, Feb 2, 2013.

  1. Pantera Dude

    Pantera Dude Member

    Joined:
    Mar 18, 2012
    Messages:
    468
    Location:
    Long Beach, California
    My UMC will no longer charge at 40, 32 or 24 amps. If any of you out there have the newer UMC or the earlier MC240, (that charges at 30 amps), and would like to sell, please let me know.

    Thanks,
     
  2. hcsharp

    hcsharp Active Member

    Joined:
    Jun 7, 2011
    Messages:
    2,532
    Location:
    Vermont
    I can probably fix it for less than you'll pay for a used UMC. Can't guarantee that without checking it out first.
     
  3. Pantera Dude

    Pantera Dude Member

    Joined:
    Mar 18, 2012
    Messages:
    468
    Location:
    Long Beach, California
    I split the case of the charger, that was a bear! I was not comfortable digging any deeper into it so I called the manufacturer, (North Shore Safety), to ask if they could repair it. They told me it would have to go thru Tesla. The guy told me the part was "potted" and I got the impression that there wasn't much they could do to it other than testing it. I have some pictures but I couldn't figure out how to include them in this note. Being potted, do you think there is any chance you might be able to repair it?

    Thanks,
    Art
     
  4. Doug_G

    Doug_G Lead Moderator

    Joined:
    Apr 2, 2010
    Messages:
    15,850
    Location:
    Ottawa, Canada
    If the device is potted, that means it's basically encased in a brick of epoxy. Good luck doing anything with it.
     
  5. Pantera Dude

    Pantera Dude Member

    Joined:
    Mar 18, 2012
    Messages:
    468
    Location:
    Long Beach, California
    Yeah, that's what I was thinking.

    Thanks,
    Art
     
  6. hcsharp

    hcsharp Active Member

    Joined:
    Jun 7, 2011
    Messages:
    2,532
    Location:
    Vermont
    I'd have to check it out first. You could send me the pics for starters. If it's like the MC240 then only the ground fault circuit is potted.
     
  7. Pantera Dude

    Pantera Dude Member

    Joined:
    Mar 18, 2012
    Messages:
    468
    Location:
    Long Beach, California
    Interesting note, not good but interesting. :biggrin: Before I opened up the case, the charger would charge at 15 amps, now it doesn't charge at all after putting it back together. I didn't do any damage that I'm aware of, but instead of charging, it shows a fault light on the UMC.
     

Share This Page