TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker or making a Paypal contribution here: paypal.me/SupportTMC

Calendar Sync with iPhone and Airwatch

Discussion in 'Model S: User Interface' started by Pkorb, Dec 4, 2015.

  1. Pkorb

    Pkorb New Member

    Joined:
    Dec 4, 2015
    Messages:
    4
    Location:
    Duluth, GA
    I just purchased a 2014 Model S with AutoPilot. My work iPhone does not load my calendar entries on my phone into the Tesla calendar. The calendar says it updated once I enter the car, but, it remains empty when my phone has many entries in the calendar. I am suspecting that it is due to my work phone having AirWatch which is a security software for protecting information on your phone. Does anyone have information on getting the calendar loaded with AirWatch installed? I can get this function working on my personal phone, but, not my work phone. Any thoughts?
     
  2. Xenoilphobe

    Xenoilphobe Active Member

    Joined:
    Jan 2, 2014
    Messages:
    1,661
    Location:
    Fairfax County Virginia
    I use air watch on my iPhone with no issues. Make sure you toggle the options on in your Tesla App... they may be turned off.
     
  3. Pkorb

    Pkorb New Member

    Joined:
    Dec 4, 2015
    Messages:
    4
    Location:
    Duluth, GA
    Are you referring to going into settings and selecting the Tesla app and turning on calender, notifications and background app refresh? All of those toggles are on... Any other thoughts?
     
  4. Patrick W

    Patrick W Member

    Joined:
    Mar 17, 2015
    Messages:
    840
    Location:
    SLC, UT
    I've no experience with a watch but when the car seems to be having problems getting calendar information from my iPhone I open the Tesla app on the iPhone and use the app to wake up the car. Even when sitting in the car. That's always worked for me.

    Note that the calendar in the car only shows the current and next day. No data from any other days, past or future (something I'd like to see fixed).
     
  5. Xenoilphobe

    Xenoilphobe Active Member

    Joined:
    Jan 2, 2014
    Messages:
    1,661
    Location:
    Fairfax County Virginia
    check the air watch app settings
     
  6. Pkorb

    Pkorb New Member

    Joined:
    Dec 4, 2015
    Messages:
    4
    Location:
    Duluth, GA
    Ok, I continue to work my calendar problem. Next question? Again, my calendar does not update with my schedule information. I realized today that my company installs Microsoft Exchange for email and calendar. My question. Does anyone have Microsoft Exchange/Outlook running on their iPhone and is it population your calendar in your car? I have a call into Tesla to see if Exchange/Outlook is supported in the Tesla calendar function. Any insight would be appreciated.
     
  7. clarkbariowa

    clarkbariowa Member

    Joined:
    Apr 4, 2015
    Messages:
    118
    Location:
    Elgin IL
    Exchange is probably the most widely used email system in the world. I have an Exchange profile on my phone and the calendar entries shows up fine. What version of IOS on the phone are you running?
     
  8. Pkorb

    Pkorb New Member

    Joined:
    Dec 4, 2015
    Messages:
    4
    Location:
    Duluth, GA
    Thanks for the response. I am running IOS 9.2. I have an appointment with my service advisor next week at Tesla. So far i can't figure out what is causing the issue.
     
  9. MikeBur

    MikeBur ManualPilot

    Joined:
    Dec 8, 2014
    Messages:
    579
    Location:
    Seattle, WA
    Are you running watch OS 2.01 or greater? There is a known issue with exhange supplier certificates with iPhone/watch (you can check by going into settings on iPhone and looking for certificates under "Profiles" under "email" iirc.

    Installing to latest watch OS worked for me, though admittedly have NOT upgraded to iOS 9.2 on iPhone yet purposely.

    if watch is sync'ing with iPhone then it is tesla App/iPhone issue that I haven't seen, sorry.
     

Share This Page