TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker and becoming a Supporting Member. For more info: Support TMC

Google WiFi router and Tesla

Discussion in 'Model S' started by TexasEV, Jan 15, 2017.

  1. TexasEV

    TexasEV Well-Known Member

    Jun 5, 2013
    Austin, TX
    Does anyone else have experience with the Google WiFi router connecting to a Model S or X? I've seen two very different experiences posted here:

    "I would highly recommend Google Wifi or a similar multi-point Wifi home system for the best connectivity."


    "I had issues using my new Google Wifi access points where the car would connect, but Slacker would not stream, and web pages would not load in the in-car browser. Every other device on my home's Google Wifi mesh network worked perfectly.

    My Google Wifi is using the 192.168.86.XXX range (subnet cannot be user configured). I had to set up a separate Wifi hotspot in my garage with an ethernet run straight back to my modem using a Netgear N300 using the range. This worked, but I don't know if it is because of the IP range (I would think that is unlikely) or whether it is related to something the Google Wifi system is doing."

    Before I buy a Google WiFi mesh router I'd like to know which experience is the more common!
  2. DJung

    DJung Member

    Feb 28, 2013
    Newport Beach, CA
    I have the mesh system from Google and it works great with my Model S. No issues fetching updates or connecting at all. Slacker and web pages load perfectly well.

    I love our Google WiFi! Awesome speeds and coverage all over our house! And dead simple to set up and use too.

    Worst case, you can always return it if it doesn't work out for you for whatever reason.
  3. pilotSteve

    pilotSteve Active Member

    Jul 14, 2012
    Vancouver WA
    Slight thread drift, but I have eero mesh routers, and one in my garage (with a hard line to the main switch). It works well with the Tesla. Nothing special about my setup (although my password is less than 16 characters long)
  4. steve841

    steve841 Active Member

    Jan 17, 2010
    Ft. Lauderdale, FL
    Netgear Orbi here ... no issues. 8 character password
  5. suttonlr

    suttonlr New Member

    Dec 25, 2016
    Austin, TX
    I have Google Fiber and it works perfectly. It's a similar setup to the google access points. You could have multiple devices giving out IP addresses. Try this... configure the google devices as access points only allowing only the n300 to dish out ip addresses and give all the devices the same said name and password. That may fix your wifi woes.
  6. wiredprairie

    wiredprairie Member

    Nov 21, 2016
    Wisconsin, USA
    My Tesla S connects fine to a Google Wifi point (which itself is connected via wireless mesh to another point).

Share This Page

  • About Us

    Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.
  • Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.