Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.

In-car Sudoku game won't start

After having had a warranty replacement of my 2020 MY LR AWD's infotainment/nav computer a couple weeks ago, I've noticed that Sudoku, the one game I occasionally play, will no longer start. When I try to invoke it, its splash screen appears, with an animated "progress bar" graph that I assume connotes a loading/initializing operation. The progress bar fills in, and just sits there; the game itself doesn't begin. I tried several of the other in-car games; most of them didn't work either, although the Solitaire game repetitively ran its progress bar from 0 to about 30% (I watched it do that for a count of one hundred). I've tried a couple both-scrollwheels-pressed reboot operations to no avail. Is there some simple way to reinitialize these games? It seems silly to go through the Tesla service app for such a trivial issue. It would sure be great if one of the in-car apps was "command shell", that would let you pop in a USB keyboard and command "rm /etc/gamestates/sudoku".
Might as well give an interim update.. Seeing as how nobody on this forum had advice to offer, I went ahead and put in a request for service via my Tesla phone app on 29Oct. That turned into a mobile service appointment for 8Nov, but in parallel, someone behind the service app curtain sent my car an OTA update (or claimed they did), and asked me to install it. Didn't help, but remote efforts were ongoing and the in-person mobile servicing got pused to 14Nov. That was followed by a couple more software updates, and a factory reset that the remote tech managed to do a save/restore of my relevant personal state for. The games still wouldn't start, though.

This morning (11Nov), finally, I got another message via the service function of my phone's Tesla app. Hopefully, they won't mind me quoting it here:
"Good morning after reviewing some more documents and information we have found this to be a known software issue at this time. The games manager is missing the security signatures to be able to load. This is actively being investigated by our engineering team at this time and a fix will be anticipated in a future firmware issue. No further diagnostics are needed at this time and hardware replacement will not resolve issue"

I'm grateful to have an explanation of the problem and assurance that it will be solved when the next free elections are held, but there are some irksome things about the situation. If it's a known issue, why did it take the better part of a month for whoever put in a couple days' labor on the issue to discover that it even existed? Doesn't Tesla maintain an internal searchable knowledge base for this stuff? Are ALL the games installed as a single module (else why wouldn't it be possible to replace them individually)? Also, to judge by the interactions I had with whoever was holding up Tesla's end of the service message conversation ("We tried another install. Tell us if it worked!"), Tesla could really use some more tools that would let them execute commands remotely. There are probably more things to whinge about, but I'll stop with wondering why, if the issue really IS a "missing security signature" on one of the car's supposedly built-in features, didn't the detection of that error get logged?
Hello Levenkay, I am currently experiencing the same issue that you are describing. It started after I had picked up my car from Tesla Service last Sunday. My Model 3 LR Dual was serviced because it had lost cellular connectivity immediately after a recent software update (with FSD Beta). Tesla Service told me that the car had a hardware issue and the connectivity card had to be replaced. I tried to argue that it was too much of a coincidence that the problem started after a software update to no avail so I just paid the $500 to get it fixed as I needed the car. After picking up the car, I noticed the next day that Solitaire's load progress bar would loop at about 30%. Sudoku's progress bar would get to the end and would not load up. All other games seem to load. I contacted Tesla Support via phone and then the same service center via the messaging feature in the app. After a short discussion, I believe that they sent me the same software update to try (2022.20.19). After updating, I had the same issues, but now a few other games will not load. I am glad to hear that someone else is having this same issue. Any update on your situation?