TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker and becoming a Supporting Member. For more info: Support TMC

Low coolant.....

Discussion in 'Model X' started by DCWitt, Apr 4, 2016.

  1. DCWitt

    DCWitt Member

    Joined:
    Nov 23, 2012
    Messages:
    173
    Location:
    Watseka, IL
    My wife noticed a small puddle of blue fluid on the garage floor when I backed out the day after we received the car. I called our service center to see if they had an idea what it could be. They suggested washer fluid. Fast forward a couple days and I started receiving "vehicle coolant low" message for a few seconds at a time. SC picked up the X today. Waiting to hear prognosis. Anyone else experiance this?
     
  2. Desmo999

    Desmo999 Member

    Joined:
    Apr 19, 2013
    Messages:
    30
    Location:
    Redwood City, CA
    Had a couple drops of the blue coolant from my Model S after it was two years old, but never got a warning.

    The SC took care of it... Said it had a leak at one of the connecting pipes from a faulty seal. Assuming this was going to/from the radiator for cooling the battery pack.
     
  3. scottf200

    scottf200 Active Member

    Joined:
    Feb 3, 2013
    Messages:
    1,533
    Location:
    Chicagoland ModelX S603
    Yes, I did. A hose clamp was not tight / attached correctly. My service center was prompt and took great care of me. (I had a low coolant issue in my 2011 Volt to that required taking it to the dealer and me dropping it off. This was quicker and less work).
     
  4. DCWitt

    DCWitt Member

    Joined:
    Nov 23, 2012
    Messages:
    173
    Location:
    Watseka, IL
    Thanks for the replays. SC found a small leak and repaired. While they had the X they fixed some other small issues that they noticed and went out of their way to get the X back to me quickly. GREAT service!
    DW
     
    • Like x 1
  5. jya*

    jya* Member

    Joined:
    Apr 3, 2016
    Messages:
    26
    Location:
    Brookline, MA, United States
    Our X is going back to the SC for low coolant for the fourth time this month. Each time the coolant level is low, they fill it, they try to diagnose the leak, give it back to us a few days later, and then after about 3 days the light comes on again. Our parking is uncovered and it has been snowy / rainy the whole month so we can't even tell when it is leaking.
     

Share This Page