Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register

Access Denied error from Tesla app?

EVRider-FL

Member
Aug 18, 2015
670
383
South Florida
I started seeing the following Access Denied error whenever I launch the Tesla app (3.10.13) on my iPad:

023D690B-9091-44AA-8FAF-B6A597AD5154.jpeg


I’ve force quit the app and restarted my iPad, but no luck. iPad is running iOS 14.6.

My iPhone has Tesla app 3.10.12 and iOS 14.6, and the app works fine there.

I’ll try deleting the app and reinstalling it, but I’ve never seen this issue and wondered if anyone else has.

Update: Deleting and reinstalling didn’t help.
 

Twiglett

Single pedal driver
Oct 3, 2014
2,980
2,947
Austin
there was an update to the iOS app yesterday to 3.10.13 but I doubt that will make any difference
Have you tried logging in from a web browser to make sure your account is OK?
 

EVRider-FL

Member
Aug 18, 2015
670
383
South Florida
I’m using 3.10.13 of the app. I tried logging in from the browser as you suggested, and I get the same error there, for any page on tesla.com. On my iPhone, both the app and browser work.

It might have something to do with the VPN I’m using (NordVPN), but I’m using that on both devices, and never had a problem with Tesla access with the VPN before.
 

CaliSurfer

Member
Jan 8, 2021
68
74
Connecticut, USA
I’m using 3.10.13 of the app. I tried logging in from the browser as you suggested, and I get the same error there, for any page on tesla.com. On my iPhone, both the app and browser work.

It might have something to do with the VPN I’m using (NordVPN), but I’m using that on both devices, and never had a problem with Tesla access with the VPN before.
If you think it's your VPN, you can go into the NordVPN settings and enable split tunneling. Then select the app you want to tunnel. This will allow that app to bypass the VPN. I had to do this with my voicemail app because it would never connect to the voicemail server when I was connected to the VPN.

I use NordVPN on my phone and have had no issues with the Tesla app through a VPN. Sounds more like you have a login credential issue.
 
  • Like
Reactions: Rachmaninov

EVRider-FL

Member
Aug 18, 2015
670
383
South Florida
Turns out it was a NordVPN issue. I wasn’t even getting to the point where I could enter credentials — any page on tesla.com would immediately display the error. Since it was working on my iPhone with NordVPN, I compared the NordVPN settings on my iPhone with my iPad, and noticed they were using different VPN servers. I disconnected NordVPN on my iPad and reconnected to a different VPN server, and the problem disappeared in both the browser and Tesla app. All is good. 🙂
 

CaliSurfer

Member
Jan 8, 2021
68
74
Connecticut, USA
Turns out it was a NordVPN issue. I wasn’t even getting to the point where I could enter credentials — any page on tesla.com would immediately display the error. Since it was working on my iPhone with NordVPN, I compared the NordVPN settings on my iPhone with my iPad, and noticed they were using different VPN servers. I disconnected NordVPN on my iPad and reconnected to a different VPN server, and the problem disappeared in both the browser and Tesla app. All is good. 🙂
I would enable split tunneling in the Nord app then. That will solve this issue you are having while not needing to turn off your VPN.
 

hcdavis3

HCD3
Supporting Member
Mar 3, 2019
2,262
1,410
02571
Turns out it was a NordVPN issue. I wasn’t even getting to the point where I could enter credentials — any page on tesla.com would immediately display the error. Since it was working on my iPhone with NordVPN, I compared the NordVPN settings on my iPhone with my iPad, and noticed they were using different VPN servers. I disconnected NordVPN on my iPad and reconnected to a different VPN server, and the problem disappeared in both the browser and Tesla app. All is good. 🙂
I had this same issue with Nord a while ago before my Tesla. I couldn’t gain access to my bank account. I disabled the VPN, and all was good thereafter.
 

EVRider-FL

Member
Aug 18, 2015
670
383
South Florida
I had this same issue with Nord a while ago before my Tesla. I couldn’t gain access to my bank account. I disabled the VPN, and all was good thereafter.
Not really the same issue. I can usually access the Tesla servers with NordVPN, but for some reason I couldn’t when using a particular VPN server (my iPhone was using a different NordVPN server and there was no issue there). When I connected to a different VPN server the problem disappeared.

I’ve never been able to access Bank of America via the browser or their app when using NordVPN, which sounds like your issue.
 

sk174

New Member
Jul 21, 2021
1
1
Belleville, Illinois
I started seeing the following Access Denied error whenever I launch the Tesla app (3.10.13) on my iPad:

View attachment 671020

I’ve force quit the app and restarted my iPad, but no luck. iPad is running iOS 14.6.

My iPhone has Tesla app 3.10.12 and iOS 14.6, and the app works fine there.

I’ll try deleting the app and reinstalling it, but I’ve never seen this issue and wondered if anyone else has.

Update: Deleting and reinstalling didn’t help.

- - - -
I was having the same issue for the last week. I solved it by going into my VPN settings and changing the location of the VPN server I was going through. It works fine now.
Steve
 
  • Like
Reactions: CaliSurfer

Products we're discussing on TMC...

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top