TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker and becoming a Supporting Member. For more info: Support TMC

API Access

Discussion in 'Model S: User Interface' started by premiercolby, Feb 2, 2017.

  1. premiercolby

    premiercolby Member

    Joined:
    Feb 2, 2017
    Messages:
    19
    Location:
    Vero Beach FL
    Hello Everyone,

    New at this and I was following the JSON page but I keep getting an error. Just trying to get past step 1 here, with generating the token.

    The best guess for why it wasnt working was that the url on JSON has changed but even updating it to the updated tesla user log in page, its still not letting me in.

    Tried 10+ times, I know its not a typing error from log in credentials (same ones as mytesla log in). The error comes from the API.. Dont know if this is helpful or not: "def establish_connection(token=None):"

    I know you all have a lot more skills than I, so please assist me in figuring this out!

    Thanks so much! Anything is appreciated!
     
  2. cgiGuy

    cgiGuy Active Member

    Joined:
    Jul 9, 2013
    Messages:
    1,227
    Location:
    Sacramento, CA
    Check out this thread.. it's long, but it may help answer your questions.

    Model S REST API
     
  3. premiercolby

    premiercolby Member

    Joined:
    Feb 2, 2017
    Messages:
    19
    Location:
    Vero Beach FL
    Thank you! I will check that out!
     

Share This Page