TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker or making a Paypal contribution here: paypal.me/SupportTMC

Can an App wake the MS from Sleep Mode?

Discussion in 'Model S: User Interface' started by RCH1708, Jun 23, 2014.

  1. RCH1708

    RCH1708 Member

    Joined:
    May 31, 2013
    Messages:
    276
    Location:
    Maarheeze, Netherlands
    For the last weeks (at least) I've been unable to wake my MS from sleep mode using the iPhone app, no matter how long I wait. The app works just fine when the car is awake. The problem is independent of location, ie I can't wake it when its connected to wifi at home or 3G at the office. I got 5.11 yesterday and the problem persists.

    As far as I recollect, the app used to always wake my MS from sleep mode - it just took a while. I could happily preheat my car in the winter, but jow that the weather is warm I can't pre-cool it.

    I asked my local service centre today and the reply I got was that the app cannot wake the MS from sleep mode... I quote:

    "The connection with the app is not working because the Model S is on Energy saving ON. If you switch if off, it will work again."

    Is this new behaviour? Or what?

    BTW, I searched the forums with Tapatalk, but didn't find anything specifically on this subject.

    Rob.
     
  2. Merrill

    Merrill Active Member

    Joined:
    Jan 23, 2013
    Messages:
    2,096
    Location:
    Sonoma, California
    I have 5.11 and the app works but takes a long time to wake it up. I have to keep trying but eventually it will work.
     
  3. RCH1708

    RCH1708 Member

    Joined:
    May 31, 2013
    Messages:
    276
    Location:
    Maarheeze, Netherlands
    Apparently this is normal behaviour. I asked Ownership the following question:

    "My issue is that the App cannot wake my MS at all - it says "waking vehicle" and then, after a while, times out saying that it cannot contact the vehicle. If I press "retry" same thing happens. In other words the App cannot wake the MS from sleep mode. Is that correct behaviour?"

    The answer was:

    "Yes this is correct, the mobile app may not always wake the vehicle, especially if the vehicle is in a deep sleep mode. This is normal behavior, and we advise customer to only turn on Energy Saving when taking long trips. But if your MS is your daily driver we suggest you keep it OFF."

    Rob.
     
  4. riceuguy

    riceuguy Member

    Joined:
    Dec 17, 2012
    Messages:
    169
    Location:
    Austin, TX
    Hmmm...this was never the case before. If it were me, I'd ask if they can validate that with engineering, and note that you've never heard of this behavior before, it didn't work this way before, and others haven't had this problem.
     
  5. Sparrow

    Sparrow S105/ Roadster 189

    Joined:
    Dec 14, 2010
    Messages:
    566
    Location:
    Marietta, GA
    I agree the app has almost always woken my car from sleep. The only time my app has not woken my car, it was in some kind of really weird deep sleep. That one time when I got in the car it took well over a minute to power up so I could drive. When I pressed on the brake it even showed me an error message on the dash saying it was powering up. I had never seen this behavior before and was really afraid something was wrong with the car.
     
  6. RCH1708

    RCH1708 Member

    Joined:
    May 31, 2013
    Messages:
    276
    Location:
    Maarheeze, Netherlands
    I had it confirmed by a technical support specialist in Fremont. It is indeed not the behaviour that I had previously, I've always had my car in sleep mode and throughout the winter had no problems waking it up from sleep. I couldn't say for certain when the behaviour changed, but it was weeks ago.

    It's disappointing that the behaviour has changed, it worked fine before - I didn't mind waiting a minute or two for the car to wake up before accessing it from the app. Taking it out of sleep mode doesn't appeal - I'm used to the way that the battery behaves as it is. Having to keep two different vampire rates in mind is too much trouble.

    As a BTW, I "lost" 10km range after updating to 5.11, last night & my sunroof won't open to 80% anymore (75% or 90%). This is also very disappointing, frustrating and seemingly fruitless. I wish they would stop messing around with the basics that work just fine.
     
  7. ABVA

    ABVA Member

    Joined:
    Nov 2, 2013
    Messages:
    234
    Location:
    Northern Virginia
    Another work around could be "Visibletesla" App selflessly contributed by Jpasqua. Great app and provides a lot more functionality compared to the iPhone App.
    Here is the link:

    VisibleTesla
     
  8. gavine

    gavine Petrol Head turned EV Enthusiast

    Joined:
    Apr 1, 2014
    Messages:
    1,009
    Location:
    Southern New Jersey
    Try shutting down the app and restarting it. I had a similar issue and when I logged back in again, it worked. Worth a shot.
     
  9. jerry33

    jerry33 S85 - VIN:P05130 - 3/2/13

    Joined:
    Mar 8, 2012
    Messages:
    12,754
    Location:
    Texas
    I've found that sometimes it does and sometimes it doesn't. Weather seems to affect this ability--the colder it is the less likely it is to wake up. (5.9)
     
  10. Chipper

    Chipper Active Member

    Joined:
    Sep 23, 2013
    Messages:
    1,182
    Location:
    Chattanooga, TN
    I am wondering if it is because the app itself is getting so long in the tooth??? Tesla has made MANY changes to the software over the past months and the app has not been updated in a LOOOONG time (particularly the Android app).
     
  11. Brightonuk

    Brightonuk Member

    Joined:
    Mar 16, 2014
    Messages:
    377
    Location:
    Plantation
    I installed VT a few weeks ago (awesome app) but I had the exact same problem tried to pre cool the car using VT went out 10 minutes later and it was still asleep.
     
  12. tezzla

    tezzla Member

    Joined:
    Jul 14, 2013
    Messages:
    545
    Location:
    SoCal
    My car has been sleeping since around 7pm last night & I just woke it up with the app (about 30 seconds). No problems (v5.11)
     
  13. jpasqua

    jpasqua P19325

    Joined:
    Feb 19, 2013
    Messages:
    696
    VisibleTesla uses the same API to wake up your car as the official iPhone app. There are times when VT will fail to wake up the car. In all of my tests, when VT fails, so does the official Tesla mobile app.
     
  14. RCH1708

    RCH1708 Member

    Joined:
    May 31, 2013
    Messages:
    276
    Location:
    Maarheeze, Netherlands
    I took my MS out of sleep mode today and accessing it with the app was fine - although it wasn't instantaneous. Also, it only lost 1km of range between 9am & 5pm sat outside my office (it lost 4km of range from 5pm to 5:25, when I turned the a/c on to cool it!).

    Note that VisibleTesla has not been working properly for me for sometime. It misses 50% of my trips. I did post about this a while ago, but I guess my post was overlooked. Maybe I'll try it again now that I've set sleep mode off.

    Rob.
     
  15. jpasqua

    jpasqua P19325

    Joined:
    Feb 19, 2013
    Messages:
    696
    I don't want to derail this thread, but just a quick response. VT will not reliably capture trip data when the app is in sleep mode.

    Having said that, I'm sure there are still bugs, so if you see trips not being captured, I'd appreciate it if you could send me log files to help me debug. The FAQ describes where to get the log files and where to send them.

    Thanks,
    Joe
     
  16. RCH1708

    RCH1708 Member

    Joined:
    May 31, 2013
    Messages:
    276
    Location:
    Maarheeze, Netherlands
    Hi Joe,

    Sure, I'll do that. But note that VT did not capture trips that I could follow on my iPhone. I had occasion to want to replay a trip that I'd tracked on my iPhone and it hadn't been captured by VT.

    I hadn't really bothered you with it beyond the initial report because I haven't had the time to isolate the circumstances sufficiently to make an accurate report and I know how busy you are...

    Also, the initial problem occurred around the time that there problems/changes with the Tesla servers and I initially wasn't sure if that was the issue.

    Rob.
     
  17. jpasqua

    jpasqua P19325

    Joined:
    Feb 19, 2013
    Messages:
    696
    Thanks. I appreciate the help isolating the problem. Feel free to email or PM me.

    Joe
     
  18. riceuguy

    riceuguy Member

    Joined:
    Dec 17, 2012
    Messages:
    169
    Location:
    Austin, TX
    You know what just dawned on me? Perhaps these incidents are occurring when Tesla is having server issues. Once in a while the app is unavailable to all due to communication or server issues. Could be a case of bad timing?
     

Share This Page