TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker and becoming a Supporting Member. For more info: Support TMC

Driver Assistance - Unavailabe (after charging)

Discussion in 'Model S' started by Struja, Apr 12, 2018.

  1. Struja

    Struja "Fanboy"

    Joined:
    Jun 27, 2017
    Messages:
    984
    Location:
    Toronto, Canada
    I know there have been other threads on this but my issue seems to be a bit different.

    I have come to realize that any time I use a supercharger (and probaby even my HPWC) and I stop charging before I am full (meaning getting to my 90%), I get the above error. However, it ONLY happens when I stop the charging (and it doesn't matter how I stop it).

    I have tried the app, I have tried from inside the car and I have also manually pressed the button on the cable and each method ends the same way... "Driver Assistance features unavailble" or disabled (or some derivative thereof).

    This is especially annoying for long trips. So, this past weekend I was driving back from Windsor to Toronto and I stopped at Comber and got the charge I needed to continue and get to Woodstock. Once I got it, I ended the charging session via the app unplugged and started down the road. By the time I was back on the highway, I got the error and I couldn't use autopilot or even cruise control. This was about a 1.5 hour stretch I drove wtih neither feature and the annoying error message.

    Am I doing something wrong when supercharging? This has even happened at home when I've interrupted my charging so it just seems like the car always wants to end charging when complete, if I don't want that error to happen.

    Thoughts on a work around? (As an aside....I have an appointment next week with Tesla so I will address this but figured I would ask here as well). Thx.
     
  2. mblakele

    mblakele beep! beep!

    Joined:
    Mar 7, 2016
    Messages:
    1,619
    Location:
    SF Bay Area
    That doesn't sound normal: let us know what the SC says.

    Meanwhile as a workaround have you tried a deep power-off? That always clears the "Driver Assistance unavailable" error for me. I mostly seem to see it when the sun angle creates a lot of glare or lens flare for the HW1 camera. Anyway: Controls -> E-Brake/Power Off -> Power Off. Then don't touch the brakes or doors or any controls for three minutes. Use a timer if possible
     
    • Like x 1
  3. Struja

    Struja "Fanboy"

    Joined:
    Jun 27, 2017
    Messages:
    984
    Location:
    Toronto, Canada
    Thanks for the deep power off suggestion. I've never done that but I certainly would be willing to try anything.

    I am one of those guys that REALLY enjoys auto pilot or even just cruise control. When I lose both on a long trip, it's very annoying.
     
  4. boaterva

    boaterva Supporting Member

    Joined:
    Apr 2, 2016
    Messages:
    7,466
    Location:
    Northern Virginia, USA
    Yeah, I've never seen this or heard of this. Only comment I can think of: how are you disconnecting the handle from the car? I always hold the button down, wait for the ring color to turn white, and then pull the handle out.

    Some people think you just push the button once and release it, and that doesn't sometimes unlock it correctly. Just a thought if perhaps the car is in some weird state when you are disconnecting the power!
     
    • Like x 1
  5. Struja

    Struja "Fanboy"

    Joined:
    Jun 27, 2017
    Messages:
    984
    Location:
    Toronto, Canada
    That's the thing...I've tried multiple ways of doing it and nothing seems to escape this error (and yes, pushing and holding the button until the ring turns to white is one of the methods of tried to no avail).
     
  6. boaterva

    boaterva Supporting Member

    Joined:
    Apr 2, 2016
    Messages:
    7,466
    Location:
    Northern Virginia, USA
    Hm.... if the car is truly okay with you disconnecting it.. :) I've never heard of this issue before. I'd definitely have the SC or call tech support and have them examine the logs. That may be quicker and it should be obvious what happened when you ended charging.

    Calling when the west coast isn't awake yet gets you a quicker answer on the phone. :D
     
  7. pyraca

    pyraca Member

    Joined:
    Mar 3, 2018
    Messages:
    24
    Location:
    San Jose, CA
    This happened to me randomly it seems like 4 times since I received the car. The way I can tell is that the car is not displaying anything like lanes, speed limit signs, or other cars. And both TACC and steering is not available.

    This did happen once after supercharging but I am pretty sure it was done supercharging when I got in and drove.

    The symptom is the same though: not available for the duration of the drive.

    After stopping for some amount of time and exiting the car it "fixed" itself. That time was a few minutes at least in one case... The last time it happened i drove it to the SC and showed it to the tech. He noted the time for log retrieval and when the car goes there in a few days they will look.

    It's hard to to say what had caused it. It happened once day after delivery, next time at 6am like a month later when I was driving to work, once after a supercharger session (but one that ended), and once recently when I drove home from work.

    If you have a reproducible case that's great. I am still looking for my planet arrangement.
     
  8. fataldeadlock

    fataldeadlock Member

    Joined:
    Mar 5, 2018
    Messages:
    28
    Location:
    South Oklahoma City
    I will second the deep power-off. I had some random issues with "Driver Assistance Unavailable", but more concerning to me was that my frunk was unlatching itself and consequently setting off the car alarm once per night, and even once while driving. I called the service center and was instructed to to a full power off, this appeared to fix both issues for my AP 1.0 car.
     
  9. Struja

    Struja "Fanboy"

    Joined:
    Jun 27, 2017
    Messages:
    984
    Location:
    Toronto, Canada
    Your description of the "fix" is exactly how mine fixes. Need to leave the car for a few minutes and let it really turn itself off and then when you get back in, all is okay... However, I didn't want to do that while highway driving.
     
  10. pyraca

    pyraca Member

    Joined:
    Mar 3, 2018
    Messages:
    24
    Location:
    San Jose, CA
    I had the car once to the SC a week after delivery to fix some fit and finish issues. They had scanned the logs and claimed there was nothing obvious that would point to an error and since they could not duplicate it I went on my way.

    They did see in the logs that the TACC did not want to engage. But at that time had no idea why. It's happened now 4 times ... turning the car for this and other minor issues soon. Will see what happens.
     

Share This Page

  • About Us

    Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.
  • Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


    SUPPORT TMC