Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register

HD Radio bugs - subchannel issues (not resuming correctly/switching order incorrect)

MarkBrokeIt

Member
Apr 21, 2018
282
243
Seattle
Not sure if the terminology is correct here. But there's HD1, HD2, HD3 streams for some stations. The HD1 is the "main" channel, and the HD2/3/etc. ones are subchannels. Or at least that's what I'm calling them in this thread :)

Issue #1 - Radio switches back to main channel after being idle

I have an HD Radio subchannel (HD2) selected. I go into a store for a little while, or leave the car overnight. I return to the car, and the tuner has switched back to the main channel (HD1). Expected behavior is that it stays on the subchannel I've selected.

Issue #2 - Selection order for HD Radio subchannels doesn't make sense

Here's the toggle order when I go from the lowest # station to the highest # station (move the scroll wheel to the right)
106.1
106.9 HD1
106.9 HD2
106.9 HD3
107.7

When I have HD2 or HD3 selected & press the wheel left, it changes to 106.1. I would expect the navigation through the stations to be the same no matter which direction I move the wheel.

I'm currently on 2019.40.50.1, but I believe both issues existed on earlier revs as well.

Anyone else experiencing these issues?
 

Products we're discussing on TMC...

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top