TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker and becoming a Supporting Member. For more info: Support TMC

USB MP3 Playback issues

Discussion in 'Model 3: User Interface' started by ChrisPDX, Jun 2, 2018.

  1. ChrisPDX

    ChrisPDX Member

    Joined:
    Mar 19, 2013
    Messages:
    215
    Location:
    Hillsboro, OR
    When I got my Model 3 back in February, I simply took the thumb drive out of my Model S and installed into the Model 3. However, I noticed right away for the vast majority of my MP3 files, it would give a playback error message. Only the FLAC files played properly and about 10 MP3 files (out of 260). So I brought the car into the service center this past week to have a rattle addressed and also had them look at this issue. They tried my thumb drive in another Model 3 and it didn't play in that car either and when they tried their own music, they said it played fine. So they wrote off the issue as saying my music was corrupt (even though I specifically mentioned the music played fine on the Model S).

    So after taking the car home, I did a close comparison to the few MP3 files that played and those that didn't. After a bit of troubleshooting, I noticed it was a tag issue! If the files had ID3v1, ID3v2.3 and APEv2 tags, it wouldn't play them. I used a program called Mp3tag to clear all tag data from the files and import it back in using the file names for artist/song info. This removed the APEv2 and just left ID3v1 and ID3v2.3 tagging info. Sure enough, they all play now (at least the ones I've tested so far)! I've sent an E-mail back to the service center to have them raise a formal bug complaint on this and specified the tag info. Hopefully they will get this working like the Model S/X system. So if you have issues with MP3 playback, I would check the tagging on them.
     
    • Informative x 2
    • Like x 1
  2. Tdriver

    Tdriver Member

    Joined:
    Jan 20, 2015
    Messages:
    337
    Location:
    Palm Desert, CA
    Notice that AAC files give you an error also on the M3......maybe someday it will play them.
     
  3. colettimj

    colettimj Member

    Joined:
    Feb 20, 2014
    Messages:
    145
    Location:
    United States
    I just found this thread a few days ago. I fiddled a bit with Mp3tag and I think you can just configure it to delete specific tags. Under Settings (or maybe Preferences?) check next to APE for 'Remove' and leave the others selected. Then I think it's just Ctrl-X to remove the tags from the selected files.
     

Share This Page

  • About Us

    Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.
  • Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


    SUPPORT TMC