TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker or making a Paypal contribution here: paypal.me/SupportTMC

Issues charging 85D at Eaton charging station

Discussion in 'Model S: Battery & Charging' started by Morinar, Jun 19, 2015.

  1. Morinar

    Morinar New Member

    Joined:
    Jun 19, 2015
    Messages:
    2
    Location:
    South Jordan, UT
    Hi all!

    I just got my Model S a few days ago and I tried to charge with the Eaton stations we have at work. I took the plug from the station, attached my SAE J1772 adapter, and plugged it into the car. The car initially blinked green and everything seemed OK, but very shortly afterward, the red "fault" light on the station lit up and the car told me to check the power source. I tried multiple stations and even dropping the amps down to 30 on the in car screen. Does anybody have any idea what could be going on here? Below are some pictures of the station in question (that are upside down for some reason).

    Thanks for the help!

    IMG_2262.JPG IMG_2263.JPG IMG_2264.JPG IMG_2265.JPG
     
  2. Max*

    Max* Autopilot != Autonomous

    Joined:
    Apr 8, 2015
    Messages:
    4,866
    Location:
    NoVa
    Are you sure you connected everything securely? I only ask because less than a week with the car, I tried charging at a local station with the J1772. I plugged in the car, it turned green, and almost instantly turned orange? (maybe red?). I took everything out, re-secured the connections, made sure everything is snug and everything worked.
     
  3. Morinar

    Morinar New Member

    Joined:
    Jun 19, 2015
    Messages:
    2
    Location:
    South Jordan, UT
    90% sure? I unplugged and replugged everything 3 or 4 times. It's certainly possible I didn't get it all secure, but I *think* I did.
     
  4. Lloyd

    Lloyd Active Member

    Joined:
    Jan 12, 2011
    Messages:
    4,885
    Location:
    San Luis Obispo, CA
    Eaton does have a firmware update available for their units. This one may need that firmware udate.
     

Share This Page