TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker and becoming a Supporting Member. For more info: Support TMC

Phone App: iPhone app login?

Discussion in 'Model S: User Interface' started by nickt, Feb 8, 2013.

  1. nickt

    nickt Member

    Joined:
    Dec 26, 2012
    Messages:
    27
    Location:
    San Francisco Bay Area
    I've seen some other mentions of people who have signed in to the iPhone app but then get a message about, "No cars linked to your account" or something similar. When I try to login, I get a failed username/password combo.

    My car is supposed to be ready in about a week. Do I use the same login I do at teslamotors.com? Do I need to register a new account somewhere?

    thanks,
    -Nick
     
  2. K Hall

    K Hall Member

    Joined:
    Jan 3, 2013
    Messages:
    339
    Location:
    Kansas City
    it is your TM.com sign in name and password. They won't activate your car until delivery
     
  3. NigelM

    NigelM Recovering Member

    Joined:
    Apr 3, 2011
    Messages:
    13,351
    Location:
    Sarasota, FL
    Don't forget that the password is cap sensitive.
     
  4. nickt

    nickt Member

    Joined:
    Dec 26, 2012
    Messages:
    27
    Location:
    San Francisco Bay Area
    I'm confident I'm typing it in correctly. I suspect either the app won't let me login until I get my car, or it has a bug when users have a '+' in their email address. I'll troubleshoot it with Tesla next week when I pick up my car.
     
  5. gg_got_a_tesla

    gg_got_a_tesla Model S: VIN 65513, Model 3: VIN 1913

    Joined:
    Jan 29, 2010
    Messages:
    6,514
    Location:
    Redwood Shores, CA
    A good old URL encoding (or lack thereof) bug.

    <embarrassed for a fellow developer> :)
     
  6. rlpm

    rlpm S P85 | Sig X _P90D_

    Joined:
    Dec 30, 2012
    Messages:
    235
    Location:
    Albuquerque, NM
    Yeah, I agree with GG.

    Try using %2B in place of the + in your email address when logging in.

    Or go to your profile on the TM site and change your username to something without + in it and try using that username instead of your email address to log into the app.
     
  7. nickt

    nickt Member

    Joined:
    Dec 26, 2012
    Messages:
    27
    Location:
    San Francisco Bay Area
    I'm also an engineer, and *sigh*, they have a URL encoding bug. I did get logged in by using %2b instead of +. I'll file a bug with TM.
     
  8. rlpm

    rlpm S P85 | Sig X _P90D_

    Joined:
    Dec 30, 2012
    Messages:
    235
    Location:
    Albuquerque, NM
    Doh! facepalm
     
  9. Electric Dreamer

    Joined:
    Mar 4, 2013
    Messages:
    45
    Location:
    Houston, Texas, United States
    My phone opens the ap sometimes, and then says there is no car....such a tease! But the car is in production, so I'm patiently (biting nails) waiting! :cool:
     

Share This Page

  • About Us

    Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.
  • Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


    SUPPORT TMC