Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register
  • The final cut of the 9th episode of the Tesla Motors Club Podcast, featuring Chad Schwitters, the former president of Plug In America, is now available. You can watch it now on YouTube or listen to it on all major podcast networks.

phone key fails after upgrade

Had similar issue : iphone inactive, impossible to open or start the car
the app would still be connected
so the iphone would not let the « add key » procedure : kind of deadlocked situation
what i did
-update tesla app on iphone
-(option: maybe update tesla M3 firmware?)
-be sure to have your main card key at hand
-be sure to delete iphone from the key list in the car
- reboot iphone ( not sure needed, but helps to reset a lot of stuff)
-reboot M3 ( push brake and 2 scroll wheels)
-wait for car power up
-enter the key menu
-when iphone back on : disconnect bluetooth (main switch on iphone) : I then got a message that the car would not be opened or connected because bluetooth off…just ignore it)
-enter « add new key » on the key menu in the car
-reconnect bluetooth « on » on iphone ,
-wait for the iphone to show restored list of devices , specially a tesla « connected »
-go to or open tesla app : you get a message that your phone can be added as a key
-go for it , full normal procedure , validate with the main card key

if it worked : iphone is back on the key list and works fine
I believe tesla is using a separate ( hidden?) bluetooth channel for the key , so the entertainment on bluetooth might be ok while key role is not operative , this you need to shutdown ALL bluetooth on the iphone …
my 2 ç
Marc
M3LR
The iPhone as a key is not a problem. The car still recognizes it as a key, just not on the blue tooth as “Tesla model 3, and no (i) designation to remove. Went through all the steps u suggested, still car connects as a series of numbers & letters (key), but no blue tooth recognition. Still waiting for Apple to come back Monday after having copied full blue tooth log
 
Same issue. iPhone 8 Plus. 2020 M3P. Connection problems started about 2months ago. Tesla service out yesterday. Basically said car checks out. Technicians iPhone 10 and wife’s iPhone 12 seem to work fine. Thinking phone upgrade, but seems like sone here with newer iPhones still having connection issues. Hopefully software fix out soon. Very frustrating. Done want to unnecessary drop 1k on new phone if not the problem/solution.
 

srs5694

Active Member
Jan 15, 2019
1,290
1,629
Woonsocket, RI
Sorry for reviving a 3-month-old thread, but this turned up first in a Web search, so I thought I should share my recent experience....

I recently bought a new phone (a Pixel 6 Pro), and it arrived today. Things started out well (Google has made the transfer of data from an old phone very easy), but it went downhill from there. After seeming to pair as a key, the new phone failed to work when I actually wanted it to, and I ended up deleting the Tesla app (multiple times), re-starting the phone (multiple times), restarting the car's computer (multiple times), and it still wouldn't work. I tried the procedure above and it didn't work. At different times, the option to set up the phone as a key disappeared from the Tesla app or failed with a "disconnect other paired devices" message. This was infuriating, because I didn't have anything else I'd paired with either the car or the phone with me. In frustration, I set off to my nearest Tesla store to see if they'd have better luck. When I was a couple miles away from the store, I realized that the "other paired devices" might have referred to my old phone, which, although it was not with me in the car, was likely within Bluetooth range in my house. Sure enough, when I pulled into the parking lot, the new phone paired and worked when I tested it. Tesla could be more specific about this in their error message. Time will tell if the phone-as-key works in the future....

Anyhow, if somebody else finds this thread in a Web search and is having similar difficulties, my suggestion is to turn off all other phones that are paired with the Tesla, or at least disable their Bluetooth. My hypothesis is that the Tesla needs a clean signal from one phone to set it up as a key; any others may interfere with that operation.
 

Products we're discussing on TMC...

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top