Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.

Steering wheel controls replaced still not working

Hi all,

I know this has been discussed proper but I’ve replaced both the steering wheel controls brand new and the clock spring (used) or SCCM on my model s and no luck.

All buttons on the steering wheel do not work, no errors, stalks work fine, horn only works from the app. Not by pressing down on itself.

Any ideas? 2015 p85d.

I looked at one of the fuses i the frunk that I thought might be the culprit but it looked normal.
That’s very interesting - my 2015 X is in exactly the same condition and it happened just a couple days ago. Did you ever get yours fixed?

Idiots at the service center wasted my time by claiming it needed the SCCM, then when I get there, “oh there’s lots of aftermarket things and it needs an airbag module which we don’t have” which tells me that they are fishing and don’t have a clue.

I asked if it has a clockspring and the answer is no - which I think is BS.
I wouldn't trust them to correctly diagnose which lights on the car are red and which are white.

The lies from the service people are the biggest thing that pisses me off. If they don't know something, say that they will research it and get back to you, don't just make shiit up!
So the service visit was a waste the first time - but my time in this city has dragged on and I got bored, so I thought I'd go back and just buy the SCCM over the counter and try to put it in myself. There IS a clockspring in the SCCM and it isn't a separate component. So that's one thing proven from the service droid not knowing what she was talking about before.

Had a long conversation with a service manager who seems actually dedicated to improving the customer service profile of the company. (I wish him MUCH luck, he's gonna need it). He was also saying the proper thing is a replacement airbag - because the switches are part of the airbag.
Here's the thing.... They aren't. They are part (screwed in so they don't HAVE to be) of the bezel AROUND the airbag, but they aren't the airbag itself of course. I pulled the wheel off and the clockspring looked just like the new one so there's no joy there, it is probably the switches b/c it seems like there might be a central IC under the airbag.

Do they sell the switches? Of course not! Do they sell the bezel? NOPE! They sell the AIRBAG (but NOT over the counter!) and it's a..... wait for it..... One THOUSAND dollar replacement. Because OF COURSE IT IS!

So for $30 of Chinese switches, your only option with them is replacing the entire airbag "module" that isn't a module, it's a screwed-in-and-spring-loaded airbag trapezoid attached to the cheap plastic bezel and buttons that you actually want. THIS is why people hate Tesla. Because they have to reinvent the fecking wheel at every turn, and make it a thousand bucks every time.

Oh, you need a shock for your car? That's $985. The brakes? (which you really shouldn't get them from a dealer anyway) That's $1100, for the pads that cost us $85 per axle. Glass for the roof, that's a rectangle 18x24 inches? $1200. Each.

They are idiots.

I've ordered a bezel with buttons for $200 off Ebay b/c it will arrive just as I get back from this road trip, otherwise I'd have gotten ONLY the buttons from a Chinesium supplier for $55, but that would have likely taken the better part of a month to arrive. The only question I have is about the horn button, b/c it doesn't seem like there IS a button but maybe it is part of the wiring hidden by the airbag itself. The boom boom doesn't make beeping, it only has the scary yellow wires going to it.
Damn, I’ll probably go through the same issue. Did you get a full diagnosis from the dealer? I tried to check some possible fuses and see if any wires could have gotten loose or frayed
The only "diagnosis" was that I needed a new airbag, even as they were admitting that it hadn't blown up in my face AND wasn't likely to, AND was still capable of functioning in the need of safety.

The bezel and buttons from Ebay haven't arrived yet. Maybe tomorrow.
sorry to hijack this thread but I replaced the scroll wheel on the left side and after that I got a very weird issue on the right side buttons.
As you can see the scroll wheel and voice button do not work at all, bottom button does. But when I honk it activates the voice!? I opened it up, replace the entire button/scroll wheel module with a used one from eBay and the same thing happened. I tightened all the cable connections that I could see. I’m wondering if something else was damaged on that side since I was yanking on it pretty hard before I realized the right side screw on the back of the steering wheel wasn’t completely loosened.
Got the wheel components today - and I can now use my horn again! Discovered a couple things:

The metal frame that supports the airbag and has the springs attached to it, has a plastic tray hidden underneath that is secured with 3 or so silver torx screws.
There are two contact switches under the plastic tray, which connect to the buttons via the smaller white connectors. They appear to be very simple contact switches.
There is a crossover wire which connects from one button set to the other.
The heater ECU is a separate component that connects through the brown clockspring connector.
I did not have the heater ECU before, now I do. The wiring for that is just tucked away in the center of the wheel for now. No idea if it will want to function without more work (and a heated wheel which I don't have)
There is NO PROGRAMMING for the buttons.

So if this should happen in the future, you CAN replace just the buttons on the wheel and source them from ebay for about $50.
  • Like
Reactions: KalJoMoS
How did you get them new from Tesla? The service center droids in Texas insisted that it could only be done as the “airbag module” as a complete assembly. I thought at the time (now confirmed) that that was complete nonsense… But that’s what I was told.

In your case though, have you tried replacing the SCCM? In service mode, under (IIRC) the steering section, can you see the angle adjust when you rotate the wheel? When you pull the wheel off, does the clock spring look damaged or are the wire tapes intact?