TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker and becoming a Supporting Member. For more info: Support TMC

Trucks no longer being displayed on speedometer

Discussion in 'Model S: User Interface' started by insaini, Apr 16, 2018.

  1. insaini

    insaini Member

    Joined:
    Nov 9, 2017
    Messages:
    145
    Location:
    Toronto
    #1 insaini, Apr 16, 2018
    Last edited: Apr 16, 2018
    Not sure how long this has been going on for but I recently noticed that trucks or any large vehicles are not being displayed as a truck image on my speedometer but just displays as a normal car.

    When i first picked up the car a couple of months ago, it would show an image of a truck in front of me if it were a truck or display a car if it was a car in front.

    Anyone else notice this or is it just me?

    Use to display trucks like the image below .. now it just shows a picture of a car for all vehicles

    [​IMG]
     
  2. boaterva

    boaterva Supporting Member

    Joined:
    Apr 2, 2016
    Messages:
    7,467
    Location:
    Northern Virginia, USA
    Uh... AP2.x never did this? AP1 did. Are you sure you didn't take a demo in an AP1 car or something?


    AP2 has never done anything except the generic car it does now.
     
    • Like x 4
    • Informative x 1
  3. insaini

    insaini Member

    Joined:
    Nov 9, 2017
    Messages:
    145
    Location:
    Toronto
    brand new model s 75 D picked up December 2017 .... did this up until Feb from the last time i saw it ...

    it definitely showed a truck ...
     
  4. SeBsZ

    SeBsZ Former Vendor

    Joined:
    Aug 1, 2017
    Messages:
    1,052
    Location:
    The Netherlands
    A brand new Model S from December 2017 would have been AP2 or AP2.5 for sure - those have never displayed trucks or motorcycles.
     
    • Like x 4
  5. boaterva

    boaterva Supporting Member

    Joined:
    Apr 2, 2016
    Messages:
    7,467
    Location:
    Northern Virginia, USA
    Anything after August 15 (or so) was 2.5 My September X is one. And, yeah, no trucks. :D


    I guess the next question is, what's the manufacturing month/year on the sticker next to the driver's door jamb (B Pillar). This is getting weird...
     
  6. RayW

    RayW Joy Riding

    Joined:
    Nov 9, 2016
    Messages:
    397
    Location:
    Cypress
    This is weird. Could the factory inadvertently install a future release of the AP 2.x software when the MCU was configured last fall?
     
  7. insaini

    insaini Member

    Joined:
    Nov 9, 2017
    Messages:
    145
    Location:
    Toronto
    i placed order Oct 23 2017 .. received vin sometime in November and car was delivered Dec 18 ....

    I know for a fact that for the first couple of weeks I could see images of trucks on the dash screen when a truck was in front of me ... it was my wife who actually pointed it out to me and so I just reconfirmed with her that yes trucks were being displayed ....

    The only thing i can think of is ... i had a service call on my car late January because i received an error on the car saying emergency braking disabled and my navigation would not track me it was stuck in one spot.

    After the service call they told me they updated the firmware to the newest one ... and I think that may have been the last time I saw trucks appearing on my dash...

    I only noticed this weekend that they haven't been appearing because my wife brought it up when we were behind a truck...

    my car has AP 2.5 .. and it def showed trucks so im not sure whats going on here?
     
  8. insaini

    insaini Member

    Joined:
    Nov 9, 2017
    Messages:
    145
    Location:
    Toronto
    here is the service invoice from that service call ....

    Concern: Customer: Navigation marker freezes while driving
    Pay Type: Goodwill
    Corrections: Navigation General Diagnosis
    Confirmed owner's concern; Removed and replaced DAS ECU (Driver assistance service
    electronic control unit); performed multiple function test; verified navigation working as
    designed.
    Corrections: Install 2nd Generation Autopilot ECU
    Confirmed owner's concern; Removed and replaced DAS ECU (Driver assistance service
    electronic control unit); performed multiple function test; verified navigation working as
    designed; Please note; Driver assistance features will not be available for approx 500km
    as the system needs to re-calibrate.
    Part Quantity
    ASSY,AUTOPILOT.ECU,2.5 - FUSED
    (1125800-70-B)
     
  9. kvandivo

    kvandivo Member

    Joined:
    Sep 11, 2017
    Messages:
    179
    Location:
    Downstate Illinois
    What's the little speedometer looking thing with an arrow.. (to the left of the current speed 68)? I'm pretty sure my Dec build car doesn't put that there.. (though I couldn't tell you off the top of my head what icon DOES show up there)
     
  10. nanimac

    nanimac Aloha!

    Joined:
    Nov 27, 2012
    Messages:
    2,401
    Location:
    Oahu
    My July Build MX (AP2.0) used to show Trucks and Motorcycles but hasn't since the last update.
     
  11. GatorGuy

    GatorGuy Member

    Joined:
    Feb 25, 2018
    Messages:
    529
    Location:
    Jacksonville
    My AP2.5 doesn't even show vehicles in adjacent lanes.
     
    • Informative x 1
  12. TaoJones

    TaoJones Beyond Driven

    Joined:
    Nov 10, 2014
    Messages:
    3,064
    Location:
    The Americas
    #12 TaoJones, Apr 16, 2018
    Last edited: Apr 16, 2018
    Well, it’s not 4/20 quite yet, so... I vote unicorn.

    And in that spirit, a visual aid:

    68F7C2EB-B9A7-401E-A153-3982169E966D.gif

    For what it's worth, I've never seen so much as a single truck or bicycle or motorcycle icon in the IC since being led to believe an AP2 car was an improvement over my AP1 car.

    Nor the adjacent traffic except in the edge case recently noted.

    Whatever the anomaly with the OP's car/firmware, it sounds as if it was exorcised with some enthusiasm.
     
    • Like x 1
  13. kmistry1986

    kmistry1986 Member

    Joined:
    Aug 4, 2017
    Messages:
    130
    Location:
    Cleveland, OH
    I believe thats the "universal" symbol for cruise control. IIRC a few of my older cars had that symbol on the dash and on the buttons themselves. I have never seen that in our Tesla (but we've only had ours for about six months so it could have been on older models/previous software)
     
  14. boaterva

    boaterva Supporting Member

    Joined:
    Apr 2, 2016
    Messages:
    7,467
    Location:
    Northern Virginia, USA
    Right, the 'speedometer' with the lines is AP1. This does look like they upgraded you, but even an AP2.0 hardware didn't do this (from all other reports!). Very interesting.... And, yep, AP2.0 only shows adjacent lanes when you are in the act of changing lanes (automatically, usually).
     
  15. SeBsZ

    SeBsZ Former Vendor

    Joined:
    Aug 1, 2017
    Messages:
    1,052
    Location:
    The Netherlands
    Err, look at the logo at the bottom left of his photo. I don't believe the pic he used was his, it's taken from this website. I call BS until I see better proof.

    Tesla confirms product announcement for October 17 - Pocket-lint

    To be fair he never said that was his photo, just they it showed trucks like in that photo.
     
  16. boaterva

    boaterva Supporting Member

    Joined:
    Apr 2, 2016
    Messages:
    7,467
    Location:
    Northern Virginia, USA
    Yeah, I sorta thought that. This whole topic is weird. I believe the photo was because his car stopped showing the trucks, etc. So, hard to show something that's not there. :D
     
  17. kdday

    kdday Active Member

    Joined:
    Oct 29, 2016
    Messages:
    1,051
    Location:
    AZ
    I can definitely say that no AP2.0/2.5 firmware has shown trucks in the IC. It hadn't happened.
     
    • Like x 1
  18. insaini

    insaini Member

    Joined:
    Nov 9, 2017
    Messages:
    145
    Location:
    Toronto
    the photo is not mine guys .. never said it was .. i edited the post and attached the image to show you guys what i use to see when i picked up the car ..... also .. i never saw multiple lanes ... only the cars infront of me ... the only thing i am saying i saw is a picture of a truck when a truck was infront of me ... and now it just shows a car for all vehicles.
     
  19. SeBsZ

    SeBsZ Former Vendor

    Joined:
    Aug 1, 2017
    Messages:
    1,052
    Location:
    The Netherlands
    Do you have any idea what firmware your car was on at the time? Maybe you took a screenshot of the Tesla about screen when you first got the car?
     
  20. RayW

    RayW Joy Riding

    Joined:
    Nov 9, 2016
    Messages:
    397
    Location:
    Cypress
    Tesla engineers are either scratching their heads or having a good laugh right now.
     
    • Like x 2

Share This Page

  • About Us

    Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.
  • Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


    SUPPORT TMC