TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker and becoming a Supporting Member. For more info: Support TMC
Start a Discussionhttps://teslamotorsclub.com/tmc/tags/

App does not unlock car

Discussion in 'Model S: User Interface' started by mastermason11, Oct 24, 2016.

  1. mastermason11

    mastermason11 Member

    Joined:
    Aug 20, 2016
    Messages:
    29
    Location:
    Cerritos, CA (SoCal)
    never really used the app until recently. All functions work with the exception of unlocking the car.

    Anyone else had this issue ?

    I have a 2013 P85 #05442
     
  2. scottm

    scottm Active Member

    Joined:
    Jun 13, 2014
    Messages:
    1,932
    Location:
    Canada
    Apple or Android?

    Version of App?

    ..maybe update App try again
     
  3. mastermason11

    mastermason11 Member

    Joined:
    Aug 20, 2016
    Messages:
    29
    Location:
    Cerritos, CA (SoCal)
    Apple

    Dont think its the app. I've tried using the tesla app and third party apps and same result. I might have to stop by the SC to sort this out.

    Thanks.
     
  4. Boatguy

    Boatguy Member

    Joined:
    Apr 3, 2014
    Messages:
    911
    Location:
    SF Bay Area
    I've used the Tesla app on my iPhone a couple of times to unlock and start the car (my wife had the keys...) several times with no problems. I would definitely check with the SvC.
     
  5. markwj

    markwj Moderator, Asia Pacific

    Joined:
    Apr 10, 2011
    Messages:
    3,975
    Location:
    Hong Kong
    Yep. Me too. Works on my wife's phone. Doesn't work on mine, no matter what App I use. I've tried logging out and back in, uninstalling and reinstalling the App, etc. Nothing solves it, and it has been the same for three phones I've owned.

    Seems like Tesla might know of the problem because when I told the the service advisor about it they asked 'can it lock the car from the App?'. I checked and found it can. So lock works, but unlock doesn't.

    I've got a service center booking for 8th November. I'll let you know if they manage to resolve it.
     
  6. beegee

    beegee Member

    Joined:
    Jun 14, 2013
    Messages:
    72
    Location:
    Wentzville, MO
    Never had a problem using the app to unlock (currently using a Nexus 6)- I get a pop asking if I am sure, hit yes and voila!
     
  7. Akikiki

    Akikiki A'-Lo-HA ! y'all

    Joined:
    Nov 26, 2012
    Messages:
    2,309
    Location:
    Kaneohe
    Just asking because just in case. Are you logging in to the app with your email address or your My Tesla userid/handle? You should be using your email address.
     
  8. markwj

    markwj Moderator, Asia Pacific

    Joined:
    Apr 10, 2011
    Messages:
    3,975
    Location:
    Hong Kong
    I'm using eMail address. Same as on my wife's phone. Hers works. Mine just spins continuously after the unlock confirmation box.
     
  9. Akikiki

    Akikiki A'-Lo-HA ! y'all

    Joined:
    Nov 26, 2012
    Messages:
    2,309
    Location:
    Kaneohe
    Thanks. Interesting problem. Same type phone? Have you delete the App and reinstalled it on yours?
    There's a couple of other non-Tesla apps for the Model S/X, have you tried one of them just to see if the problem persists?
     
  10. markwj

    markwj Moderator, Asia Pacific

    Joined:
    Apr 10, 2011
    Messages:
    3,975
    Location:
    Hong Kong
    Same phone. Same type, same model, same memory. OK, hers is silver and mine is black.

    Yes, I've deleted and reinstalled. No difference.

    Tried three other Apps. None can unlock.

    Only other thing I can think to try is to MITM the SSL connection for hers and mine and see if I can find a difference between the two low-level commands.
     
  11. Akikiki

    Akikiki A'-Lo-HA ! y'all

    Joined:
    Nov 26, 2012
    Messages:
    2,309
    Location:
    Kaneohe
    markwj, interesting problem. Glad its not me, but very interesting. Hope you find the cause. And hope you come back and tell us, just in case.
    One more question, have you connected the phone to wifi and have the car connected to same wifi network, then tried the unlock at your home/garage so its not trying to use cell connection? Just an idea to help rule out some parts of the picture.
     
  12. markwj

    markwj Moderator, Asia Pacific

    Joined:
    Apr 10, 2011
    Messages:
    3,975
    Location:
    Hong Kong
    Yep, same for both wifi and cellular connections.

    Side Note: Although recently I removed the wifi connection for my home network. I found that the 7.x firmware in my car can't transition from leaving wifi to cellular if passing through an area of poor cellular connectivity. It never managed to get a cellular connection, even after entering an area of good cellular connectivity. Turning off the wifi resolves that. Maybe 8.x will fix it permanently, but no idea when that will come to Hong Kong.
     
  13. brkaus

    brkaus Active Member

    Joined:
    Jul 8, 2014
    Messages:
    2,124
    Is the car silver? That may be the problem :)
     
    • Funny x 2
  14. zzzzdoc

    zzzzdoc Member

    Joined:
    Sep 14, 2014
    Messages:
    186
    Location:
    Tampa Bay, Florida
    I had this problem once. I called Tesla, they had me reset the car AND they did something on their end, and all has been well since.
     
  15. redi

    redi 2013 P85+ http://ts.la/dale2363

    Joined:
    Aug 31, 2013
    Messages:
    549
    Location:
    DFW, TX
    I had the problem for at least a year - called Tesla, who was unable to resolve it remotely. They went through all the bs about getting me to delete the app and re-sign-in, my internet connection, yada yada, even though I told them the same issue existed with VisibleTesla, Remote S, etc. I just gave up talking to the folks in CA reading the script and said I would have them look at it the next time the car was in the shop (the local SC is not all that convenient for me to get to). No regular fw updates had any change on this behavior. Everything else on the remote worked fine. Calling CA is mostly a waste of time (like calling the cable company) - nice kids but nothing gets done and nobody knows anything really.

    Then I reported this problem in writing during an annual inspection at the Service Center about 9 months following the above calls. They forgot to address it, or forgot to read the order, noticing my squawk for the first time when I was in 2 days later going through the QA check on the short issue list (3 items) before picking up the car. Nobody at the shop I talked to "ever heard of my problem before". I had to go through the script again, deleting the app, reinstalling it, re-signing in, yada yada. Still nothing. But they noted it now as legit.

    A Ranger arrived at my home the next day and resolved it with a laptop and assistance from the mothership in about 10 minutes. It's remained working since his change.
     
    • Informative x 1
  16. markwj

    markwj Moderator, Asia Pacific

    Joined:
    Apr 10, 2011
    Messages:
    3,975
    Location:
    Hong Kong
    My car is fixed. Took service centre almost two weeks to do it. My Apps couldn't unlock the car remotely, but strangely could lock it remotely. Tesla Technical Service couldn't unlock either.

    Service report says that they 'reset the security system'. Also re-programmed all key fobs (as sometimes key fob couldn't unlock or start car either).

    Similar to the previous poster redi, they ignored my report of this when I put the car in for service. 10 days later, they said the car was ready for pickup. I said I wanted to do a remote unlock test. Did it. Didn't work. They then tried themselves using Tesla Technical Service Unlock and couldn't get that to work either, so finally acknowledged the problem. 2 days later it was fixed.

    Conclusion is that this is a known problem (there are at least three threads just here on TMC about it), but probably kind of rare. If you get it, try to see if Tesla Technical Support can't unlock it. If they can't then they'll probably finally do something about it.
     
  17. faughtz

    faughtz Model S P85DL

    Joined:
    Jan 4, 2015
    Messages:
    91
    Location:
    Los Angeles
    Kudoes to the TESLA Service Center in Torrance. Mark, Tony, Vinny, Rosa. Took car in mostly for a rattle, and they fixed rattle, remote unlock, speed sensor (everybody needs 155mph), and even replugged my CAN device. Nice.
     

Share This Page