Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.

FM radio - is yours working?


Mr. Duck
Nov 6, 2017
Nashville TN
My FM seem to work fine (but no AM that I can see), but can't find where to play music from a USB. Where the heck can I find that source? Thx.
If you have a usb drive connected that has music files (in the working formats) on it, in the sources list at the bottom it's over on the right side. If you don't see it, check your music settings and make sure you have it enabled.


Supporting Member
Supporting Member
Apr 4, 2019
San Diego
My FM seem to work fine (but no AM that I can see), but can't find where to play music from a USB. Where the heck can I find that source? Thx.
  • Like
Reactions: sduck


Jan 4, 2019
Port Hueneme
I'm having the same issue with my radio. It's stuck on the same station and the touch screen controls for it are unresponsive as well as clicking the scroll wheel forward.
I've tried a soft reboot as well as a power off through the user interface and it had no effect. The latest update to 48.30 didn't fix it either.


Aug 14, 2018
I’ve got this same problem. My daughter noticed one day it wasn’t showing the song or station info anymore. Tried changing to another preset station and it would just stay stuck on the same station. Honestly don’t know how long it’s been like this....since I either only listen to the same fm station or streaming radio...but my feeling is that it only started happening recently after one of the updates during the holidays. Direct tune won’t change the station either. 2 button resets don’t fix it. I tried deleting the favorites and rebooting...didn’t work either. I have a service appointment scheduled this Saturday.
Last edited:


Aug 14, 2018
Update. My radio is working now. Huge thumbs up for Tesla and my local service center!

I sent a text last night through the Tesla app about my service appointment this Saturday, asking if they could re-send the latest update. I was already on 48.30 but figured maybe it was a glitchy install. I was sent the update this morning, installed 48.30 again...but no fix. Texted that it still wasn’t working. They replied back saying its a known firmware issue, is supposed to be resolved in the next firmware 48.35 but that they would try to fix it temporarily remotely. Got a call 10 min later saying they fixed it remotely but that a permanent fix will be in the next firmware update. I went out to the car and it’s working. I noticed I was also missing the “stations” tab. When it wasn’t working it only showed favorites and direct tune.


Dec 15, 2019
El Paso, TX
My car had FM, but no LTE. But it's now working too, so wife is a happy camper :). Going on our first long trip tomorrow; we'll see how it goes. We're taking the heavy jackets in case the heat-pump (or a high-pressure sensor, to be more specific) craps out, since we'll be traveling at or near freezing temperatures for several hours. The car is new, and right off the truck, so don't anticipate the 12V battery being bad this soon, which is the only issue I've seen so far that renders the car useless. Hope wind and road noise is not too bad, so I don't have to think about an S. Ha ha.

Products we're discussing on TMC...

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.