Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.

Model 3 key fob: are there any known issues?

Curious to see if there are any known issues with a Model 3 key fob. Mine seems to intermittently not work due to (seemingly) a bad connection with the battery. But as far as I can tell, all the metal contacts with the battery are intact and there should be no reason the key fob shouldn't work.

I ordered a brand-new one from the Tesla shop about a week ago. I got it today in the mail, popped in a new CR2032 3V battery, and successfully paired it with the car using the instructions on the touchscreen. However, when I pushed the key fob buttons, nothing happened.

Turns out it seemed to be an issue with the key fob not sensing the CR2032 battery. I had to keep reseating the battery for it to work. BUt even then, it would only work for a short time. The metal contacts on the inside of the key fob seem fine, but it's just so inconsistent. It will work fine for a few hours, then stop working, forcing me to re-open the key fob to reseat the battery.

Absent a 1 in 1000 chance the one I got is simply defective, dead on arrival, etc. has anyone else had issues with their key fobs? Part of the reason I ask is that a quick search turned up some results from a few years ago about Model X key fobs no longer working when the only change was a battery replacement & Tesla techs needing to order brand new key fobs.

EDIT: it could be user error, sure. But I've replaced the battery in my old Model S key fob multiple times and never had issues.
My wife’s key fob has worked without issues for 3+ years. I have a mouse that loses battery contact that’s solved by aluminum foil enlarging the battery footprint. Also, I’d try a different brand of battery to rule that out. It’s a strange issue, for sure.
  • Like
Reactions: APotatoGod
My Model 3 fob has weird issues with the battery as well. It stops responding and I'd check the voltage at 3.00 VDC the first time. I popped a fresh one in, a few intermittent issues, and just today (2 month old CR2032 which was a fresh Duracell from Costco) it was 3.03 VDC

When I re-inserted this battery it worked fine again.
Try a known Mercedes Benz trick. ONLY use Panasonic Batteries. Duracell and Energizer ones seem to have gremlins in som tech. Our Mercedes still eats a battery every 6 months...but every other brand of battery lasts wayyyy shorter or malfunctions....who knows why?
I am on my second Duracell 2032 since Feb. Glad I keep a keycard in my wallet.

Wonder if the battery just lost connection and if I reseated would have worked. I tossed it earlier but curious.

I don't use the phone because it seems like if I walk near the car it will wake up with the phone? Not sure.

I have a 2020. Can I use a S or X fob that looks similar as a M3 fob? Seem cheaper on here used and eBay.
Last edited:
I always check the CR2032 voltage after I pull it. Their voltage level should still be good, so I am not sure what's going on.

I've set up the Phone Key feature now, and was hesitant to use it because of power draw. But as long as I force close the app, it won't use power. And if I need to use the phone as a key, i Just start the app and it works right away. BUt I am still using the fob. It's on its 3rd or so battery now.
...and low voltage alert for FOB came today. Then cleared.

I added some material to help push it into the slot. If that doesn't work I'll address the coating.

When I ordered this Duracell 2032s from Amazon the package picture showed them without the child protection coating.

Next time I may buy the swiss brand Renata, which also have a reasonable following or Japanese Maxells.