TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker and becoming a Supporting Member. For more info: Support TMC

Poll Dashcam/Sentry Mode USB Failure (Mac or Windows).

Discussion in 'Model 3: User Interface' started by RickW, Sep 30, 2019.

?

If you have had DashCam or Sentry Mode Errors what Operating System did you use to format your USB ?

Poll closed Dec 29, 2019.
  1. Mac OSX (Any version) Fat 32 setting

    100.0%
  2. Windows (Any version) Fat 32 setting

    0 vote(s)
    0.0%
  1. RickW

    RickW Member

    Joined:
    Aug 5, 2019
    Messages:
    145
    Location:
    Seattle
    Hi folks,

    I have had my Tesla Model 3 for about a week now and I have begun to notice a few nuances with Dashcam and Sentry Mode. I have tried several USB sticks, finally settling on a 32 gb Sandisk model. I initially formatted the disk on my Mac to the recommended FAT-32 and placed the TeslaCam folder as directed in the manual. The first day Sentry mode essentially recorded everything, including my garage. Dashcam seemed to have a mind of its own recording every trip. On day 2, the Dashcam vanished and did not become available. I did the appropriate release maneuver to see what had been downloaded and reinserted the stick. Nothing seemed to record on the stick at all. I then removed the stick and reformatted it. The same thing happened as above.

    Acting on a hunch, I decided to reformat the stick, but this time I reformatted it (not using quick format) in a Windows 10 machine. The format took longer than the Mac (15 minutes). After creating the TeslaCam folder I placed the stick back in the car and it worked. This time however, the Dashcam only showed up when I started driving. When I parked, the SentryCam showed up. I removed the stick and went back to the windows machine. I did not change any files, but I reinserted the stick back in the car and it continues to work. I haven't filled the stick with data yet to see if it will start going wonky after that, but there was a definite difference between formatting on a Mac and formatting on a Windows machine.

    Why the hunch? Well, I used to have a linux mini-server at home which ran on a portable drive. I was able to disconnect the drive and plug it back into the mini-server (these were really popular a few years ago, called plug-drive). The only issue I ran into was when I plugged the drive into my Mac to load it with files. When I reinserted the drive back into the Plugdrive, I found that I could not write to it when I was out of the house. I could review files, but somehow it had become corrupted. I did a deep dive into the file system and noted that Windows formatting didn't create a number of "ghost files" or "ghost folders." However the Mac did and it didn't matter if you were downloading or uploading to the disk, the Mac ghost files would appear. These ghost files appear to be necessary for OSX (Mac operating system) to operate. Non specific examples are noted below:

    .Trashes
    .fseventsd


    Once I reformatted the drive (a general pain at the time since they were 500 gb drives - with no easy feat backing them up) with Windows everything went back to normal. Even if the formatting was done with Mac to Fat32 the ghost files would still appear but not when formatted with Windows. I am now wondering if Tesla is using the same Open Source Linux software to drive Sentry and Dashcam?

    Please vote so that we can see if this may be the issue. And for the love of technology and all things wholesome, do not make this a Mac vs Windows debate. For the record I'm a Mac guy so that should end that debate. Also, anyone with more technical know how, please enter the debate to see if my assertions may be correct or flawed. Poll closes in 90 days.

    Thanks.

    Tesla OS Version: 2019.27 (Ver 9).
     
  2. RickW

    RickW Member

    Joined:
    Aug 5, 2019
    Messages:
    145
    Location:
    Seattle
    So, although the small sample size is noted, I think that I can report that it doesn't seem to matter if it's Mac or Windows. The same problem seems to arise. I will be trying a SSD drive this weekend and then a RaspberryPi. I am beginning to think that this is a software issue and not hardware.
     

Share This Page

  • About Us

    Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.
  • Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


    SUPPORT TMC