TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker and becoming a Supporting Member. For more info: Support TMC

Update 40.50.7 major problem

Discussion in 'Software: Firmware Updates, Features, Tesla App' started by Sedman, Jan 3, 2020.

  1. Sedman

    Sedman New Member

    Joined:
    May 4, 2019
    Messages:
    3
    Location:
    Mill Valley, CA
    Just got the 2019.40.50.7 update, and it seems to have “lost” all the nav cameras. No lane markers or nearby cars now show up at all on the touch screen, and therefore the blind spot warning, etc from previous updates are no longer working. Still have radar proximity “arcs” but that is all, while driving (b/u camera still works in reverse).
    I do not have any autopilot upgrades, etc., just the standard LR M3, delivered August 2018. I have rebooted the screen twice and no change.
    This seems like a significant safety issue. Anyone else experience this, or know of a fix? If no fix, can Service set me back to the previous software version? Thanks for any help!
     
  2. linux-works

    linux-works Active Member

    Joined:
    Dec 23, 2019
    Messages:
    1,609
    Location:
    mtn view, ca
    I'd let it go into a full sleep, turn off all things that would stop it from auto-sleeping and let it sleep overnight.

    perhaps that level of 'reboot' will restart any stopped subsystems.
     
  3. Kmartyn

    Kmartyn Member

    Joined:
    Mar 7, 2019
    Messages:
    542
    Location:
    Toronto
    I have had 50.7 for a couple of days with no issues.
     
  4. jdicecco

    jdicecco Member

    Joined:
    Mar 6, 2019
    Messages:
    27
    Location:
    Crystal Lake
    I have seen this. A good hour sleep will fix it.
     
  5. Geoffrey

    Geoffrey Member

    Joined:
    Feb 16, 2016
    Messages:
    7
    Location:
    Oregon
    50.1 seemed ok, I opened the glovebox by voice command, but starting on Jan 2 with 50.?=<7 the phone started randomly calling people when you open the door, Very Embarrassing! I was hoping 50.7 would fix it but No.
    Now, even worse, neither my Android nor my wife's Apple phones can connect to our M3, but from the car we can connect to the phone. But even after connecting, and both the phone and car saying Connected, it won't let you shift to D or R to drive the car, it pops up the Touch key card to console dialog box.
    Voice command and text msg problems in 50.x will eventually get fixed, BUT this is DISABLING!
     
  6. glewis83186

    glewis83186 Member

    Joined:
    Jun 5, 2018
    Messages:
    221
    Location:
    California
    Only thing I notice is I lost the ability to view text messages and have them read out loud!
     
  7. BlkLightning23

    BlkLightning23 New Member

    Joined:
    Dec 3, 2019
    Messages:
    3
    Location:
    Los Angeles
    I’m having the same bugs - no lane markers, no nearby cars on the screen, no cruise control or auto steer, and FSD preview gone. I have a M3 Long Range with FSD.

    I’ve tried the Power Off and hard reboot, neither has worked. The car was asleep for hours while I was at work and nothing was better afterwards.

    Hope they send a better update soon...
     
  8. glewis83186

    glewis83186 Member

    Joined:
    Jun 5, 2018
    Messages:
    221
    Location:
    California
    UPDATE: On my way back from San Diego I stopped for a bathroom break and when I resumed my trip I lost my driving visualization, lane markings, cruise control and auto pilot features. When I finally got to the Kettleman City Supercharger I called my local Service Center and had them push the 2019.40.50.7 update to my car again. It seemed to fixed all the issues I was having expect for the text messaging features. I later got advice from someone on twitter on how to address the matter. Basically I had to delete the phone key, and delete the phone from the bluetooth menu and start all over again. Followed the directions on the release notes and boom! Everything is working as intended. So I would try to reach out to your local service center and go that route. Hope this helps you.
     

Share This Page

  • About Us

    Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.
  • Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


    SUPPORT TMC