Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register

WiFi turning off by itself

f205v

Member
May 12, 2018
649
769
Tessin, Switzerland
When I upgraded from MCU1+HW2 to MCU2+HW3 I lost all of my configurations.
So I set up again my driver profile and "easy entry" profile. Both of them were set up while parked and with the car WiFi connected to my phone hot-spot.
Now, whenever I get into the car and profile goes from "easy entry" to my profile, WiFi switches to OFF.
I can't find a way to set up my profile so that WiFi stays on.
I know that it will disconnect while shifting into gear, this is not the issue I'm talking about. In the past, while shifting into gear, WiFi disconnected, by remained ON and I simply had to tap the wifi icon to reconnect it to my hot-spot. Now it goes to OFF, and re-connection needs for to go through re-switching to ON.

Any help?
TIA
 

jjrandorin

Moderator, Model 3, Tesla Energy Forums
Nov 28, 2018
11,491
13,391
Riverside Co. CA
Thank you @DerbyDave for your suggestion, but it doesn't work.
Whatever profile I create, it always turns OFF by itself when shifting into gear.

It's driving me mad.....

That is by design, I am sure. I realize this is the model S section, but every model 3 turns off wifi when you put the car in gear. You have to manually turn it back on if you are trying to use your phone as a hotspot to not pay for premium connectivity while you drive.

It might be model S owners dont know as much about this, since many of their cars come with premium connectivity, but model 3s for the most pat dont so we in the model 3 section are very familiar with this. The reason for this was put forth as wifi staying ON was causing issues for people who paid for premium connectivity.

If you pay for premium connectivity, and wifi stays on, when you get into your car at home it will be connected to wifi, and if it doesnt shut off wifi when you put it in gear, the car will attempt to stay on your home wifi as you drive off, then disconnectm, causing you to have a lapse in connectivity (shutting your music off if you are streaming, etc). To combat that, tesla defaults wifi to toggling off when you put the car in gear, and there is no setting you can change to make it NOT do that.

TL ; DR. Either pay for premium connectivity if you dont have it, or understand that the car will toggle wifi off every time you shift into gear and you have to turn it back on.


EDIT: I slightly misread OP post as well.. as I missed that OP said "I know wifi switches to off when put in gear
 
Last edited:
  • Informative
Reactions: DerbyDave

Chaserr

Hyperactive Hyperdrive
Sep 5, 2017
2,666
6,523
Logan
That is by design, I am sure. I realize this is the model S section, but every model 3 turns off wifi when you put the car in gear. You have to manually turn it back on if you are trying to use your phone as a hotspot to not pay for premium connectivity while you drive.
It is by design. For the first few years it would retain Wifi in D and there was a minute of no connectivity while it tried to reconnect to your fading Wifi signal as you drove away, until it finally gave up and switched to mobile data. They fixed that dead zone by forcing it to hard cut to Wifi somewhere between v7.1 - v8.
 
  • Helpful
Reactions: jjrandorin

f205v

Member
May 12, 2018
649
769
Tessin, Switzerland
@Chaserr Thank you, but that is not the issue I'm experiencing!
What you are describing is the auto-disconnect when shifting into gear. It was a security feature introduced in v8 to prevent a possible man-in-the-middle attack when leaving your garage wifi. I'm aware of it, and I had the same behaviour BEFORE upgrading from MUC1 to MCU2.

What I'm experiencing now is not a simple disconnect, but a full TURNING OFF of the wifi.
They are 2 different things:
with disconnect the WiFi is still on, and tapping the icon will bring down a list of all available wifi, a second tap on the selected wifi will force re-connect.
In my case wifi goes to OFF, meaning that a tap on the icon will show the wifi setup window, with the switch positioned on OFF. I have to to tap again on ON, tap somewhere else to close the window, tap again on the icon, and finally tap on my wifi hotspot to reconnect.

Basically I went from 2 taps to 5 taps, which is a good 150% LOSS in efficiency!
 
  • Informative
Reactions: Chaserr

whitex

Well-Known Member
Sep 30, 2015
6,790
8,626
Seattle area, WA
It is by design. For the first few years it would retain Wifi in D and there was a minute of no connectivity while it tried to reconnect to your fading Wifi signal as you drove away, until it finally gave up and switched to mobile data. They fixed that dead zone by forcing it to hard cut to Wifi somewhere between v7.1 - v8.
Actually when they fixed it, the fix didn't apply to previously setup WiFi connections. I had to re-setup my WiFi in order for it to automatically disconnect when shifted into Drive. Apparently there is flag in the configuration files (not visible to regular users), but also, I heard (though have not verified as I don't have a usecase for it) that if you setup your WiFi connection in a Model S while the car is in Drive, that flag is set and your car will not disconnect when shifting to Drive.
 
  • Informative
Reactions: Chaserr

jjrandorin

Moderator, Model 3, Tesla Energy Forums
Nov 28, 2018
11,491
13,391
Riverside Co. CA
@Chaserr Thank you, but that is not the issue I'm experiencing!
What you are describing is the auto-disconnect when shifting into gear. It was a security feature introduced in v8 to prevent a possible man-in-the-middle attack when leaving your garage wifi. I'm aware of it, and I had the same behaviour BEFORE upgrading from MUC1 to MCU2.

What I'm experiencing now is not a simple disconnect, but a full TURNING OFF of the wifi.
They are 2 different things:
with disconnect the WiFi is still on, and tapping the icon will bring down a list of all available wifi, a second tap on the selected wifi will force re-connect.
In my case wifi goes to OFF, meaning that a tap on the icon will show the wifi setup window, with the switch positioned on OFF. I have to to tap again on ON, tap somewhere else to close the window, tap again on the icon, and finally tap on my wifi hotspot to reconnect.

Basically I went from 2 taps to 5 taps, which is a good 150% LOSS in efficiency!

Reading your opening post again, you mention "setting up your profile while connected to your hotspot". Have you tried NOT being connected to your hotspot when you setup your profile?

As in, delete your driver profiles, delete all wifi connections (both in the car, and on your phone). Do not connect the car to your wifi hotspot. Re create the profile(s), without the car being connected to your wifi hotspot. Re-Pair the phone with the car (as bluetooth, not wifi). Basically, start all over with the phone and the car, re creating the profile without connecting to wifi. Once you verify bluetooth and phone and profile are all setup, then turn on hotspot on your phone and connect your car to the wifi hotspot on your phone.

I am only guessing here, but setting up your profile while connected to your wifi hotspot might have some flag in it like @whitex mentions. Best to start from square one, and not connect to wifi hotspot while you setup, to ensure there isnt some setting in there that is causing it to toggle wifi off when it disconnects.
 
  • Like
Reactions: f205v

serendipitous

Member
Sep 10, 2019
419
695
Maryland, USA
Actually when they fixed it, the fix didn't apply to previously setup WiFi connections. I had to re-setup my WiFi in order for it to automatically disconnect when shifted into Drive. Apparently there is flag in the configuration files (not visible to regular users), but also, I heard (though have not verified as I don't have a usecase for it) that if you setup your WiFi connection in a Model S while the car is in Drive, that flag is set and your car will not disconnect when shifting to Drive.

I put two and two together, and just went out to confirm what I thought has always been the case with my car (2019 MSP). It's normal for it to take 5 taps.

It's always (since whatever release they introduced the feature) turned WiFi off (not just disconnected it) when you put it in gear. What you must have been experiencing for years was the bolded part up there that Whitex mentioned. You just got lucky because your old connection configuration was grandfathered somehow. Replacing your MCU and re-setting up WiFi made your car work like every other car has when setting up a WiFi connection. It isn't related to this software release.
 

f205v

Member
May 12, 2018
649
769
Tessin, Switzerland
@jjrandorin good suggestion!
My car will be back from the bodyshop next Friday (1) and I will immediately give a try to your suggested method!

(1) Someone left a scratch on passenger side doors and rear quarter panel, it happened the day BEFORE I upgraded from MCU1 to MCU2, so no sentry recordings of the accident. :confused:
 

f205v

Member
May 12, 2018
649
769
Tessin, Switzerland
Got my car back from the bodyshop.
Haven't tried @jjrandorin method yet, but found something odd: when I switch WiFi back ON, while driving, it auto-reconnects to my hot-spot! So I do not have to force re-connection, just switch the WiFi ON and it does it by itself, even while in drive.
 

Products we're discussing on TMC...

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top