Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register

Tesla X Sentry / Dashcam USB drives failing issues

Hi All,

I have never really looked into the dashcam / sentry mode since owning my X however trying to explore its features now. I have recently upgraded the infotainment system to MCU2 a few weeks ago and have been experimenting with it since... espicially since i can now watch recorded events on the screen.

I have a problem with USB drives failing after a few days. All drives purchased from either Bing Lee of Officeworks stores, so none are the fake online specials. Its really a system i cannot rely upon if an event occurs.

I have tried the following drives after reading comments here and there throughout the forms. I had sentry mode disabled when at home for most of these tests.

Symptoms - All are NEW drives:
Samsung T7 1000Gb - Recognises when inserted but formatting the drive an error occurs. never works. I tried partitioning to a 100Gb first partition but same issue. I assume there is probably a limit on maximum size as after reading forums that most people use the 500Gb drives.

Sandisk Extreme 64Gb Drive. Formatted in Tesla, dashcam and sentry working. 3 days later noticed the dashcam icon missing. Asks to format drive again but error occurs. plugged into computer and drive has become read only. After reading up this is a faulty drive according to Sandisk. Used "Flash Drive Tester" program and confirmed faulty

Generic USB Nvme case with samsung 128Gb drive. Formatted in Tesla and worked for a day. afterwards would not recognise a USB is inserted in either USB port. Plugged into computer and could read some footage. [formatted and drive test ok with computer. Inserted back into Tesla and says to insert a drive. confirmed with PC again drive is OK

Verbatim Store and Go 64Gb. Formatted in Tesla at the time working. pressed dashcam a few times during my trip. Checked 3 days later, No dashcam icon and says to insert a USB. will not detect again. Plugged into PC and could read saved footage from 1 day, roughly 5Gb of files found. Copied footage then formatted drive with errors., Used"Flash Drive Tester" program and confirmed faulty.

Could this be related to the new MCU2 or by chance could ALL my drives be faulty? or have i done something wrong?

My Model S doesnt have dashcam/senrty as its an older model and have been happy with the BlackVue dashcam in that. i may do the same in this car as im now using it more often.


1653812392914.png
 
I use a high performance micro SD card (I picked one that was recommended for BlackVue dashcams) and a sandisk microSD-> USB adaptor. It took me a couple of goes to get the right adaptor. (The jaycar ones don’t work) I just don’t think USB drives are engineered the same as micro SD as no one else uses USB for dashcams other than old Teslas.

SD card is Samsung endurance PRO 128GB
adaptor is Sandisk micro SD to USB A 3.0
 
Last edited:

lascavarian

little endian
Supporting Member
Jul 27, 2017
1,563
9,257
usa
Asks to format drive again but error occurs.
It may not be entirely applicable to your problems but EM has acknowledged a SW problem involving the file system and the dashcam. Fix is coming soon OTA.

I can confirm having USB data storage problems on my 2018 model 3. USB drives fail shortly after installation. FORMAT does not work properly.
 

Products we're discussing on TMC...

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top