Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.

Undocumented Change to Cruise Set Speed in 2024.3.6 / 2024.3.10?

This site may earn commission on affiliate links.
I got the FSD trial. Promptly agreed, set it up, tried it out. I didn't mind tinkering and learning but my passengers really weren't comfortable so I disabled it and went back to standard autopilot. No biggie to me, figured I have a month and can flip back and forth.

That's when I notice a difference with cruise speed activation. I've done a bunch of changing modes and settings and have come up with 3 possibilities: it's either a bug, an undocumented change (or I missed it), or it's always been this way and I'm nuts.

I've always had my cruise set to engage at current speed and I adjust from there. I just find it's the smoothest experience for me. Now, even though it's set to current speed, I find Autopilot is engaging at the speed limit and I have to scroll the right wheel up to match current speed. The interesting part, to me, is this is only the case when engaging Autopilot with auto steer on slower, non-divided highways. Here's the behavior and scenarios I've confirmed with current 2024.3.10, and previous 2024.3.6.

- TACC alone, no issues. For example I can be driving 84km/hr in a recognized 80 zone and cruise engages at 84. (2 lane back road with 1 painted center line and soft shoulder, or 1/2 lane road in town with painted lines each side of lane)
- Using Autopilot, on the very same 80km/hr road and recognized 80 zone doing the very same 84km/hr speed, if I double tap the stalk to engage Autopilot the speed sets to 80. If I'm not on the pedal the car slows to 80. If I maintain 84 with the pedal I can scroll the wheel up to maintain the current speed.
- However, using autopilot on a divided highway I don't have the same issue. 100km/hr highway, the car recognizes the zone. Driving at 115km/hr and I double tap to engage autopilot and it sets cruise correctly to the current speed of 115km/hr. No need to have the extra step of messing with the scroll wheel.

I think this is either a bug, or a change in the software to set autopilot to the speed limit on lower speed / non divided highways. I swear I used to be able to use autopilot in a 60km/hr zone, turn it on doing 65 and it would set at 65. Then I could scroll up to 70, where it would limit autosteer to 10km/hr over the recognized limit.

Has anyone else noticed this? Am I right or am I nuts? It's not the end of the world, but is a bit annoying to have the extra step on anything other than a divided highway.

Bonus opinions on the FSD trial.
FSD is better than I thought. But it also isn't perfect and I'm not the biggest fan. Perhaps I need more exposure to it to get more comfortable with it. I will give it more chances. The FSD visuals are amazing.

The deal breaker for me is when FSD is enabled you lose ANY cruise functionality without the rest of the FSD functionality. Like, sometimes I just want the car to hold a speed while I control the rest. IMO you should at least have the option of 1 tap for cruise and 2 taps for FSD.

Enhanced autopilot is OK. But, the lane change functionality should be built into basic AP. It's a helluva lot to pay for something other cars in it's class can already do (maintain or re engage autopilot after lane change). I had to turn off auto lane changes based on speed for both FSD and enhanced auto pilot. I didn't like the bouncing around in heavier traffic, especially when I'm ok with chilling in a lane because I know the turn lane I need is coming up.

Autopark blew me away. While I can still park quicker, and with less pain to the front tires, I've tried it a few times into normal parking spaces and it's been dead center 1-shot parking each time. I just cringe at the heavy steering action while stopped or very nearly stopped. I can hear and feel the front tires screaming in pain lol. I feel like I do a better job of steering with at least some roll to minimize this. But it's still cool!