TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker and becoming a Supporting Member. For more info: Support TMC

Won't Shift in to Reverse or Drive

Discussion in 'Model 3: User Interface' started by PeteInCA, May 16, 2018.

  1. kbecks13

    kbecks13 Active Member

    Joined:
    Dec 27, 2017
    Messages:
    1,911
    Location:
    SoCal
    Call Tesla and let them know it's happening, i'd also suggest using your voice control and saying "Report a bug can't shift into drive" everytime it happens so they have a marker in your log files.
     
  2. AcuraDude

    AcuraDude Member

    Joined:
    Feb 24, 2018
    Messages:
    29
    Location:
    Midwest
    Yes I did put in a call and received the standard 'Try rebooting the car' response. But at the very least he did log my concern. I'll have to write down that report bug in the voice control. I was going to do that right when it happened but couldn't remember what phrase to use.
     
  3. tm3vt

    tm3vt Member

    Joined:
    Sep 14, 2018
    Messages:
    5
    Location:
    Vermont
    Hello! I would like to add my 3 cents... Since both the car and the phone are computers, do basic "computer" fixing steps. I start with my phone - is the app up to date? Is the OS up to date? Reboot (how often do people reboot their phones?? I work in IT, I'm always asking - some people have *never* rebooted the phone, they wait for updates to do it. Oh no!) Usually that does the trick (Tesla unlocks quickly, drives perfectly, app is responsive...) Or, do you have a very old phone that no longer updates? Get a new one or use the key card.

    If that doesn't work, reboot the car computer. I only had to do this twice - both times when first delivered. Hold both scroll buttons down (on the steering wheel) until the Tesla logo appears, then release the buttons.

    And, I'd like to share that at first we weren't getting Tesla software updates and we were several versions behind everyone else. I discovered that the service center forgot to mark our car "delivered". Once they did that, we got updates as expected.
     
    • Like x 1
  4. AcuraDude

    AcuraDude Member

    Joined:
    Feb 24, 2018
    Messages:
    29
    Location:
    Midwest
    Hey thanks for the tips! Yes I have an old Pixel 1 phone. I turn it off several times a week and also turn the blue tooth off and on several times during the week. The phone OS and Tesla app are up to date. I don't really do the car soft reboot much, but I do try to turn off the car once a week through the safety and security screen. Although maybe I'll start doing both weekly.

    I wonder if pushing the brake pedal makes a difference during a soft reboot. When I was on the phone with the help center today, in addition holding the scroll wheels, he said to push the brake too. I've always done the soft reboot like you said where I'd only hold the scroll wheels.
     
  5. M3aem

    M3aem New Member

    Joined:
    Oct 10, 2018
    Messages:
    1
    Location:
    San Francisco
    I've had this happen a number of times over the last month or so. Brought my M3 into service this week for a trunk alignment issue and mention this. Rep speculated it might be an occupancy sensor issue (detecting someone is sitting in the driver's seat). He suggested getting a time stamp the next time it happens, but warned me that there are long waits for techs to review logs and diagnose (though they can do remote).
     
  6. animorph

    animorph Active Member

    Joined:
    Apr 1, 2016
    Messages:
    2,126
    Location:
    Scottsdale, AZ
    I wonder if this is related to the turn signal problems? They have been fixed by replacing the steering column control module, which also replaces the shifter stalk. We have the turn signal problem (most often get continuous blinks instead of just three with a light press). We have also had a problem getting into reverse, although drive worked. Seems like a flakey control module in both cases.
     
  7. BobAbooey

    BobAbooey Member

    Joined:
    Oct 12, 2018
    Messages:
    589
    Location:
    usa
    I had no clue we could do this .....
     
  8. TT97

    TT97 Active Member

    Joined:
    Aug 6, 2017
    Messages:
    2,168
    Location:
    Los Angeles
    That is very courageous admitting not knowing something that is in the manual. Subject yourself to endless scorn! :)
     
  9. colettimj

    colettimj Member

    Joined:
    Feb 20, 2014
    Messages:
    260
    Location:
    United States
    Just wanted to say that I haven't seen this issue in a while, at least since 39.7 (now on 42.4)
     
  10. BobAbooey

    BobAbooey Member

    Joined:
    Oct 12, 2018
    Messages:
    589
    Location:
    usa
    What manual?
     
    • Funny x 2
  11. ecarfan

    ecarfan Well-Known Member

    Joined:
    Sep 21, 2013
    Messages:
    19,179
    Location:
    San Mateo, CA
  12. Superspectral

    Superspectral Member

    Joined:
    Aug 20, 2018
    Messages:
    109
    Location:
    Ann Arbor, Michigan
    I had this problem today. Would not shift out of P. Worked when I reset with both buttons and brake pedal. I had been having the car not recognize my phone and open right away-going to the Tesla app let me in. But when it wouldn’t shift I had no problem getting in.
     
  13. kbecks13

    kbecks13 Active Member

    Joined:
    Dec 27, 2017
    Messages:
    1,911
    Location:
    SoCal
    Yea its not a phone problem, if you try to hit the remote start button when this happens it will say something like "Car is already authorized to drive". It's been an intermittent bug for at least 9 months now :(
     
  14. PeteInCA

    PeteInCA Member

    Joined:
    May 16, 2018
    Messages:
    34
    Location:
    California
    Exactly. Thats' what I tried the other day. Phone unlocked car. Steped on brakes and seat adjusted and car appeared to start but could not shift. I used the app to try and "start" the car and got the message that the car was already running. So I wonder too whether it is NOT a phone problem. Have you had any definitive discussion with Tesla that corroborates that it is not the phone? I understand the logic you're using with the set of circumstances you've described (and I have experienced) but wonder if it could still be a phone thing.
     
  15. RobbL

    RobbL Member

    Joined:
    Jul 13, 2018
    Messages:
    115
    Location:
    Oakland, CA
    I have had my M3 for a month, and also have an iPhone X. I have been on 42.3 for a week. For the first month, I just left my phone in my pocket and everything worked as expected. A few days ago, I had the problem listed here and consistently, could not shift into Reverse or Drive. I had to take out my phone and tap the screen to wake it up, to make it communicate. Following advice on another thread, I toggled Bluetooth off and then on from my iPhone. Function returned back to normal as before and I have had no further problem through multiple starts.
     
  16. DanL3

    DanL3 Member

    Joined:
    Feb 1, 2018
    Messages:
    238
    Location:
    Vancouver, Washington
    Happened to me first time today.

    Was on the key card. Rolled down the window and put the card to the pillar from inside the car. Locked, then unlocked then all worked OK.
     
  17. No_petro

    No_petro Member

    Joined:
    Oct 20, 2018
    Messages:
    41
    Location:
    Maryland
    This happened to me for the first time yesterday.

    The car would not shift into R or D. Did the steering wheel buttons reset and it was back to normal. I'm on 42.3.
     
  18. substance12

    substance12 Member

    Joined:
    Oct 21, 2018
    Messages:
    29
    Location:
    Torrance, CA
    Happened to me today. To fix it I exited the car, waited for it to lock, returned... Worked. Not happy about this.
     
  19. IM_1406

    IM_1406 Member

    Joined:
    Nov 27, 2018
    Messages:
    36
    Location:
    Pennsylvania
    Has happened to me numerous times trying all of the "fixes" I have read on fb or here on the forum. All with phone entry, haven't tried the keycard (I simply prefer not to use that!).
     
  20. sduck

    sduck Mr. Duck

    Joined:
    Nov 6, 2017
    Messages:
    1,378
    Location:
    Nashville TN
    Unpair and re-pair your phone. Do the two button reset. Do it again holding the brake pedal.
     

Share This Page

  • About Us

    Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.
  • Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


    SUPPORT TMC