TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker and becoming a Supporting Member. For more info: Support TMC
  1. TMC is currently READ ONLY.
    Click here for more info.

Won't Shift in to Reverse or Drive

Discussion in 'Model 3: User Interface' started by PeteInCA, May 16, 2018.

  1. Bazza

    Bazza New Member

    Joined:
    Feb 2, 2019
    Messages:
    4
    Location:
    Gold Coast
    E90C6327-EC3A-4ECD-AE70-F858342E34AA.jpeg E90C6327-EC3A-4ECD-AE70-F858342E34AA.jpeg My model S is now 3 months old and recently on several occasions I have put the car in park while my wife left the car and then been unable to get the car out of park and into gear without having to exit the car and re enter and start from scratch.
    Could lead to serious road rage under the rite circumstances.
    Tesla is now looking at my logs and hopefully will find a fix?
    This or similar problems have been reported for some years by others and are still popping up???
    So frustrating not being able to simply drive away.
     
  2. jkeyser14

    jkeyser14 Member

    Joined:
    Jul 30, 2012
    Messages:
    102
    Location:
    Baltimore Area
    I started having this issue last weekend. Have to reboot everytime I get in the car now.
     
  3. alseTrick

    alseTrick Active Member

    Joined:
    May 17, 2016
    Messages:
    1,645
    Location:
    Florida, USA
    This literally just happened to me. First time ever. Almost cried haha.

    Walk up unlock via my phone. Seat auto assisted to my setting. Put it in reverse and nothing. Tried forward and nothing.

    Did the hard reset and nothing.

    Did a Google search. Found this thread. Turned on\off my Bluetooth and did the airplane mode on\off. And then it worked.

    Hope this never happens again.
     
    • Informative x 1
    • Like x 1
  4. Sherlo

    Sherlo Member

    Joined:
    Feb 13, 2019
    Messages:
    348
    Location:
    SF Bay Area

    First time it happened to me (in 7 months). Hard reboot and got out of car (opened to charging port, not sure why or if it mattered). Got back in and it shifted. Glad it was my day off and wasn't trying to flee the scene of a crime o_O
     
  5. Fernand

    Fernand Active Member

    Joined:
    Mar 22, 2019
    Messages:
    1,457
    Location:
    Northern california
    #105 Fernand, Apr 21, 2019
    Last edited: Apr 21, 2019
    Might the OP's issue be a problem with the wand switches themselves or their controller?

    I think we're probably looking at several distinct issues. The phone pairing problems etc sound different from the failure to shift he first reported.

    I've had Bluetooth pairing issues, where the phone won't unlock the car, and variations. Going into Airplane mode on the phone and back again seems to solve that one. It IS very important to update the Tesla App frequently, especially after an over the air car update. I've also had annoyingly slow response with the phone unlocking the car.

    Don't blame Tesla. The whole Bluetooth spec is wonky, and the range is unpredictable. I was trying to use my phone while waiting for my car to be fixed, and couldn't hear the other party. I finally realized it was because it was going to the car that was all the way in the back of the service hall. And there's a ton of interference now from all the technocrap we've spent so much money on. Also most phones are paired with too many devices. It might be a good idea to clear out pairings you don't normally use.

    But I've also had the "can't shift" problem, that one clears after a few tries, like the switch is intermittent. Working the wand(s) vigorously without your foot on the brake to clean the contacts might be worth trying. A Tesla tech confirmed it was microswitches.

    And
    I've had a very annoying variation, namely one out of 4 times it wouldn't go into AP on a double tap. Sometimes nothing, and sometimes it would go into just Cruise instead, barreling ahead without auto-steer, which almost got me into an accident once before I got obsessive about triple-checking.

    The service center tech drove w/ me, confirmed it was real, ordered the part. A week later (yesterday) they took 2 hours to replace the wands and the whole steering column assembly. The tech said they have changed vendors on this part, as they have been seeing these kinds of problems.

    Since then it seemed fixed, but at least once tonight I think it missed going into AP again (no chime, no message, just not "catching" the request). I'll keep checking.


    In my case this was the issue, it might not be yours. My Invoice shows:

    -- "Right wand seems to not consistently engage AP. Sometimes I think AP is on,"
    -- "but it's only TACC. Switch/sensor issue?"

    "Verified, replaced steering column control module.Test drove operation restored."
    "Correction: Module - Steering Column Control"
    "Parts Replaced or Added"
    "Part Quantity"
    "M3 STEER COLMN CNTRL MODULE KOSTAL 1"
    "(1097662-00-L)"
    "BOLT RC M16x1.5x26 PC88 PTP (1036655-00- 1"
    "A)"
    "Kostal 10400691752 (1028053-00-A) 1"
     
  6. Fernand

    Fernand Active Member

    Joined:
    Mar 22, 2019
    Messages:
    1,457
    Location:
    Northern california
    FWIW, it looks like my problem has not been corrected. Or has returned.

    If I double tap the right wand, and auto-steer is unavailable, I believe it
    MUST always do SOMETHING. Enable AS, tell me it's not available,
    throw up some other message, at least chime.

    Isn't that the expected behavior?


    But I was getting nothing again a lot today. And some cases where
    I (only) got TACC instead.

    I'm waiting until tomorrow to do a full reboot,
    I want to confirm how this is happening first.

    I don't think I've had any failure to shift occurrences today, which kind
    of says the wand switch itself is alive.
     
  7. stonelance

    stonelance Member

    Joined:
    Jul 26, 2018
    Messages:
    298
    Location:
    Seattle
    I started getting the "Can't shift into D or R" problem only recently, but happens pretty frequently (like once or twice a week). I am not sure if it is related to the early access build, but also there are higher version firmwares out, so not really sure if my build is really "early access" any more. I think the issue might be related to trying to shift into gear too quickly after getting in\entering the PIN. I suspect some part of the computer thinks it is in gear even though it is not. Putting it "back" into park fixes it:
    - Take foot off brake
    - Put foot on the brake, then put the car into park by pushing the button on the end of the stalk (even though it is already in park)
    - Take foot off brake
    - Put foot on the brake, then shift into gear.
     
  8. SciFriGuy

    SciFriGuy Member

    Joined:
    Sep 8, 2018
    Messages:
    46
    Location:
    Connecticut
    Has happened to me numerous times on 8.3. I've even had it happen partially: was able to move car while screen was rebooting and dark. Waiting for new system to upgrade. Seems I'm way behind.
     
  9. Quickstart88

    Quickstart88 Member

    Joined:
    Mar 19, 2017
    Messages:
    239
    Location:
    Orange County
    If it won't shift, just open and close the door again. Works every time for me.
     
  10. pgergen001

    pgergen001 New Member

    Joined:
    May 21, 2019
    Messages:
    1
    Location:
    Long Beach, CA
    I had issues with not being able to shift into gear, which became chronic in the succeeding weeks. After my Model 3 (purchased Nov, 2018) was in the shop for a couple of weeks, here's the invoice description of the fix that solved the problem for me:

    Vehicle does not shift into gear and receives multiple alerts
    Replaced VC left and updated FW. Performed circuit integrity tests, passed.
    Replaced per Engineering request. No further problems found at this time.
    Correction: Module - Body Controller - LH
    Parts Replaced or Added:
    RWK PCBA, M3 LEFT CONTROLLER (1078673-
    90-K)
    Part Quantity 1
     
    • Informative x 1
  11. 1speed

    1speed Member

    Joined:
    Oct 6, 2017
    Messages:
    104
    Location:
    Seminole, FL
    This happened in my Model S this morning for the first time in the freaking carpool lane! Reboot did nothing. I had to walk away from the car (lock it with the fob), and return to the car to get it to go into Drive.

    Making it even more stressful, I did not have my phone with me so I couldn't call Tesla support. I have issued a support ticket.
     

Share This Page

  • About Us

    Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.
  • Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


    SUPPORT TMC