Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register
  • TMC Podcast #11 will stream live Saturday at 1PM PDT. We will be joined by special guest JT Stukes, a former engineer at Tesla. You can watch it live and participate in the chat on YouTube. We will addressing viewer comments and questions. For more information, follow the TMC Podcast #11 thread.

App takes forever to connect to car

MY is parked in an area with great LTE. I opened the app to see where it is in relation to me, and I have been waiting for the app to display the current status of the car for the last 5 minutes and I still only have the progress bar. Same thing happened this morning in my garage, but I chalked it up to the spotty WiFi connection that gets disconnected at times and the car goes to a mobile network with only EDGE...

This makes things like Summon, or trying to turn on the AC when you are a few minutes of walk away from the car, no fun at all, it kind of defeats the purpose of any remote function. This morning I just got into the car and drove it out of my (quite tight) garage because I got fed up waiting for it to connect so I could use Summon.

Does anyone have the same issue? Any idea why it is happening, ESPECIALLY when the car is in an area of perfect LTE coverage?
 
MY is parked in an area with great LTE. I opened the app to see where it is in relation to me, and I have been waiting for the app to display the current status of the car for the last 5 minutes and I still only have the progress bar. Same thing happened this morning in my garage, but I chalked it up to the spotty WiFi connection that gets disconnected at times and the car goes to a mobile network with only EDGE...

This makes things like Summon, or trying to turn on the AC when you are a few minutes of walk away from the car, no fun at all, it kind of defeats the purpose of any remote function. This morning I just got into the car and drove it out of my (quite tight) garage because I got fed up waiting for it to connect so I could use Summon.

Does anyone have the same issue? Any idea why it is happening, ESPECIALLY when the car is in an area of perfect LTE coverage?
Mine seems to take 3 -5 min to connect now with the updated app, no matter if the car is only on LTE or connected to my wifi.
 
  • Like
Reactions: Donncha
Funny, I've got the same problem. My MY takes forever to wake up, and when it does, it disconnects almost immediately (ie: I wait for the car to wake up (a few mins), turn on HVAC, walk to the car, the app gives me error 404... I wait again, and then unlock). I"m waiting patiently on chat support to see what they can do. Will keep you posted.
 
MY is parked in an area with great LTE. I opened the app to see where it is in relation to me, and I have been waiting for the app to display the current status of the car for the last 5 minutes and I still only have the progress bar. Same thing happened this morning in my garage, but I chalked it up to the spotty WiFi connection that gets disconnected at times and the car goes to a mobile network with only EDGE...

This makes things like Summon, or trying to turn on the AC when you are a few minutes of walk away from the car, no fun at all, it kind of defeats the purpose of any remote function. This morning I just got into the car and drove it out of my (quite tight) garage because I got fed up waiting for it to connect so I could use Summon.

Does anyone have the same issue? Any idea why it is happening, ESPECIALLY when the car is in an area of perfect LTE coverage?

This is a new problem with the updated phone app. I used to get almost instant connection, now it seems like it takes forever. With the old version of the phone app I used to start walking too my car after work, pull out the phone and fire up the Air Conditioning. Now with the new phone app by the time it becomes useable I am standing next to the car :(

Keith
 
  • Like
Reactions: frankvb
I’ve been having similar issues with both the Tesla app and Stats app, which makes me wonder if something has changed on the backend coincident with the updated app. Our MY was delivered after the updated app was released so unfortunately I don’t have a comparator. I’m also not a developer, IT pro, or software engineer of any kind, so my thoughts are pure armchair-quarterback speculation.
 
Funny, I've got the same problem. My MY takes forever to wake up, and when it does, it disconnects almost immediately (ie: I wait for the car to wake up (a few mins), turn on HVAC, walk to the car, the app gives me error 404... I wait again, and then unlock). I"m waiting patiently on chat support to see what they can do. Will keep you posted.
That's disappointing... 404 is basically "page not found" - that sounds like an internet error.

Recently I had a 502 error (first time since I've had the car, which is about 3 weeks). A 502 is a bad gateway. Seems like there have been some connectivity problems lately.

I wonder if the connection from app to car goes through a server that is overloaded or has some other issues.
 
I’ve been having similar issues with both the Tesla app and Stats app, which makes me wonder if something has changed on the backend coincident with the updated app. Our MY was delivered after the updated app was released so unfortunately I don’t have a comparator. I’m also not a developer, IT pro, or software engineer of any kind, so my thoughts are pure armchair-quarterback speculation.
For me, the connection problems started BEFORE I upgraded the app (I just upgrade today but I have been having connectivity issues well before the upgrade". This seems to indicate that the connection issue is probably not related to the new version of the app, it is probably only time coincident with it.
 
  • Like
Reactions: Donncha and E30-4ME
That's disappointing... 404 is basically "page not found" - that sounds like an internet error.

Recently I had a 502 error (first time since I've had the car, which is about 3 weeks). A 502 is a bad gateway. Seems like there have been some connectivity problems lately.

I wonder if the connection from app to car goes through a server that is overloaded or has some other issues.
Not sure. I did spend some time with the Tesla chat support folks. They also saw the same thing from their side but couldn’t find anything server side. Wifi was at 4 bars so connectivity wasn’t an issue. It’s also on a dedicated guest network. They recommended I quote the case # and get a service appointment scheduled to look at things car side.

It’s crazy. I’ll open the app, unlock the doors, and then literally 3 seconds later, by the time I try to click on climate, I get 404 and have to wait 2-3 mins for another connection.

I‘ll keep you posted on progress.
 
Not sure. I did spend some time with the Tesla chat support folks. They also saw the same thing from their side but couldn’t find anything server side. Wifi was at 4 bars so connectivity wasn’t an issue. It’s also on a dedicated guest network. They recommended I quote the case # and get a service appointment scheduled to look at things car side.

It’s crazy. I’ll open the app, unlock the doors, and then literally 3 seconds later, by the time I try to click on climate, I get 404 and have to wait 2-3 mins for another connection.

I‘ll keep you posted on progress.
Yeah, that does sound bad. I have never seen a 404 error and it sure doesn't sound right.
 
  • Like
Reactions: David1oh
Same problem with the new Tesla app and M3. As a retired ICT professional, the issue is clearly with Tesla. It looks like they might have changed the app's method of access so that it now connects and logs into a website. Hence the 404s when the app can't initially find the web page.

The whole logon and data retrieval process seems to add significantly to the time taken to access the M3. There also seems to be an issue with the new app itself in that it doesn't maintain its Bluetooth service in the way that the old app did. So whereas I could walk up to the car and tug on a handle to open the car, I now have to explicitly open the app on my phone for the car to respond. Really really annoying.

Tesla seem to be going backwards rather than forwards with this new app.
 
  • Like
Reactions: Deutsch100
Having the same issues as @David1oh here. Both my app and my wife’s, 404s nearly every time. Subscribing to see what happens, I have a service appointment tomorrow and will add it to my list of questions. Will share anything that seems valuable.
How did the service appointment go? Mine is this coming Friday so will see what happens. My MY was updated from 2021.11.102 to 2021.32.21. Hoping it might make a difference but no joy.
 
How did the service appointment go? Mine is this coming Friday so will see what happens. My MY was updated from 2021.11.102 to 2021.32.21. Hoping it might make a difference but no joy.
Still in service :(. Minor imperfection in the fender that needs bodywork to fix.

I did notice that mine updated to 2021.32.21 while in service, but the app doesn't seem to have improved (even though it's in service, there's still a 404 error showing that goes away after a minute or so once it connects).
 
  • Like
Reactions: David1oh

TomServo

Active Member
Apr 10, 2014
2,053
1,430
Belleville IL
It’s frustrating to approach my Y, open the door and then get in the car, fasten my seatbelt and then still wait for the lcd to come on so I can tap the brake pedal and shift into gear.

Often I have counted past 5 seconds after I get in the car. I know it’s a first world problem, but I recall when I first got the car I could open the drivers door and the AC, radio and LCD screen would turn on before I could get seated. It has to be software related.
 

Cigar Man

Intriguing Human
Jul 23, 2020
136
114
McAllen, Texas
Okay - this is getting worse. My phone will not connect at all. It won't even display on my Android phone.

I updated, and it changed nothing. The app still will not open.

So, I uninstalled, reinstalled and it still will not open. It just sits there and spins.

All of which means my phone is no longer my key - and I can't open up the app to set it up as a key.

Any ideas, folks?
 

Products we're discussing on TMC...

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top