TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker and becoming a Supporting Member. For more info: Support TMC

Dead AP, ACC, Lights... thoughts?

Discussion in 'Model S' started by arlorose, Jul 13, 2017.

  1. arlorose

    arlorose Member

    Joined:
    Mar 5, 2017
    Messages:
    13
    Location:
    California
    Had my S90D in for a persistent driver's side rattle, and came back with:

    1) Inability to do an OTA update (has failed 5x)
    2) Cruise control won't engage
    3) Lanes don't show up on console
    4) AP (obviously) won't engage
    5) Lights stay on (don't detect day or night, but interior UI knows it's day)

    Pretty crazy... and I'm not posting here to complain... just curious if anyone has seen this set of stuff and might know what's up.

    I'll know more in the AM.
     
  2. Akikiki

    Akikiki A'-Lo-HA ! y'all

    Joined:
    Nov 26, 2012
    Messages:
    2,219
    Location:
    Kaneohe
    Our thoughts? You were wise to take it to the experts.
     
  3. Dborn

    Dborn Confirmed

    Joined:
    Aug 26, 2011
    Messages:
    2,316
    Location:
    Sydney, Australia
    The experts for sure. Checked the fuses? Maybe check the manual and see if there is any correlation between fuses and your issues.
    It may be that they disconnected something or dislodged something in the process of tracking down your rattle. Either way, they are going to need to fix t!!
     
    • Helpful x 1
  4. arlorose

    arlorose Member

    Joined:
    Mar 5, 2017
    Messages:
    13
    Location:
    California
    Oh, I'm sure they disconnected something. This was more about seeing if anyone had that "I had that happen once, they said a cable came detached from the front camera rig."

    Curiosity, not trying to troubleshoot. :)

    The only info that I've found interesting (so far) is that they said the software updates fail if there's a hardware issue. Seems to me like if there's a hardware issue that would cause that, they'd do some sort of "Update failed, schedule a service appointment" message rather than the "We'll download it again and try later." message.
     
  5. MP3Mike

    MP3Mike Active Member

    Joined:
    Feb 1, 2016
    Messages:
    3,385
    Location:
    Oregon
    My guess is they failed to reconnect the B pillar camera. (A number of people have reported that the B pillar camera cables/connectors are causing rattling issues.)
     
  6. JasJ

    JasJ Member

    Joined:
    Jan 26, 2017
    Messages:
    213
    Location:
    Houston, TX
    I was one of the b-pillar rattles fixed by the SC earlier in the week... this morning the car was dead and did not charge over night. Did the steering wheel reset that brought it back to life - 30 minutes later, a software update showed up (first in 2 months).

    How does one tell if the camera is connected as they messed with the camera cable?
     
  7. Dborn

    Dborn Confirmed

    Joined:
    Aug 26, 2011
    Messages:
    2,316
    Location:
    Sydney, Australia
    Is that camera even activated yet? When I got my car, the blind spot ultrasonic sensors were not activated. That came later via software update. I wonder whether the system knew it was there during that time.
     
  8. MP3Mike

    MP3Mike Active Member

    Joined:
    Feb 1, 2016
    Messages:
    3,385
    Location:
    Oregon
    Active? Yes. In use by EAP for driving? No. (It is currently used to capture stills/video that are sent back to Tesla for analysis.)
     
  9. arlorose

    arlorose Member

    Joined:
    Mar 5, 2017
    Messages:
    13
    Location:
    California
    It was just an unplugged cable, but the car came back with a funky scratch on the front bumper, and a bunch of marks on the dash's wood... so for the 8th time, it'll be going back.

    I love this car, but the service is so mediocre (even though they're all ex-BMW folks at my SC).

    Ah well.
     
  10. Dborn

    Dborn Confirmed

    Joined:
    Aug 26, 2011
    Messages:
    2,316
    Location:
    Sydney, Australia
    Ah hah! So I was right!
     

Share This Page