TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker and becoming a Supporting Member. For more info: Support TMC

Figured out Pixel 2 Bluetooth constantly disconnecting issue

Discussion in 'Model X' started by Jimmy T, Aug 18, 2018.

  1. Jimmy T

    Jimmy T Member

    Joined:
    Jun 13, 2018
    Messages:
    13
    Location:
    Bellerose
    Got my model X last week and I'm loving it, it's an amazing car. My Pixel 2 has the Pie OS.

    One major problem that I've had since I got the car was my Pixel 2 Bluetooth kept on disconnecting and reconnecting every 30 seconds or so without fail. It would get in contact and then disconnect and then connect and disconnect. Not being able to make phone calls while I'm driving was a real annoyance.

    I tried to restart my phone, I tried to reset the car, I enabled developer options in my settings and tried different versions of Bluetooth. Nothing worked.

    I tried the process of elimination and started turning off different options within the Bluetooth settings.

    I realize that if I kept the phone call only and turned off the audio/media, plus HD audio, plus phone book syncing, the Bluetooth problem goes away and the phone stays connected!

    I know it's not ideal especially with the contact not being synced but at least I can make phone calls while I'm driving plus using the OK Google command on my phone helps make the calls hands free.

    Give it a shot and let me know if that works!
     
    • Helpful x 1
  2. Jimmy T

    Jimmy T Member

    Joined:
    Jun 13, 2018
    Messages:
    13
    Location:
    Bellerose
    Adding a picture of the settings. The HD audio comes up if I had emailed media audio.
     

    Attached Files:

  3. XHabjab

    XHabjab Helping to end the ICE Age

    Joined:
    Feb 25, 2018
    Messages:
    121
    Location:
    Georgetown TX
    The way that I read this is that you don't have it figured out but have a poor man's workaround by disabling some fundamental features.

    I have the same problem on my Samsung (Android) phone. Same workaround.

    I see a lot of fuss on various forums (including Tesla's) about problems with iPhones, but my wife's iPhone works fine on our X and it is my Android with the problem you seem to be describing.
     
  4. Jimmy T

    Jimmy T Member

    Joined:
    Jun 13, 2018
    Messages:
    13
    Location:
    Bellerose
    Yes, the poor man's workaround is right. The other stuff is nice but the simple act of making and taking calls was the important part. Agreed it would be better if the others worked as well.

    I googled solutions many times but never came across this fix, so thought I would share it for the next person.

    Also side note, same here, my wife's iPhone 8 works with no issue. Which is annoying !
     
  5. hly

    hly Member

    Joined:
    Jan 31, 2015
    Messages:
    179
    Location:
    NJ
    Just another data point: I also have the Pixel 2 XL with Pie and I don't have any issues with Bluetooth connections with all the settings enabled: Phone calls, Media audio, HD audio, Contact sharing
     
    • Like x 1
  6. Jimmy T

    Jimmy T Member

    Joined:
    Jun 13, 2018
    Messages:
    13
    Location:
    Bellerose
    That's so weird... Did you do anything special or it just worked?
     
  7. CuriousG

    CuriousG Active Member

    Joined:
    Dec 1, 2015
    Messages:
    1,297
    Location:
    Elk Grove, CA
    Try checking your contacts on your phone and make sure there aren't symbols in any of your contacts [e.g. &#()@]. This fixed the issue for me on a Model 3 that didn't have this issue on my older Model S. Perhaps the newer CID share some same code for contacts? Dashes or hyphens work fine for me.
     
    • Helpful x 1
    • Informative x 1
  8. Jimmy T

    Jimmy T Member

    Joined:
    Jun 13, 2018
    Messages:
    13
    Location:
    Bellerose
    You are amazing. That was exactly it! Went through all the contacts via Google contacts webpage on my laptop and cleared at my special characters. Connected without issue!!

    Thank you very much!
     
    • Helpful x 1
  9. CuriousG

    CuriousG Active Member

    Joined:
    Dec 1, 2015
    Messages:
    1,297
    Location:
    Elk Grove, CA
    I can't take credit for it but only found the solution myself recently through a reddit post. I can only hope to have this spread more frequently as it took me over 6mos to resolve this issue myself.
     
    • Helpful x 1
    • Like x 1
  10. mxnym

    mxnym Member

    Joined:
    Mar 9, 2018
    Messages:
    197
    Location:
    Bloomington, IN
    This solved issue for OP, but I wanted to point out that when I the same problem cropped up with my Nexus 6P running Oreo (that had previously already been connected to my X and working fine), I just deleted and re-added the phone to resolve the issue.
     
  11. dethman

    dethman Member

    Joined:
    Apr 19, 2018
    Messages:
    365
    Location:
    socal
    I have this same problem with a note 8. I tried disabling the other stuff like you tried but it still disconnects evry 20 seconds or so. Tesla service has no clue and says it's a 'known bug.'

    Phone worked with loaner no problems and a second phone works with my X no problem.
     
  12. Anzir

    Anzir Supporting Member

    Joined:
    Nov 9, 2012
    Messages:
    510
    Location:
    Central Florida
    #12 Anzir, Aug 20, 2018
    Last edited: Aug 20, 2018
    I also have a Note 8 with no problems on my X (knock on wood). Try the contact list edit if you haven't. Although I don't understand why it wouldn't work otherwise.
     
  13. Jimmy T

    Jimmy T Member

    Joined:
    Jun 13, 2018
    Messages:
    13
    Location:
    Bellerose
    That stinks. Did you try the cleaning up of the contacts fix?
     
  14. dethman

    dethman Member

    Joined:
    Apr 19, 2018
    Messages:
    365
    Location:
    socal
    tried cleaning up the contacts, took out all the special characters and it still disconnects. SUPER annoying.
     
  15. CuriousG

    CuriousG Active Member

    Joined:
    Dec 1, 2015
    Messages:
    1,297
    Location:
    Elk Grove, CA
    I don't know if the X has a sync contacts option (I don't recall seeing it on the S) like the 3, but try turning that off and see if it stays connected. If the option isn't available from the car, do it from the phone. At least you can rule out whether contacts is the issue. I ran without contacts for 6 mos due to it constantly disconnecting. Every now and then the contacts option was set to sync again even though I specifically told it not to.
     
  16. Mjølner

    Mjølner Member

    Joined:
    Aug 26, 2015
    Messages:
    133
    Location:
    Midgard (Norway)
    Same problem with Galaxy Note 9.
    Will try the "clean contacts" tip tomorrow.
     
  17. turtlesz

    turtlesz Member

    Joined:
    Aug 7, 2017
    Messages:
    132
    Location:
    Southern California
    I had issues before Android Pie on my Pixel 2 XL, but since the update it's worked 100% of the time. I just turned off battery optimization for the Tesla app, not sure if that makes a difference or not.
     
    • Helpful x 1
  18. Mjølner

    Mjølner Member

    Joined:
    Aug 26, 2015
    Messages:
    133
    Location:
    Midgard (Norway)
    DId not help for me. Problem still there:(
     
  19. ScoutHC

    ScoutHC New Member

    Joined:
    Yesterday
    Messages:
    1
    Location:
    Phoenix, AZ
    Thank you. After months of doing eveything I could find online to fix my bluetooth issues with my android and my Tesla model 3 this fixed it. I removed all special characters from my contacts and my bluetooth is FINALLY working after 4 months of frusteration.
     
    • Like x 1

Share This Page

  • About Us

    Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.
  • Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


    SUPPORT TMC