TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker and becoming a Supporting Member. For more info: Support TMC

Front left safety restraint system fault

Discussion in 'Canada' started by Techniques, Dec 24, 2019.

  1. Techniques

    Techniques Member

    Joined:
    Jul 4, 2018
    Messages:
    512
    Location:
    Richmond Hill
    Wanted to share this error with you all. Been getting a “Front left safety restraint system fault” message recently.
    Have many of you beeb seeing this lately? If so, what did Tesla do to repair? I was told by a mobile ranger it is a wiring harness, but have also seen online some have had their driver/passenger replaced because of it.

    My build is of Aug 2018.

    Happy holidays everyone!
     

    Attached Files:

  2. martind3

    martind3 Member

    Joined:
    May 14, 2019
    Messages:
    175
    Location:
    Ottawa
    SR+, July 2019 build. Tesla is replacing my entire passenger seat. In my case it's apparently the weight sensor and seat heaters conflicting. Seat is on order.
     
    • Informative x 1
  3. Techniques

    Techniques Member

    Joined:
    Jul 4, 2018
    Messages:
    512
    Location:
    Richmond Hill
    Thanks for the info. I wonder if that’s why they delayed my service appointment because service mentioned that the part was on backorder. Chance I’m getting a new seat, guess we’ll see.
     
  4. MexiCanuck

    MexiCanuck Member

    Joined:
    May 7, 2019
    Messages:
    448
    Location:
    Vancouver Island
    I hope I never have to have the driver/passenger replaced in my Tesla.

    Well, sometimes I might be OK with having just the passenger replaced.

    :)
     
    • Funny x 4
  5. mrat-X+3

    mrat-X+3 New Member

    Joined:
    Jan 20, 2020
    Messages:
    1
    Location:
    Los Angele
    I get the same fault on my X. Service center took it in 2 times only to tell us there's no problem and a firmware update SHOULD fix it. Said firmware may be coming sometime in the future. They gave me some BS excuse that the new seats in the Dec builds are causing issues in the X and the engineers are working on it. Scheduled with mobile service this weekend to see if the 3rd time is the charm. If not...
     
  6. 5_+JqckQttqck

    5_+JqckQttqck Active Member

    Joined:
    Apr 27, 2018
    Messages:
    1,851
    Location:
    Toronto
    I had the passenger side blip up for a weekend. I checked and wiggled it and it went away. They may have replaced it on one of the SC visits. It's a faulty sensor I believe (loose wire).
     
  7. GtiMart

    GtiMart Member

    Joined:
    Nov 13, 2019
    Messages:
    357
    Location:
    Quebec City, Canada
    I got this error for like 10 seconds after getting my car back from getting a ppf done.stayed in a humid garage for the whole day. I can't think of another reason. Never came back. I'm assuming it's in the logs. Next time it happens I'll report it...
     
  8. Techniques

    Techniques Member

    Joined:
    Jul 4, 2018
    Messages:
    512
    Location:
    Richmond Hill
    I had a wiring harness and connector replaced by the SC. Error has not appeared since. They told me it was an over tight connection to the sensor that over time loosens and throws up the error. The new harness allows more play for the sensor cable.
     
    • Like x 1
  9. Jeycue

    Jeycue New Member

    Joined:
    Mar 3, 2020
    Messages:
    1
    Location:
    FONTANA, CA
    Had the same error in my M3. Tesla Mobile Service replaced OCR Harness Kit twice. Once in December and last one was last Sunday, March 1st. Error popped out again yesterday. I don't know what is the issue behind it now. Setup another appointment at Inland Empire TSC ( Rancho Cucamonga, CA ) on next week and hoping they will be able to find out the real solution to it. Will keep you posted.
     
    • Informative x 1
  10. GtiMart

    GtiMart Member

    Joined:
    Nov 13, 2019
    Messages:
    357
    Location:
    Quebec City, Canada
    Update: had the error again but passenger side a week pr two ago. Service came and replugged the wiring harness under the passenger seat. That's all there was to it. Just a bad connection from the assembly line... I have a 2020 that was delivered in December 2019. Hope this helps!
     
    • Informative x 2

Share This Page

  • About Us

    Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.
  • Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


    SUPPORT TMC