Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register

GPS issue since the past few weeks

Hello
I have a 2018 TM3 LR with no issues with GPS until a few weeks ago, at most, a month.
This happens intermittently, but regularly if that makes sense. It happens at least a couple of times daily when driving where it shows the car's current location off by anywhere between 50-500 ft or so.

2 scenarios:
1) When I am actually on a highway, the red arrow shows I am on the service/access/feeder road of the highway instead.
2) Sometimes, when I am on a city street heading northbound, red arrows would show on the same city, but on the other side (left) of the road, so it shows the red arrow moving against the flow of traffic!

This causes issues with navigation where it constantly asks me to merge onto the highway (scenario 1) or it asks me to take the next right and then left onto the city street I am already on. This is annoying and distracting...especially on the highway. More alarmingly and dangerous, on the highway, it would suddenly start braking since it thinks I am on the feeder road where the speed limit is obviously lower.

I have seen other posts where the more common issue with the GPS was that it was frozen in a particular location.
I did see a similar post that talks about the same issue I have been having:

Now, I have gone to Service and they have tried to tell me that the signal is being blocked by my windshield tint (which I doubt). They nevertheless replaced the GPS antenna but I still have the same issue.
I have scheduled another service apt, but should I push for them to look at the gyro/accelerometer?

Changes that have been made to the car this year: New windshield tint + sunroof tint. I can't imagine tint causing this issue, these are not some old-style metallic tints, these are top of the line ceramic tint from a very reputed tint installer that has done thousands of Tesla tints.

Has anyone had this exact issue and gotten a resolution/found the cause?

One day last week, for the whole day, I kept getting messages on the screen: 'Autosteer not available', 'Cruise Control not available', 'Automatic Emergency Braking not available', but they fixed themselves the next day. Not sure if these were/are related to the GPS issue which still happens daily.

Oh and I have already tried soft reboot a couple of times to no avail.
TIA
KG
 
Same problem with no tint or any upgrade. It is really annoying to have this simple problem.... I never had this problem in my BMW ever. I started experiencing after some software updates but it is particularly dangerous in autopilot when going over a junction because it picks up the speed limits of the nearby roads.
 
Same problem with no tint or any upgrade. It is really annoying to have this simple problem.... I never had this problem in my BMW ever. I started experiencing after some software updates but it is particularly dangerous in autopilot when going over a junction because it picks up the speed limits of the nearby roads.
I have a model 3 LR 2022, brand new.
 

Products we're discussing on TMC...

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top