Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register

Phone key working less often

PatinCT

Member
Mar 24, 2020
147
80
CT
Recent development... phone working less often as a key (have already deleted and re-added). Samsung S22... I'll unlock the car from the app and then have to hit "start" (because I don't feel like pulling out my key). Has been working with no problems up until recently. Any suggestion?
 
  • Like
Reactions: jsight
My guess is the phone is turning off enough stuff to keep the Tesla app from connecting with the car via Bluetooth. Last summer (2021) I posted instructions on how to fix this but almost all of them no longer apply due to changes in Android. The only one that is still applicable is to disable "put unused apps to sleep".

OTOH, I don't have this disabled and my phone usually works as a key. I'd say it works over 90% of the time.
 
This has been my experience as long as I've owned this car (several weeks now). I've tried rebooting phone, rebooting car, reinstalling app, resetting phone as key, restarting bluetooth, keeping phone app in foreground and connecting to car before I go out, keeping app from sleeping, taken the car to service. Nothing has worked so far. I'm at the point I might ask service to install a fob for me just so I can get in and start the car.
 
Same issue here, just began doing this.
Galaxy S22 Ultra, 2021 Y LR latest updates.
Today each time I returned from a store or business while out running errands and shopping I had to get my card out of my pocket and not only place it against the pillar to get in, but put it on the center console to start. I also had to reconnect my phone via BT each time.
I did the 2 thumbs reboot on the steering wheel (didn't help), and also the "power off" selection on the safety menu, no help either.
 

JHCCAZ

Electrified Engineer
Supporting Member
Feb 2, 2021
809
1,562
Tucson
Mine seems to have stopped completely now - for driving that is, I think I can still use the phone to get into the car

And this while I'm looking at the phone running the app
I went through the same thing with the app permissions, after having similar problems occasionally for the last couple of months.

I had one incident after the update and permissions setting, but it usually works like it did before. Galaxy Fold 4.

A friend of mine has had a lot more trouble and continues to have trouble after the app update. Android but I'm not sure what phone. It seems that the fundamental problem has not been fixed.
 

DanDi58

Active Member
Jun 22, 2020
2,566
2,073
Dayton NJ
Ditto - it seems the last week or 10 days, it is more often than not that I have to dig out my phone and actually open the app for it to unlock (I always have the app running in the background on the phone). I'm going to try disconnecting and reconnecting the phone shortly and see what happens. It's pretty irritating. Must be related to a recent update as I never had this issue in almost 2 years of ownership.
 
I just wanted to provide a quick update. I am running a FOLD3 and Android 13.
I took the advice on a thread (can't remember which one since there are many on this subject), but I deleted the Telsa App and found an earlier version APK (Nov 22) and installed it. I deleted devices on both the Fold3 and the Tesla and restarted both. I was able to pair the Fold3 as a phone key again after a few tries. After a few drives not bringing my fob, it seems to be working again to allow the car to shift into drive. No telling how long it will last but it at least is paired and is working at the moment. Hopefully this helps some others. I thought it was an Android 13 issues since the forced update but by installing an older Telsa app version, it is back to working which seems to indicate an issue with Telsa's app. I dunno anymore.
 

DanDi58

Active Member
Jun 22, 2020
2,566
2,073
Dayton NJ
I just deleted and re-added my phone so we'll see if it makes a difference. But I also noticed that if you have the Driver Door Unlock Mode on (like I did) that only unlocks the driver's door when you approach. I know a couple of times when I was trying to get into the car, it was through a rear door (to put something in the back seat) so at least some of the time, I was unable to access the car simply because I wasn't trying the driver's door first. I've now shut that setting off.
 

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top